New USB Raise Port Limit Patch for High Sierra

Discussion in 'High Sierra Desktop Support' started by tonymacx86, Jun 30, 2017.

  1. davelaw56

    davelaw56

    Joined:
    Mar 29, 2013
    Messages:
    169
    Mobo:
    Gigabyte GA-Z87X OC
    CPU:
    Intel Core i7 4790K
    Graphics:
    2X REFERENCE NVIDIA GTX 980
    Mac:
    MacBook Pro
    Mobile Phone:
    iOS
    Sep 30, 2017 at 10:27 AM #21
    davelaw56

    davelaw56

    Joined:
    Mar 29, 2013
    Messages:
    169
    Mobo:
    Gigabyte GA-Z87X OC
    CPU:
    Intel Core i7 4790K
    Graphics:
    2X REFERENCE NVIDIA GTX 980
    Mac:
    MacBook Pro
    Mobile Phone:
    iOS
    it is working for me. just simple as hitting the + copy and paste in kernel kext and patches section in clover configurator install the kext in efi/clover/kext and in library extension with kextbeast:headbang:
     
  2. kiu77

    kiu77

    Joined:
    Jun 21, 2010
    Messages:
    202
    Mobo:
    Gigabyte GA-Z170-HD3P F21 / Clover / 10.13
    CPU:
    i7-6700K @ 4.4GHz
    Graphics:
    Gigabyte GTX1050 OC w. 2GB GDDR5
    Mac:
    MacBook Pro
    Mobile Phone:
    iOS
    Sep 30, 2017 at 7:21 PM #22
    kiu77

    kiu77

    Joined:
    Jun 21, 2010
    Messages:
    202
    Mobo:
    Gigabyte GA-Z170-HD3P F21 / Clover / 10.13
    CPU:
    i7-6700K @ 4.4GHz
    Graphics:
    Gigabyte GTX1050 OC w. 2GB GDDR5
    Mac:
    MacBook Pro
    Mobile Phone:
    iOS
    Upgrade to HS worked after using audio_cloverALC-130_v0.3.command,
    but gave me two dead USB 3.0 ports.
    I fixed this with the patch from this thread and USB ist working now.

    But reproduceably there remains a problem with sleep.
    If I set the system into sleep mode and wake it up (via key press)
    system comes back bat all (really all) USB ports are dead. They have
    power but neither corded keyboard nor a mouse (or an USB stick)
    is recognized or working.
    Where should I look first?

    (Clover newest version, kexts as shown in screenshot)

    Attached is a list of patched kexts too - 3 times AppleHDA - okay?
     

    Attached Files:

    • Bildschirmfoto 2017-09-30 um 20.04.19.jpg  (39.5 KB, 207 views)
    • Bildschirmfoto 2017-09-30 um 20.09.41.jpg  (57 KB, 208 views)
  3. 7sudden

    7sudden

    Joined:
    Jun 27, 2015
    Messages:
    24
    Mobo:
    Gigabyte Z270X Gaming 5
    CPU:
    i7-7700K
    Graphics:
    XFX RX580
    Sep 30, 2017 at 11:35 PM #23
    7sudden

    7sudden

    Joined:
    Jun 27, 2015
    Messages:
    24
    Mobo:
    Gigabyte Z270X Gaming 5
    CPU:
    i7-7700K
    Graphics:
    XFX RX580
    Anyone know of a patch for 200 series boards?
     
  4. RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    160,470
    Mobo:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Sep 30, 2017 at 11:37 PM #24
    RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    160,470
    Mobo:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    The port limit patch is not specific to chipset.
     
  5. cretans

    cretans

    Joined:
    May 10, 2013
    Messages:
    26
    Mobo:
    GA-Z170X-Gaming 3
    CPU:
    i5 6600K
    Graphics:
    Powercolor R9 280X
    Mac:
    iMac
    Mobile Phone:
    iOS
    Oct 1, 2017 at 8:18 AM #25
    cretans

    cretans

    Joined:
    May 10, 2013
    Messages:
    26
    Mobo:
    GA-Z170X-Gaming 3
    CPU:
    i5 6600K
    Graphics:
    Powercolor R9 280X
    Mac:
    iMac
    Mobile Phone:
    iOS
  6. subte

    subte

    Joined:
    Jun 15, 2016
    Messages:
    5
    Mobo:
    Gigabyte Z170X-Gaming 5
    CPU:
    i7 6700K Skylake, 4.1 GHz
    Graphics:
    Nvidia GTX 950
    Oct 3, 2017 at 7:08 PM #26
    subte

    subte

    Joined:
    Jun 15, 2016
    Messages:
    5
    Mobo:
    Gigabyte Z170X-Gaming 5
    CPU:
    i7 6700K Skylake, 4.1 GHz
    Graphics:
    Nvidia GTX 950
    Working here, thanks!
     
  7. S3Atze

    S3Atze

    Joined:
    Aug 17, 2010
    Messages:
    28
    Mobo:
    Gigabyte Z97X-UD5H
    CPU:
    Core i7 4790K
    Graphics:
    NVIDIA GeForce GTX 980
    Mac:
    MacBook Pro
    Mobile Phone:
    iOS
    Oct 8, 2017 at 4:07 PM #27
    S3Atze

    S3Atze

    Joined:
    Aug 17, 2010
    Messages:
    28
    Mobo:
    Gigabyte Z97X-UD5H
    CPU:
    Core i7 4790K
    Graphics:
    NVIDIA GeForce GTX 980
    Mac:
    MacBook Pro
    Mobile Phone:
    iOS
    No USB 3 device is working on my system under 10.13. Under 10.12 no problems at all.

    I tried the USBInjectAll.kext, but no luck... This is frustrating me :sick:

    Is there any easier way than creating an SSDT to get USB3 devices to work again?
     
  8. abhinasia

    abhinasia

    Joined:
    May 5, 2012
    Messages:
    87
    Mobo:
    Biostar TZ77XE4
    CPU:
    I7 3770K
    Graphics:
    H4000
    Mac:
    MacBook Pro
    Classic Mac:
    Apple
    Mobile Phone:
    Android
    Oct 9, 2017 at 2:13 PM #28
    abhinasia

    abhinasia

    Joined:
    May 5, 2012
    Messages:
    87
    Mobo:
    Biostar TZ77XE4
    CPU:
    I7 3770K
    Graphics:
    H4000
    Mac:
    MacBook Pro
    Classic Mac:
    Apple
    Mobile Phone:
    Android
    Before me, also same. After reading guide, I come to know how it works. Not so frustrating.
     
  9. codyl1992

    codyl1992

    Joined:
    Jan 31, 2017
    Messages:
    4
    Mobo:
    Gigabyte H170N Wifi
    CPU:
    Intel i5 6500
    Graphics:
    Asus 1050 TI
    Oct 11, 2017 at 10:23 PM #29
    codyl1992

    codyl1992

    Joined:
    Jan 31, 2017
    Messages:
    4
    Mobo:
    Gigabyte H170N Wifi
    CPU:
    Intel i5 6500
    Graphics:
    Asus 1050 TI
    Thanks! I couldn't figure it out. But I had an existing line in my Clover Configurator from a MultiBeast install, and I just changed the keys to what you had and it worked.
     
  10. Robvas

    Robvas

    Joined:
    Sep 17, 2017
    Messages:
    19
    Mobo:
    Gigabyte Z270X- Gaming 5
    CPU:
    Intel i7700
    Graphics:
    Radeon RX Vega 64 8GB
    Oct 18, 2017 at 3:52 AM #30
    Robvas

    Robvas

    Joined:
    Sep 17, 2017
    Messages:
    19
    Mobo:
    Gigabyte Z270X- Gaming 5
    CPU:
    Intel i7700
    Graphics:
    Radeon RX Vega 64 8GB
    Can you lead me through it. I use Clover Configurator as well, but little bit lost here. I also have lagging mouse issue, and, if I connect more than 1, external driver lags so much more.

    edited,
    Looks like my settings are same as posted in 1st post. But lagging mouse is still there.

    Thx
     
    Last edited: Oct 18, 2017 at 3:57 AM

Share This Page