Contribute
Register

New USB Raise Port Limit Patch for High Sierra

Joined
May 10, 2013
Messages
37
Motherboard
GA-Z390 gaming X
CPU
i5 9600K
Graphics
MSI ARMOR RX580
Mac
  1. iMac
Mobile Phone
  1. iOS
Joined
Jun 15, 2016
Messages
9
Motherboard
Gigabyte Z170X-Gaming 5
CPU
i7-6700K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Working here, thanks!
 
Joined
Aug 17, 2010
Messages
39
Motherboard
Asus Prime Z390-A
CPU
i9-9900K
Graphics
UHD 630
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. iOS
No USB 3 device is working on my system under 10.13. Under 10.12 no problems at all.

I tried the USBInjectAll.kext, but no luck... This is frustrating me :sick:

Is there any easier way than creating an SSDT to get USB3 devices to work again?
 
Joined
May 5, 2012
Messages
113
Motherboard
Biostar TZ77XE4 With Fenvi T919 1750Mbps PCIe Desktop Wifi Card BCM94360CD
CPU
i7-3770K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Classic Mac
  1. Apple
Mobile Phone
  1. Android
No USB 3 device is working on my system under 10.13. Under 10.12 no problems at all.

I tried the USBInjectAll.kext, but no luck... This is frustrating me :sick:

Is there any easier way than creating an SSDT to get USB3 devices to work again?

Before me, also same. After reading guide, I come to know how it works. Not so frustrating.
 
Joined
Jan 31, 2017
Messages
4
Motherboard
Gigabyte H170N Wifi
CPU
Intel i5 6500
Graphics
Asus 1050 TI
Thanks! I couldn't figure it out. But I had an existing line in my Clover Configurator from a MultiBeast install, and I just changed the keys to what you had and it worked.
 
Joined
Sep 17, 2017
Messages
66
Motherboard
Gigabyte Z270X- Gaming 5
CPU
i7-i7700
Graphics
RX Vega 64
Mac
  1. iMac
Fantastic. Worked like a charm. Used Clover Configurator and restarted the machine. All good. Thanks!

Can you lead me through it. I use Clover Configurator as well, but little bit lost here. I also have lagging mouse issue, and, if I connect more than 1, external driver lags so much more.

edited,
Looks like my settings are same as posted in 1st post. But lagging mouse is still there.

Thx
 
Last edited:
Joined
May 18, 2017
Messages
12
Motherboard
Gigabyte Z390 DESIGNARE
CPU
Intel Coffee Lake i9 9900K 3.6GHz
Graphics
AMD Vega 56
Anyone know of a patch for 200 series boards?
For 200 series on High Sierra the USB 3.0 and 3.1 are working without any patch. I have Gigabyte GA-Z270X-Gaming-K5 and all usb port are working without a patch
 
Joined
Jul 16, 2013
Messages
414
Motherboard
Asus Prime X299-Deluxe
CPU
i9-7900X
Graphics
Radeon VII
Quick note- High Sierra has a new Raise Port Limit Patch for USB 3 on Skylake/100 Series builds.

What about for other builds? I'm running an X79 system on a P9X79-E WS and can't get the USB3 ports on the motherboard to work. The USB3 card I have installed works though.
 
Joined
Sep 22, 2012
Messages
72
Motherboard
Asus Z370i ROG Strix
CPU
i7-8700K
Graphics
Nvidia GTX 1070
Mobile Phone
  1. Android
  2. iOS
Works well on Asus Z370 ROG STRIX. Thanks!
 
Top