New USB Raise Port Limit Patch for High Sierra

Discussion in 'High Sierra Desktop Support' started by tonymacx86, Jun 30, 2017.

  1. RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    159,830
    Mobo:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Jul 15, 2017 at 8:44 PM #11
    RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    159,830
    Mobo:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Read FAQ, "Problem Reporting"
    https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
     
  2. osxfr33k

    osxfr33k

    Joined:
    Jul 16, 2010
    Messages:
    312
    Mobo:
    Asus G750JX-DB71 Laptop (H87M chipset)
    CPU:
    i7-4700HQ
    Graphics:
    Nvidia GeForce GTX 770M GPU 3GB
    Mac:
    Mac Pro
    Mobile Phone:
    iOS
    Jul 20, 2017 at 11:18 PM #12
    osxfr33k

    osxfr33k

    Joined:
    Jul 16, 2010
    Messages:
    312
    Mobo:
    Asus G750JX-DB71 Laptop (H87M chipset)
    CPU:
    i7-4700HQ
    Graphics:
    Nvidia GeForce GTX 770M GPU 3GB
    Mac:
    Mac Pro
    Mobile Phone:
    iOS
    I am confused as well, with the guide on creating a custom SSDT for UsbInjectAll, is this patch still needed?

    Thanks!

    Edited:

    I figured it out thanks!
     
    Applementalist likes this.
    Last edited: Jul 21, 2017
  3. RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    159,830
    Mobo:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Jul 22, 2017 at 1:11 AM #13
    RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    159,830
    Mobo:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    The patch is used during port discovery only.
    After you have a correct SSDT for USBInjectAll, and the number of ports injected are within the 15-port limit, no need for the patch.
     
    osxfr33k likes this.
  4. dehjomz

    dehjomz

    Joined:
    Oct 24, 2013
    Messages:
    56
    Mobo:
    MSI Z170 Gaming M7 (BIOS 1.I - 2017-04-26)
    CPU:
    Skylake 6700K Overclocked to 4.7 GHz
    Graphics:
    Geforce GTX 1080
    Mac:
    iMac, MacBook
    Jul 26, 2017 at 3:12 AM #14
    dehjomz

    dehjomz

    Joined:
    Oct 24, 2013
    Messages:
    56
    Mobo:
    MSI Z170 Gaming M7 (BIOS 1.I - 2017-04-26)
    CPU:
    Skylake 6700K Overclocked to 4.7 GHz
    Graphics:
    Geforce GTX 1080
    Mac:
    iMac, MacBook
    This patch doesn't appear to be working any more for public beta 3. Can you confirm?
     
  5. vk2fro

    vk2fro

    Joined:
    Mar 7, 2011
    Messages:
    45
    Mobo:
    Z270M Mortar (MSI)
    CPU:
    I5 7600K (4.8Ghz oc)
    Graphics:
    Intel 630/ATI RX 480 8G
    Mac:
    MacBook Pro
    Mobile Phone:
    iOS
    Aug 11, 2017 at 4:22 AM #15
    vk2fro

    vk2fro

    Joined:
    Mar 7, 2011
    Messages:
    45
    Mobo:
    Z270M Mortar (MSI)
    CPU:
    I5 7600K (4.8Ghz oc)
    Graphics:
    Intel 630/ATI RX 480 8G
    Mac:
    MacBook Pro
    Mobile Phone:
    iOS
    Working for public beta 4 - it solved the "why doesn't this blasted USB hard drive show up in finder" issue for me! Thanks :)

    edit: and now removed since I have a working SSDT to keep number of ports at 15 or below. The 6 I disabled were all motherboard headers, will need to swap some in boot flags when I switch cases and move the usb 3.0 header from SS07/08 to SS03/04.
     
    Last edited: Aug 15, 2017
  6. LazarusNine

    LazarusNine

    Joined:
    Apr 22, 2017
    Messages:
    7
    Mobo:
    GIGABYTE H170 M-D3H
    CPU:
    Intel i5 6400 Skylake 2.7GHz
    Graphics:
    GIGABYTE Nvidia 960 GTX
    Sep 28, 2017 at 2:10 PM #16
    LazarusNine

    LazarusNine

    Joined:
    Apr 22, 2017
    Messages:
    7
    Mobo:
    GIGABYTE H170 M-D3H
    CPU:
    Intel i5 6400 Skylake 2.7GHz
    Graphics:
    GIGABYTE Nvidia 960 GTX
    This was the final step in getting my High Sierra installation running smoothly. For the record, I used Clover Configurator to make the changes to the config.plist file rather than TextWrangler, etc. Works well!
     
    Last edited: Sep 28, 2017
  7. dss862

    dss862

    Joined:
    Sep 21, 2011
    Messages:
    156
    Mobo:
    laptop dell 7348,dell 7559 UHD...desktop asrock H97M anniversary edition
    CPU:
    laptop-i7 --. 6700HQ..i5-5200U...desktop -i7-4790k
    Graphics:
    intel hd-5500,530 . desktop --palit nvidia gtx 1060 6gb ram
    Mac:
    iMac, MacBook Air, MacBook Pro
    Mobile Phone:
    Android
    Sep 28, 2017 at 2:22 PM #17
    dss862

    dss862

    Joined:
    Sep 21, 2011
    Messages:
    156
    Mobo:
    laptop dell 7348,dell 7559 UHD...desktop asrock H97M anniversary edition
    CPU:
    laptop-i7 --. 6700HQ..i5-5200U...desktop -i7-4790k
    Graphics:
    intel hd-5500,530 . desktop --palit nvidia gtx 1060 6gb ram
    Mac:
    iMac, MacBook Air, MacBook Pro
    Mobile Phone:
    Android
    rehabman do u have new usb 3.0 patch for release version 10.13? bec some port cannot read usb drive but not in 10.12.6
     
  8. RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    159,830
    Mobo:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Sep 28, 2017 at 2:25 PM #18
    RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    159,830
    Mobo:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    sam777 likes this.
  9. dirtydignity

    dirtydignity

    Joined:
    Oct 29, 2013
    Messages:
    11
    Mobo:
    Asus Maximus VIII Hero
    CPU:
    i7-6700k
    Graphics:
    NVIDIA GeForce GTX 980 4095 MB
    Mac:
    MacBook Pro, Mac mini
    Mobile Phone:
    iOS
    Sep 29, 2017 at 3:53 AM #19
    dirtydignity

    dirtydignity

    Joined:
    Oct 29, 2013
    Messages:
    11
    Mobo:
    Asus Maximus VIII Hero
    CPU:
    i7-6700k
    Graphics:
    NVIDIA GeForce GTX 980 4095 MB
    Mac:
    MacBook Pro, Mac mini
    Mobile Phone:
    iOS
    Fantastic. Worked like a charm. Used Clover Configurator and restarted the machine. All good. Thanks!
     
    LazarusNine likes this.
  10. arjunchawda

    arjunchawda

    Joined:
    Feb 28, 2013
    Messages:
    44
    Mobo:
    Gigabyte GA-Z270X-UD5
    CPU:
    i7 7700K @ 5GHz 1.43V
    Graphics:
    Saphire RX Vega 64
    Mac:
    Mac Pro
    Sep 29, 2017 at 11:12 PM #20
    arjunchawda

    arjunchawda

    Joined:
    Feb 28, 2013
    Messages:
    44
    Mobo:
    Gigabyte GA-Z270X-UD5
    CPU:
    i7 7700K @ 5GHz 1.43V
    Graphics:
    Saphire RX Vega 64
    Mac:
    Mac Pro
    I've tried following the guides on here to address my ports correctly, but to no avail. Using the USB Inject All kext seems to make the boot take about 4 mins, and then after the progress bar at the black Apple logo screen reaches the end, the screen just goes black, and stays black.

    I'm willing to drop a small amount of money for somebody to help out over TeamViewer. If anyone is interested, just drop me a line.
     

Share This Page