Contribute
Register

New USB Raise Port Limit Patch for High Sierra

Joined
Nov 26, 2012
Messages
1,090
Motherboard
Gigabyte Z370 Aorus Gaming 5
CPU
i7-8700K
Graphics
RX 580
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Thanks. Still not certain where to put them in config.plist but I will research further. Appreciated.
Open your config.plist and scroll down to where you see this "Kext to Patch":

<key>KextsToPatch</key>
<array>
<dict>
<key>Comment</key>
<string>USB 10.13.4+ by PMHeart</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
g32UDw+DlwQAAA==
</data>
<key>InfoPlistPatch</key>
<false/>
<key>MatchOS</key>
<string>10.13.x</string>
<key>Name</key>
<string>com.apple.driver.usb.AppleUSBXHCI</string>
<key>Replace</key>
<data>
g32UD5CQkJCQkA==
</data>
</dict>
<dict>
 
Joined
Jul 6, 2011
Messages
37
Motherboard
Asrock Z170M OC Formula
CPU
i7-6700K
Graphics
RX 570
Mac
iMac
10.13.6b1 has a new USB patch. Here we go again!


Code:
<key>KextsToPatch</key>
        <array>
            <dict>
                <key>Comment</key>
                <string>USB 10.13.6+ by PMHeart&FredWst</string>
                <key>Disabled</key>
                <false/>
                <key>Find</key>
                <data>
                g32IDw+DpwQAAA==
                </data>
                <key>InfoPlistPatch</key>
                <false/>
                <key>MatchOS</key>
                <string>10.13.x</string>
                <key>Name</key>
                <string>com.apple.driver.usb.AppleUSBXHCI</string>
                <key>Replace</key>
                <data>
                g32ID5CQkJCQkA==
                </data>
            </dict>
        </array>

Credits: @FredWst and @PMheart

Latest USBInjectall.kext must be also used.
*********
Greetings from JPN,
Please provide me your advice since I encounter the problem/isue of "Not available of any USB 3.0 port " after applying !0.13.6 Update. Though I could apply the new USB patch that you mention above, still exited the subject problem/issue.

So, I think that my OSx system also need the latest USBInjectall.kext as you pointed out.
- How to get the Latest USBInjectall.kext
- Any another attention/information to estbalish the 10.13.6 update completion ?

Thanks in advance.
 
Joined
Nov 26, 2012
Messages
1,090
Motherboard
Gigabyte Z370 Aorus Gaming 5
CPU
i7-8700K
Graphics
RX 580
Mac
iMac, MacBook Pro
Mobile Phone
iOS
*********
Greetings from JPN,
Please provide me your advice since I encounter the problem/isue of "Not available of any USB 3.0 port " after applying !0.13.6 Update. Though I could apply the new USB patch that you mention above, still exited the subject problem/issue.

So, I think that my OSx system also need the latest USBInjectall.kext as you pointed out.
- How to get the Latest USBInjectall.kext
- Any another attention/information to estbalish the 10.13.6 update completion ?

Thanks in advance.
 

Attachments

Joined
Jun 16, 2018
Messages
12
Motherboard
Gigabyte B360M D3H
CPU
Core i5-8400
Graphics
Intel UHD 630
Hello bro
I'm not sure which motherboard you have
i Just bοught the B360M-D3H and i have the same prob.
USB 3.1 GEN 2 working always
The USB 3.1 GEN1 and USB2 can't take together.
When install the XHCI-200-series-injector works the USB 3.1 GEN1
When install the USBInjectAll works only the USB 2
i try these kexts but nothing change
if u have the same motherboard please for your whole EFI folder
and something more,on bios usb section please your choices..

Update > Usb 3.1 GEN1 ports works only as USB 2
Update ii > When ejecting Usb 3.1 GEN 1 as USB 3 not working as USB 2
Thanks a lot.
You may want to try XHCI-300-series-injector.kext instead.
 
Joined
Mar 21, 2018
Messages
32
Motherboard
GA-Z270-HD3P
CPU
I7-7700K
Graphics
Vega 56
So this is probably the first time I need some help... After upgrading to 10.13.6 and also updating the USB patch I have a minor problem: My USB is generally working fine, but after waking up from sleep I get the error "Drive ABC was not ejected properly". Am I missing something? I already found that the xmp setting in bios might be a cause for this, but this didn't solve it for me. I've attached my config.plist and would really appreciate if someone could take a look.
 
Joined
Mar 21, 2018
Messages
32
Motherboard
GA-Z270-HD3P
CPU
I7-7700K
Graphics
Vega 56
So this is probably the first time I need some help... After upgrading to 10.13.6 and also updating the USB patch I have a minor problem: My USB is generally working fine, but after waking up from sleep I get the error "Drive ABC was not ejected properly". Am I missing something? I already found that the xmp setting in bios might be a cause for this, but this didn't solve it for me. I've attached my config.plist and would really appreciate if someone could take a look.
Found a kind of weird solution myself... As long as I'm only using LAN and no WIFI this won't happen...
 
Top