Contribute
Register

New UEFI updates for Gigabyte's high-end Z77 boards

Joined
Nov 13, 2011
Messages
33
Motherboard
Z77X-UP4 TH
CPU
Intel Core i7-3770
Graphics
R9-280X(GV-R928XOC-3GD) / GTX-780(N780-3GD5)
Mac
MacBook Air, MacBook Pro
Mobile Phone
iOS
No USB3 issue solved in Z77X-UP4-TH F7. The USB3 ports still works only with USB3 devices when setting XHCI-AUTO in UEFI BIOS and ML 10.8.1 (USB3 ports can not works with USB2 devices).
 
Joined
Jun 4, 2011
Messages
4
Motherboard
EVGA X58
CPU
i7 960
Graphics
GTX 285
Mac
Classic Mac
Mobile Phone
I just flashed my Z77X-UD5H using the QFlash method to F14. So far so good!
 
Joined
Mar 9, 2012
Messages
38
Motherboard
Asus X99-A
CPU
Intel i7-5930K
Graphics
Asus Strix GTX 970
BE AWARE.... I just updated my Z77X-UD5H to firmware version F14... and the system wouldn't shutdown properly. I reverted back to version F8, and everything is working fine again (relief). I also installed a GTX 660 TI around the same time, but I don't think that affected the shutdown problem. I believe the problem is with the F14 firmware.... perhaps others can test with their systems and verify?

-masterdrogo
 
Joined
Aug 17, 2012
Messages
446
Motherboard
GA-Z77X-UD5H
CPU
i5-3570K
Graphics
GTX 960
Mac
MacBook
Mobile Phone
iOS
Article: New UEFI updates for Gigabyte's high-end Z77 boards

BE AWARE.... I just updated my Z77X-UD5H to firmware version F14... and the system wouldn't shutdown properly. I reverted back to version F8, and everything is working fine again (relief). I also installed a GTX 660 TI around the same time, but I don't think that affected the shutdown problem. I believe the problem is with the F14 firmware.... perhaps others can test with their systems and verify?

-masterdrogo
What is the exact problem? If the pc turn on again it might be the Wake on LAN. You need to disable it.
 
Joined
May 21, 2012
Messages
11
Motherboard
GIGABYTE-z77xud5h
CPU
Intel-i73770k
Graphics
Nividia Geoforce GTX 970
Mac
MacBook Pro
Were are the dsdt's for the gigabyte z77 already i have been asking this question for a long time with no answer
you guys had a few before and now there all missing
 
Joined
May 21, 2012
Messages
11
Motherboard
GIGABYTE-z77xud5h
CPU
Intel-i73770k
Graphics
Nividia Geoforce GTX 970
Mac
MacBook Pro
Article: New UEFI updates for Gigabyte's high-end Z77 boards

i just updated my ga-z77x-ud5h. My first time updating a bios. It looks like my system setting have been completely reset, even the new version of ml got rolled back...weird. All my files are still here though. Is this normal?
where are all the dsdt's for the z77 ud5h??????????????
 
Joined
Jan 13, 2010
Messages
2,934
Motherboard
Gigabyte Z77X-UD5H
CPU
Core i7-3770K @4.2-4.4GHz
Graphics
Galaxy GeForce GTX 660 Ti
Mac
Classic Mac
Mobile Phone
Android
Article: New UEFI updates for Gigabyte's high-end Z77 boards

BE AWARE.... I just updated my Z77X-UD5H to firmware version F14... and the system wouldn't shutdown properly. I reverted back to version F8, and everything is working fine again (relief). I also installed a GTX 660 TI around the same time, but I don't think that affected the shutdown problem. I believe the problem is with the F14 firmware.... perhaps others can test with their systems and verify?

-masterdrogo
Did you disable Wake on LAN?
 
Joined
Jan 13, 2010
Messages
2,934
Motherboard
Gigabyte Z77X-UD5H
CPU
Core i7-3770K @4.2-4.4GHz
Graphics
Galaxy GeForce GTX 660 Ti
Mac
Classic Mac
Mobile Phone
Android
Article: New UEFI updates for Gigabyte's high-end Z77 boards

Were are the dsdt's for the gigabyte z77 already i have been asking this question for a long time with no answer
you guys had a few before and now there all missing
And we've answered it many times, you don't need one
 
Joined
Jan 13, 2010
Messages
2,934
Motherboard
Gigabyte Z77X-UD5H
CPU
Core i7-3770K @4.2-4.4GHz
Graphics
Galaxy GeForce GTX 660 Ti
Mac
Classic Mac
Mobile Phone
Android
Article: New UEFI updates for Gigabyte's high-end Z77 boards

BE AWARE.... I just updated my Z77X-UD5H to firmware version F14... and the system wouldn't shutdown properly. I reverted back to version F8, and everything is working fine again (relief). I also installed a GTX 660 TI around the same time, but I don't think that affected the shutdown problem. I believe the problem is with the F14 firmware.... perhaps others can test with their systems and verify?

-masterdrogo
Same config, shuts down just fine. However, the GTX 660 Ti seems to add an additional 20-30 seconds to the shut down time, something my HD 6870 didn't.
Sleep works, but it's still iffy when waking up with regards to USB device.
 
Joined
Aug 17, 2012
Messages
446
Motherboard
GA-Z77X-UD5H
CPU
i5-3570K
Graphics
GTX 960
Mac
MacBook
Mobile Phone
iOS
Article: New UEFI updates for Gigabyte's high-end Z77 boards

Were are the dsdt's for the gigabyte z77 already i have been asking this question for a long time with no answer
you guys had a few before and now there all missing
you don't need it.
 
Top