Contribute
Register

New Intel NUC NUC8i7BEH compatibily

Status
Not open for further replies.
Joined
Sep 4, 2012
Messages
28
Motherboard
Intel NUC8i5BEH2
CPU
i5-8259U
Graphics
Iris Pro 655
Mac
  1. iMac
  2. Mac mini
Mobile Phone
  1. Android
I updated my Bios firmware to the latest version (61 i believe). Couldn't install/boot Macos anymore. Even older versions (sierra/high sierra) didn't boot. So i went back to bios version 56. Installed High Sierra without any problems on NUC8I5BEH with only using multibeast, voodoohda audio and Intel graphic 6xx support. Installed in 15 minutes..works like a charm!
 
Joined
Jul 19, 2010
Messages
131
Motherboard
Intel NUC8i7BEH2
CPU
i7-8559U
Graphics
Iris Plus 655
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I updated my Bios firmware to the latest version (61 i believe). Couldn't install/boot Macos anymore. Even older versions (sierra/high sierra) didn't boot. So i went back to bios version 56. Installed High Sierra without any problems on NUC8I5BEH with only using multibeast, voodoohda audio and Intel graphic 6xx support. Installed in 15 minutes..works like a charm!
I confirm that new BIOS v64 now available completely breaks booting! BIOS v56 did work like a charm. I think it got stuck somewhere (at each verbose boot) in AHCI message saying:

Code:
IOAHCIBlockStorageDriver::DetermineDeviceFeatures -- !!!!! WARNING !!!! - Fordce Data Set Management is set

Avoid at all costs! Thankfully I had kept a copy of v56... Will downgrade now.
In their Readme.pdf there is a mention of a SATA RAID Option ROM update, together with ME Firmware and PMC Firmware being updated (not sure what the latter is)
 
Joined
Jul 19, 2010
Messages
131
Motherboard
Intel NUC8i7BEH2
CPU
i7-8559U
Graphics
Iris Plus 655
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I updated my Bios firmware to the latest version (61 i believe). Couldn't install/boot Macos anymore. Even older versions (sierra/high sierra) didn't boot. So i went back to bios version 56.
Excuse my follow-up and possible off-topic; @tiqo how did you manage to downgrade? I was careless enough to not check forums and upgraded my NUC8i7BEH to BIOS v64 and for the love of me, I cannot downgrade. Tried all 3 methods, the Visual BIOS then F7, the direct boot F7 (same) and pressing the power button 3 seconds until blue becomes orange, and going through that menu. I even tried removing the BIOS security jumper too (per Intel's guide here and here), restart the process and always gets to the same error Flash Update Failed! Technical Information (0x8000000000000015, 0)
(I did format USB stick and double checked the integrity of the .BIO file). Any ideas, anyone? Could BIOS v64 have changed the procedure? Thank you...
 
Joined
Sep 4, 2012
Messages
28
Motherboard
Intel NUC8i5BEH2
CPU
i5-8259U
Graphics
Iris Pro 655
Mac
  1. iMac
  2. Mac mini
Mobile Phone
  1. Android
Excuse my follow-up and possible off-topic; @tiqo how did you manage to downgrade? I was careless enough to not check forums and upgraded my NUC8i7BEH to BIOS v64 and for the love of me, I cannot downgrade. Tried all 3 methods, the Visual BIOS then F7, the direct boot F7 (same) and pressing the power button 3 seconds until blue becomes orange, and going through that menu. I even tried removing the BIOS security jumper too (per Intel's guide here and here), restart the process and always gets to the same error Flash Update Failed! Technical Information (0x8000000000000015, 0)
(I did format USB stick and double checked the integrity of the .BIO file). Any ideas, anyone? Could BIOS v64 have changed the procedure? Thank you...
I had the same issue downgrading from v61. None of the options worked until i tried the "Bios Recovery" option. That worked for me!

See here : https://www.intel.com/content/www/us/en/support/articles/000005532/mini-pcs.html

By the way, i used the "Power Button Menu" option, and then F4 (BIOS recovery). It worked for me on the 8i5BEH. Hope it works for you too and v64 didn't change anything about it!
 
Joined
Jul 19, 2010
Messages
131
Motherboard
Intel NUC8i7BEH2
CPU
i7-8559U
Graphics
Iris Plus 655
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Thank you @tiqo thank you very much for your kind post. Indeed, I did it all from scratch and followed again those instructions to the letter, slowly and keeping cool. The secret seems the steps and USB contents: To format the USB stick (I did with Rufus on Windows) and only put that single BE0056.BIO file (FAT32 with default sector size). Moreover, the NUC takes a few seconds to show the Recovery Boot screen after pressing power for 3 seconds (with a quick flash of the LED from blue to orange). The F4 menu option for BIOS Recovery also takes some seconds to reboot to the screen again, showing a countdown to flashing (showing "ESC to abort") that I never got to, before. Probably after reading the .BIO file in memory or something.

I was disappointed earlier a lot because Intel's Readme PDF writes:

Downgrading the BIOS to an earlier version isn’t recommended and might not be supported. An earlier BIOS version might not offer support for the latest processors, bug fixes, critical security updates, or support the latest board revisions currently being manufactured. If you’re trying to downgrade to a previous BIOS version and its Intel® ME Firmware version is older than that currently on the motherboard, then the downgrade is NOT supported.

The two BIOS Release Notes files for NUC8i7BEH differ in the following (and note the ME version, that justified my disappointment):

BIOS Version 0064 - BECFL357.86A.0064.2019.0213.112
• ME Firmware: 12.0.23.1311
• PMC Firmware: 300.1.20.1023
• Framework Reference Code: Based on 7.0.44.23
• Integrated Graphics: Option ROM: v1017, UEFI Driver: v9.0.1084
• SATA RAID Option ROM: 16.8.0.1000

BIOS Version 0056 - BECFL357.86A.0056.2018.1128.1717
• ME Firmware: 12.0.10.1128
• PMC Firmware:300.1.20.1019
• Framework Reference Code: Based on 7.0.37.50
• Integrated Graphics: Option ROM: v1014, UEFI Driver: v9.0.1080
• SATA RAID Option ROM: 16.5.0.3492

I must have fiddled with BIOS and Clover settings all day, to no solution. Neither USB installer nor my test Kingston SSD would go past a screen full of lines (in verbose boot).

Now that I have my system up and running, can you or any reader confirm two points that I noticed since completing the setup, please?

a) has anyone noticed if the HDD yellow LED (I use only SSD SATA for now) is only working intermittently? One time it blinks, another time it's completely off despite operations...

b) if you boot in -v mode, does anyone confirm that there's a slight slowdown, with the boot process taking some time when reaching this stage below?

Code:
afps_vfsop_mount 2525 mounted volume: VM

Thank you again everyone.
 
Last edited:
Joined
Sep 4, 2012
Messages
28
Motherboard
Intel NUC8i5BEH2
CPU
i5-8259U
Graphics
Iris Pro 655
Mac
  1. iMac
  2. Mac mini
Mobile Phone
  1. Android
Thank you @tiqo thank you very much for your kind post. Indeed, I did it all from scratch and followed again those instructions to the letter, slowly and keeping cool. The secret seems the steps and USB contents: To format the USB stick (I did with Rufus on Windows) and only put that single BE0056.BIO file (FAT32 with default sector size). Moreover, the NUC takes a few seconds to show the Recovery Boot screen after pressing power for 3 seconds (with a quick flash of the LED from blue to orange). The F4 menu option for BIOS Recovery also takes some seconds to reboot to the screen again, showing a countdown to flashing (showing "ESC to abort") that I never go to earlier. Probably after reading the .BIO file in memory or something.

I was disappointed earlier a lot because Intel's Readme PDF writes:



The two BIOS Release Notes files for NUC8i7BEH differ in the following (and note the ME version, that justified my disappointment):



I must have fiddled with BIOS and Clover settings all day, to no solution. No USB installer or my test Kingston SSD would go past a screen full of lines (in verbose boot).

Now that I have my system up and running, can you or any reader confirm two points that I noticed since completing the setup, please?

a) has anyone noticed if the HDD yellow LED (I use only SSD SATA for now) is only working intermittently? One time it blinks, another time it's completely off despite operations...

b) if you boot in -v mode, does anyone confirm that there's a slight slowdown, with the boot process taking some time when reaching this stage below?

Code:
afps_vfsop_mount 2525 mounted volume: VM

Thank you again everyone.

btw : i formatted my usb stick with fat32 in Disk Utility. That seemed to work too.

Answers to your questions :
a) - Yes, my HDD led doesn't light up as it used to. So i have the same issue here.
b) - Yes, also a slowdown over here.
 
Last edited:
Joined
Mar 8, 2019
Messages
24
Motherboard
Intel NUC8i7BEH3-Clover
CPU
i7-8559U
Graphics
Iris Plus 655 (1920x1080)
Mac
  1. Mac mini
i use the NUC8i7BEH with UEFI defaults and had just change secureboot off in biossettings. So test the attached clover folder.

I can run through the whole installation with dualmonitor via usb-c.

Update: New cloverfolder. Now BT works fine, also SD-Card. So please give me Feedback if it also works for you.
Hi on the NUC8i7BEH did you manage to get BT to work as you say above? I copied most of your clover and got dual screen to work and be stable (thanks), but BT not working - also I has sound from the jack working but now its gone.

Any thoughts would be great. See the two separate clover-before (audio from jack) and after audio only from monitor (based on your set above).

(Do I need to install to /Library/Extensions as well the new kexts?)

Thanks again.
 

Attachments

  • CLOVER_WORKING_BEFORE.zip
    5.3 MB · Views: 154
  • CLOVER_AFTER.zip
    7 MB · Views: 109
Joined
May 18, 2018
Messages
1
Motherboard
ASUS Z370p
CPU
i7 8th gen 8700
Graphics
UHD630
Hi on the NUC8i7BEH did you manage to get BT to work as you say above? I copied most of your clover and got dual screen to work and be stable (thanks), but BT not working - also I has sound from the jack working but now its gone.

Any thoughts would be great. See the two separate clover-before (audio from jack) and after audio only from monitor (based on your set above).

(Do I need to install to /Library/Extensions as well the new kexts?)

Thanks again.

You saved my day .. I was having all kinds of issues with My 8i5BEH ,
I just mounted my EFI and replaced files with your Clover_working_before files
and everything magically worked after a quick reboot.

thank you very much !
 
Joined
Mar 8, 2019
Messages
24
Motherboard
Intel NUC8i7BEH3-Clover
CPU
i7-8559U
Graphics
Iris Plus 655 (1920x1080)
Mac
  1. Mac mini
You saved my day .. I was having all kinds of issues with My 8i5BEH ,
I just mounted my EFI and replaced files with your Clover_working_before files
and everything magically worked after a quick reboot.

thank you very much !
For 8i7BEH I got all the stuff from following rehabmans guide. Just having issues with screen flicker.
 
Joined
Jul 6, 2011
Messages
11
Motherboard
ROG STRIX Z390-E GAMING
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac Pro
Classic Mac
  1. iMac
  2. Power Mac
Mobile Phone
  1. Android
  2. iOS
[Success]

Hackintosh macOS Mojave 10.14.3 Build 18D42 at Intel NUC8i7BEH
 

Attachments

  • Screenshot 2019-03-08 at 11.54.00 AM.png
    Screenshot 2019-03-08 at 11.54.00 AM.png
    85.5 KB · Views: 358
  • Screenshot 2019-03-08 at 11.55.11 AM.png
    Screenshot 2019-03-08 at 11.55.11 AM.png
    37.5 KB · Views: 363
  • Screenshot 2019-03-08 at 11.57.07 AM.png
    Screenshot 2019-03-08 at 11.57.07 AM.png
    79.6 KB · Views: 339
  • Screenshot 2019-03-08 at 11.57.34 AM.png
    Screenshot 2019-03-08 at 11.57.34 AM.png
    88.8 KB · Views: 359
  • Screenshot 2019-03-08 at 11.58.04 AM.png
    Screenshot 2019-03-08 at 11.58.04 AM.png
    98.2 KB · Views: 349
  • Screenshot 2019-03-08 at 11.58.23 AM.png
    Screenshot 2019-03-08 at 11.58.23 AM.png
    100.8 KB · Views: 333
  • Screenshot 2019-03-08 at 11.59.48 AM.png
    Screenshot 2019-03-08 at 11.59.48 AM.png
    90.6 KB · Views: 331
  • Screenshot 2019-03-08 at 12.15.59 PM.png
    Screenshot 2019-03-08 at 12.15.59 PM.png
    69.5 KB · Views: 335
Last edited:
Status
Not open for further replies.
Top