Contribute
Register

New Intel NUC NUC8i7BEH compatibily

Status
Not open for further replies.
Joined
Dec 16, 2018
Messages
1
Motherboard
Intel NUC8i5BEK1
CPU
i5-8259U
Graphics
Iris Plus 655
Nevermind, I followed Rehabman's Guide from start to finish to the letter. It worked like a charm on my NUC8i5BEK.
Would you mind posting your EFI folder so I can create a working USB stick? I purchased the same NUC today and am having little success getting Mojave installed. It is currently locking up near the end of the installation process.
 
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,466
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Joined
Feb 11, 2012
Messages
15
Motherboard
NUC 6i5SYH
CPU
i5-6260U
Graphics
Iris 540
RehabMan and everyone on this thread- thanks for all the work on getting these NUCs working with Mac OS. I have been using a NUC6 which has worked flawlessly after a painless install when I followed the RehabMan guide. This Nuc8 has been quite a bit harder to get working.

One tip on the bios-
Some of the bios settings RehabMan describes in the tutorial don’t exist on the current firmware. The major ones you need to do are Legacy boot, disable secure boot, and the wake on lan settings which are there.

The major issues I had:
1) Reboot loop after software install. Like everyone else I booted in safe mode and was able to select language, etc. Then it rebooted fine.

2) Once I booted into the finder I could not download developer command line tools or even use the internet due to extremely slow network speed. Since I had followed the instructions on the RehabMan thread, I tried reinstalling everything again and got the same thing. I tried a bunch of different changes and drivers, non of which worked.
After reading through the this thread I finally saw the tip about manually changing the nic speed to 100 mbit. That finally worked and I was able to complete the install and everything but gigabit works now.

Is there a fix to be able to get gigabit network speeds? I do find that my local network connections are slower than on my NUC6.

Thanks.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,466
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Is there a fix to be able to get gigabit network speeds? I do find that my local network connections are slower than on my NUC6.
Check BIOS settings. Make sure WOL is disabled, both in BIOS and SysPrefs.
 
Joined
Nov 5, 2018
Messages
5
Motherboard
NUC8i5BEH
CPU
i5-8259U
Graphics
Intel Iris 655
Mobile Phone
  1. Android
  2. iOS
Hi, I got Mojave 10.14.2 installed to NUC8I5BEH. Everything seems fine except it rebooting itself after sleep. I am thinking it is caused by the Asus Bluetooth USB dongle(bcm20702a0). Anyone know how to resolve this problem? thanks...
 
Joined
Feb 11, 2012
Messages
15
Motherboard
NUC 6i5SYH
CPU
i5-6260U
Graphics
Iris 540
Hi Everyone. Again thanks again.

So now my NUC8i7BEH is working fairly well except for one recurrent issue.

When I try to open some images using "Quicklook" in Finder or the Preview App I get weird graphics glitches that eventually lead to a complete system crash (black screen then reboot with no error message).

I have tried different graphics IDs (currently using 0x12345678).
It's weird because the same image can be opened on apple photos with no problem.

Problem reporting files attached and a iPhone pic of the graphics glitch (glitchy picture in Preview on left, normal picture on right in Photos).

Thanks for all of your help!
 

Attachments

  • debug_6811.zip
    2.8 MB · Views: 53
  • IMG_9753.jpg
    IMG_9753.jpg
    774.7 KB · Views: 178
Joined
Feb 11, 2012
Messages
15
Motherboard
NUC 6i5SYH
CPU
i5-6260U
Graphics
Iris 540
Also... in Console I see a bunch of errors over and over that look like this:

com.apple.xpc.launchd[1] (com.apple.displaypolicyd[1647]): Service exited due to SIGABRT
com.apple.xpc.launchd[1] (com.apple.displaypolicyd): Service only ran for 0 seconds. Pushing respawn out by 10 seconds.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,466
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I have tried different graphics IDs (currently using 0x12345678).

You should not expect working graphics with an invalid ig-platform-id.
 
Joined
Feb 11, 2012
Messages
15
Motherboard
NUC 6i5SYH
CPU
i5-6260U
Graphics
Iris 540
You should not expect working graphics with an invalid ig-platform-id.

I get exactly the same behavior with the platform id that is used in your config.plist from the git. 0x3e9b0007
I did also try to take the # out form in front of the ig-platform-id key.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,466
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I get exactly the same behavior with the platform id that is used in your config.plist from the git. 0x3e9b0007
I did also try to take the # out form in front of the ig-platform-id key.

Reply in guide thread with problem reporting files as requested in the guide.
 
Status
Not open for further replies.
Top