Contribute
Register

New EDID generator, help needed

Status
Not open for further replies.
Joined
Nov 10, 2011
Messages
1,455
Motherboard
GA-H77N-WIFI F4
CPU
i7-3770
Graphics
HD 4000
Mobile Phone
  1. Android
The newedid.sh link is dead.
I have a 4540s with 3210M.
I ran the package in the Installer and It changed my System Profiler and I edited the plist file and corrected the name.

If there are tests you want me to do I'm here.

Here's the latest script. Both files should be in one and the same folder. Extract the archive, start the script in Terminal like this:

sudo bash -x /path/to/EDIDGen.sh

then copy the whole output from Terminal and post it here.
 

Attachments

  • EDIDGen.zip
    14.3 KB · Views: 203
Joined
Aug 15, 2012
Messages
53
Motherboard
GA-Z77X-UD5H
CPU
Intel® Core™ i5-3570K
Graphics
Gainward GeForce® GTX 560 Ti 2048MB
Mac
Classic Mac
Mobile Phone
  1. Android
Here's the latest script. Both files should be in one and the same folder. Extract the archive, start the script in Terminal like this:

sudo bash -x /path/to/EDIDGen.sh

then copy the whole output from Terminal and post it here.

Code:
+ '[' -e /tmp/display.plist ']'
+ case `./ioregpbi -n AppleBacklightDisplay -rxw0` in
++ ./ioregpbi -n AppleBacklightDisplay -rxw0
/Users/samer/Desktop/EDIDGen/EDIDGen.sh: line 41: ./ioregpbi: No such file or directory
+ ./ioregpbi -n AppleDisplay -arxw0
/Users/samer/Desktop/EDIDGen/EDIDGen.sh: line 42: ./ioregpbi: No such file or directory
+ GenEDID 0
+ /usr/libexec/PlistBuddy -c 'Print :0' /tmp/display.plist
Cannot parse a NULL or zero-length data
Error Reading File: /tmp/display.plist
+ '[' 1 -eq 0 ']'
+ echo 'No display detected!'
No display detected!
+ GenEDID 1
+ /usr/libexec/PlistBuddy -c 'Print :1' /tmp/display.plist
Cannot parse a NULL or zero-length data
Error Reading File: /tmp/display.plist
+ '[' 1 -eq 0 ']'
+ echo 'No display detected!'
No display detected!
+ GenEDID 2
+ /usr/libexec/PlistBuddy -c 'Print :2' /tmp/display.plist
Cannot parse a NULL or zero-length data
Error Reading File: /tmp/display.plist
+ '[' 1 -eq 0 ']'
+ echo 'No display detected!'
No display detected!
+ rm -rf /tmp/display.plist

PS: I've already installe the script from the ProBook Installer, is that what causing these errors?

I believe I'm doing sth wrong.
 
Joined
Nov 10, 2011
Messages
1,455
Motherboard
GA-H77N-WIFI F4
CPU
i7-3770
Graphics
HD 4000
Mobile Phone
  1. Android
Code:
+ '[' -e /tmp/display.plist ']'
+ case `./ioregpbi -n AppleBacklightDisplay -rxw0` in
++ ./ioregpbi -n AppleBacklightDisplay -rxw0
/Users/samer/Desktop/EDIDGen/EDIDGen.sh: line 41: ./ioregpbi: No such file or directory
+ ./ioregpbi -n AppleDisplay -arxw0
/Users/samer/Desktop/EDIDGen/EDIDGen.sh: line 42: ./ioregpbi: No such file or directory
+ GenEDID 0
+ /usr/libexec/PlistBuddy -c 'Print :0' /tmp/display.plist
Cannot parse a NULL or zero-length data
Error Reading File: /tmp/display.plist
+ '[' 1 -eq 0 ']'
+ echo 'No display detected!'
No display detected!
+ GenEDID 1
+ /usr/libexec/PlistBuddy -c 'Print :1' /tmp/display.plist
Cannot parse a NULL or zero-length data
Error Reading File: /tmp/display.plist
+ '[' 1 -eq 0 ']'
+ echo 'No display detected!'
No display detected!
+ GenEDID 2
+ /usr/libexec/PlistBuddy -c 'Print :2' /tmp/display.plist
Cannot parse a NULL or zero-length data
Error Reading File: /tmp/display.plist
+ '[' 1 -eq 0 ']'
+ echo 'No display detected!'
No display detected!
+ rm -rf /tmp/display.plist

PS: I've already installe the script from the ProBook Installer, is that what causing these errors?

I believe I'm doing sth wrong.

Hm, check if the ioregpbi binary is executable and if it's not, make it executable with sudo chmod +x ./ioregpbi

OR

edit the script and replace ./ioregpbi with only ioreg (on lines 41, 42 and 44)
 
Joined
Nov 10, 2011
Messages
1,455
Motherboard
GA-H77N-WIFI F4
CPU
i7-3770
Graphics
HD 4000
Mobile Phone
  1. Android
The script is executable and also I ran chown but the same output.

Not the script, the ioregpbi utility (which is in the archive with the script and should be extracted in the same folder as the script), when you execute a script with bash -x some_script, it doesn't matter if the script is executable or not.
 
Joined
Jan 25, 2012
Messages
653
Motherboard
ASUS P8P67-LE
CPU
i5-2400
Graphics
GTX 550TI
Mobile Phone
  1. Android
  2. iOS
I have a 4340s HM76 chipset with i3-3110m CPU - are you still looking for people with Ivy-Bridge to test your script?
Also sorry for asking this, what exactly does this purpose of the script?
 
Joined
Nov 10, 2011
Messages
1,455
Motherboard
GA-H77N-WIFI F4
CPU
i7-3770
Graphics
HD 4000
Mobile Phone
  1. Android
I have a 4340s HM76 chipset with i3-3110m CPU - are you still looking for people with Ivy-Bridge to test your script?
Also sorry for asking this, what exactly does this purpose of the script?

Sure, I still don't have any test results on this platform with Ivy Bridge CPU, so if you have some time, download the archive from one of my previous posts, extract it somewhere, make sure both files are in the same folder and they are executable (chmod +x ./*) and then execute the script in Terminal like this:

sudo bash -x /path/to/EDIDGen.sh

Copy the whole output in the Terminal window and post it here.

The point of all this is for some reason OS X doesn't use the EDID information of every laptop internal display (except the information in the MacBooks) and this is a way to force it to use this information.
 
Joined
Oct 30, 2012
Messages
53
Motherboard
Gigabyte B85M Gaming 3
CPU
Core i5-4590
Graphics
MSI N750TI-2GD5/OC
Mac
Classic Mac
Mobile Phone
Not sure how relevant it is anymore, well, just for the record: "IODisplayConnectFlags" = <00080000>
 
Joined
Aug 20, 2011
Messages
92
Motherboard
MSI b85m-e45 | MSI b75MA-P45 | Probook 6470b
CPU
i7 4790 | i5 3570K | i5-3320m
Graphics
NITRO+OC RX480 8GB | XFXHD6870 1GB | HD4000
Hey,

i arrive this thread searching about hack's hd4000 capabilities for well detecting external displays. I have a probook 6470b with i5 3320. My displays are recognized as spdisplays_display Internal and spdisplays_display External so i can't use the native monitor resolution!! (im using DP->VGA).

There's a solution?

Cheers!

PD:

Here's the output

+ '[' -e /tmp/display.plist ']'
+ case `./ioregpbi -n AppleBacklightDisplay -rxw0` in
++ ./ioregpbi -n AppleBacklightDisplay -rxw0
/Users/tamaraocampo/Downloads/EDIDGen/EDIDGen.sh: line 41: ./ioregpbi: No such file or directory
+ ./ioregpbi -n AppleDisplay -arxw0
/Users/tamaraocampo/Downloads/EDIDGen/EDIDGen.sh: line 42: ./ioregpbi: No such file or directory
+ GenEDID 0
+ /usr/libexec/PlistBuddy -c 'Print :0' /tmp/display.plist
Cannot parse a NULL or zero-length data
Error Reading File: /tmp/display.plist
+ '[' 1 -eq 0 ']'
+ echo 'No display detected!'
No display detected!
+ GenEDID 1
+ /usr/libexec/PlistBuddy -c 'Print :1' /tmp/display.plist
Cannot parse a NULL or zero-length data
Error Reading File: /tmp/display.plist
+ '[' 1 -eq 0 ']'
+ echo 'No display detected!'
No display detected!
+ GenEDID 2
+ /usr/libexec/PlistBuddy -c 'Print :2' /tmp/display.plist
Cannot parse a NULL or zero-length data
Error Reading File: /tmp/display.plist
+ '[' 1 -eq 0 ']'
+ echo 'No display detected!'
No display detected!
+ rm -rf /tmp/display.plist
 
Status
Not open for further replies.
Top