Contribute
Register

New Build... and some problems

Status
Not open for further replies.
Joined
Jul 20, 2011
Messages
78
Motherboard
Gigabyte Z390 Gaming X
CPU
i7-9700
Graphics
RX 570
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
  5. Mac Pro
Classic Mac
  1. 128K
  2. 512K
  3. Apple
  4. Centris
  5. Classic
  6. Color Classic
  7. iBook
  8. iMac
  9. LC
  10. Lisa
  11. Performa
  12. Plus
  13. Power Mac
  14. PowerBook
  15. Quadra
  16. SE
  17. SE/30
Mobile Phone
  1. iOS
I took my heart in my hand and upgraded my 6 year old Hackintosh yesterday. Quite a leap from Haswell! Everything except Wifi seems to be working, but there are some odd behaviours. I have internal graphics enabled but not used. I have 2 monitors, both Dell. My 24" is connected via DVI to the video card and my 27" 4K is connected via HDMI. None of the DisplayPort connectors work... and never did under Mojave either. About this Mac says I have an iMac (Retina 5K, 27-inch, 2017) with a 3.6GHz 8-Core Intel Core i9. Hackintool and Geekbench both correctly identify the CPU as an i7.

When I boot, I get black screens until the 2nd half of the Mac boot process, when the black screen and white apple show up immediately before the desktop comes up. I never see the Gigabyte screen or Clover. Geekbench result is very low too, but the computer seems EXTREMELY snappy!

I'd love explanations and help for the odd boot behaviour, the low Geekbench and especially the Wifi. Wifi is via a Buyer's Guide recommended (at time of purchase) TP-Link Archer T6E pci card Which worked with Mojave. Hackintool does see the WiFi card.
 
Joined
Apr 1, 2012
Messages
437
Motherboard
MSI MPG Z490 Gaming Plus
CPU
i7 10700
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
  2. iOS
Have you tried turning off the onboard iGPU to see what happens? If you have the iGPU set as primary that could be why you don't see anything until the operating system initializes its driver.
 
Joined
Jul 20, 2011
Messages
78
Motherboard
Gigabyte Z390 Gaming X
CPU
i7-9700
Graphics
RX 570
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
  5. Mac Pro
Classic Mac
  1. 128K
  2. 512K
  3. Apple
  4. Centris
  5. Classic
  6. Color Classic
  7. iBook
  8. iMac
  9. LC
  10. Lisa
  11. Performa
  12. Plus
  13. Power Mac
  14. PowerBook
  15. Quadra
  16. SE
  17. SE/30
Mobile Phone
  1. iOS
Thanks for the reply. I tried moving my 27" display to the internal hdmi connector but I still don't see the BIOS screen. I suspect I'll have to remove my video card to force it. For those willing to help, I'm also posting the contents of related folders here, in the hope that someone can help me with my WiFi problem.
 

Attachments

  • Contents of :EFI:EFI:CLOVER:kexts:Other:.txt
    101 bytes · Views: 26
  • Contents of :L:E.txt
    753 bytes · Views: 13
  • Contents of :S:L:E.txt
    6.9 KB · Views: 118
  • Contents of EFI:EFI:CLOVER:drivers64UEFI.txt
    93 bytes · Views: 27
Status
Not open for further replies.
Top