Contribute
Register

Native USB 2.0 / USB 3.0 on Skylake

Joined
Feb 21, 2011
Messages
313
Motherboard
GA-Z170X-UD3
CPU
I5-6600K
Graphics
Vega 64
Mac
MacBook Air, MacBook Pro
Mobile Phone
iOS
Hi

I have been using a script that configures USB 2.0 and USB 3.0 ports without using USBInjectAll.kext for both my El Capitan and now my Sierra guide.

After seeing that some people where having problems with USB 3.0 on Sierra with USBInjectAll.kext and have been using my script (With some missing ports), I decided to create a generic script that should work for some Skylake boards.

It seems to work on Gigabyte boards, but I'm not sure which boards work and which doesn't, so if you try it, please report in this thread.

Download this: https://github.com/cnrd/OSX-USB-SSDT/archive/master.zip

Unzip the folder and double click the "USB-SSDT.command" file.

This should open a window looking something like this:
Screen Shot 2016-09-24 at 14.37.30.png

You will need to know which ports to enable or disable from some other source.

The script will ask you up to 3 questions about each port for proper configuration, please read these carefully.

When done, the script will place a file called: USB-SSDT.aml on your desktop, place this file in: /EFI/CLOVER/ACPI/Patched
Also please remove any other USB patched you may be using.

Now open your config.plist and add this:
Code:
<key>DropTables</key>
<array>
    <dict>
        <key>Signature</key>
        <string>SSDT</string>
        <key>TableId</key>
        <string>xh_rvp10</string>
    </dict>
</array>
You can also use Clover Configurator by adding: Signature: SSDT, Type/key: TableID, String/Number: xh_rvp10 like in the picture below:
Screen Shot 2016-09-24 at 14.42.20.png

NOTE: I have seen some boards (Asus I think?) that use xh_rvp08, if that is the case, drop that table instead.

Credit: Pike R. Alpha: Using an SSDT to inject USB and RehabMan: iasl61
 
Joined
Mar 28, 2013
Messages
17
Motherboard
Asus Maximus Hero VIII
CPU
i7-6700k
Graphics
980TI
Thanks a lot! Should the 30-Port Limit Patch also be removed from Clover?
 
Joined
Feb 21, 2011
Messages
313
Motherboard
GA-Z170X-UD3
CPU
I5-6600K
Graphics
Vega 64
Mac
MacBook Air, MacBook Pro
Mobile Phone
iOS
That depends on the number of ports you need. (The script will let you create more than 15 ports but will notify you if you do that).
 
Joined
Jan 3, 2013
Messages
33
Motherboard
GA-Z170X-Gaming 3
CPU
Intel Core i5 6600K 3.90 GHz
Graphics
NIVIDA GeForce GTX 970
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
Thanks for making the script! However I'm having some issues. When I look in IORegistryExplorer I can see HS01-14 available but no SS and only one USR port. I thought using your script would let me enable some of those SS ports. Is this not the case or am I doing something wrong? I've determined which ports I want and went through the script properly to my knowledge.
 

Attachments

Joined
Feb 21, 2011
Messages
313
Motherboard
GA-Z170X-UD3
CPU
I5-6600K
Graphics
Vega 64
Mac
MacBook Air, MacBook Pro
Mobile Phone
iOS
Thanks for making the script! However I'm having some issues. When I look in IORegistryExplorer I can see HS01-14 available but no SS and only one USR port. I thought using your script would let me enable some of those SS ports. Is this not the case or am I doing something wrong? I've determined which ports I want and went through the script properly to my knowledge.
Hmm are you also dropping xh_rvp10?

Please attach config.plist, USB-SSDT.aml, and clover bootlog.

It looks like it is not being correctly injected.
 
Joined
Jan 3, 2013
Messages
33
Motherboard
GA-Z170X-Gaming 3
CPU
Intel Core i5 6600K 3.90 GHz
Graphics
NIVIDA GeForce GTX 970
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
Hmm are you also dropping xh_rvp10?

Please attach config.plist, USB-SSDT.aml, and clover bootlog.

It looks like it is not being correctly injected.
Yeah I have xh_rvp10 included in clover configure. There are some extra things in the config.plist right now since I was trying other ways to get it working so I apologize for the mess.
 

Attachments

Joined
Feb 21, 2011
Messages
313
Motherboard
GA-Z170X-UD3
CPU
I5-6600K
Graphics
Vega 64
Mac
MacBook Air, MacBook Pro
Mobile Phone
iOS
Yeah I have xh_rvp10 included in clover configure. There are some extra things in the config.plist right now since I was trying other ways to get it working so I apologize for the mess.
Hmm config.plist and USB-SSDT.aml seems okay.

Your bootlog does not seem to show any table dropping, also what is the reason you are doing a legacy Clover instead of UEFI Clover?

Try using Maciasl and look for the xh_rvp10 table, should look something like this:
Screen Shot 2016-09-25 at 00.12.05.png
 
Joined
Jan 3, 2013
Messages
33
Motherboard
GA-Z170X-Gaming 3
CPU
Intel Core i5 6600K 3.90 GHz
Graphics
NIVIDA GeForce GTX 970
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
Hmm config.plist and USB-SSDT.aml seems okay.

Your bootlog does not seem to show any table dropping, also what is the reason you are doing a legacy Clover instead of UEFI Clover?

Try using Maciasl and look for the xh_rvp10 table, should look something like this:
View attachment 211988
If I try to open the SSDT file then I get the attached error page. Also I am using UEFI clover as in I am booting from my EFI partition, but that is the only boot log I could find.
 

Attachments

Joined
Feb 21, 2011
Messages
313
Motherboard
GA-Z170X-UD3
CPU
I5-6600K
Graphics
Vega 64
Mac
MacBook Air, MacBook Pro
Mobile Phone
iOS
If I try to open the SSDT file then I get the attached error page. Also I am using UEFI clover as in I am booting from my EFI partition, but that is the only boot log I could find.
Is that the USB-SSDT.aml file? If yes that is pretty weird as it open fine on my machine with maciasl. (The one you attached above).

The picture I post above shows all tables loaded on the machine, I just wanted to know if the table is being loaded.

You can find the boot.log in Clover Configurator (Left panel: Boot.log, Bottom Panel: Generate Log).
 
Joined
Jan 3, 2013
Messages
33
Motherboard
GA-Z170X-Gaming 3
CPU
Intel Core i5 6600K 3.90 GHz
Graphics
NIVIDA GeForce GTX 970
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
Is that the USB-SSDT.aml file? If yes that is pretty weird as it open fine on my machine with maciasl. (The one you attached above).

The picture I post above shows all tables loaded on the machine, I just wanted to know if the table is being loaded.

You can find the boot.log in Clover Configurator (Left panel: Boot.log, Bottom Panel: Generate Log).
That was the error when I try to open the file through the menu you included a picture of. However when I try to open the file itself, the only difference is the first line "Loading Acpi table from file iASLlQJ2PZ.aml - Length 00011198 (002BBE)"

Attached is the log I had clover generate. It looks like the table is dropped. However the port limit patch is not enabled for some reason.
 

Attachments

Top