Contribute
Register

Native Support for NVIDIA GTX 650 Ti and GTX 660 Graphics Cards in 10.8.3

Status
Not open for further replies.
Joined
Nov 19, 2012
Messages
23
Motherboard
MacBook Pro
CPU
3.66 Intel Core 2 Duo
Graphics
NVidia 9600
Mac
  1. MacBook Pro
Classic Mac
  1. iBook
Mobile Phone
  1. Android
  2. iOS
I have a question. Is the 680 Classified supported by 10.8.3? I am debating between the 680 Classified and the 680 OC. If some one can tell me that would be awesome.
 
Joined
May 31, 2011
Messages
8
Motherboard
Gigabyte Z68MA-D2H-B3
CPU
Core i7-2600K
Graphics
Asus R9 280X
Mac
Classic Mac
Mobile Phone
I just upgraded to an Asus Geforce GTX 660 from a Radeon 6850. It has been working perfectly so far, but I have to admit I'm very disappointed in the performance under 10.8.3. So far it doesn't seem any faster than the 6850 (under Starcraft 2 and Cinebench), whereas under Windows I'm seeing the expected 50%+ gains. Anyone else getting poor performance? Was just wondering if it's something in my setup or the drivers really are that bad. Luckily I do most of my gaming under Windows so it's not a huge deal but it'd still be nice to get full performance under OS X.
 

kun

Joined
Mar 3, 2013
Messages
5
Motherboard
MPR 2007
CPU
2.4 Core 2 Duo
Graphics
8600GT
Mac
Classic Mac
Mobile Phone
Article: Native Support for NVIDIA GTX 650 Ti and GTX 660 Graphics Cards in 10.8.3

I just upgraded to an Asus Geforce GTX 660 from a Radeon 6850. It has been working perfectly so far, but I have to admit I'm very disappointed in the performance under 10.8.3. So far it doesn't seem any faster than the 6850 (under Starcraft 2 and Cinebench), whereas under Windows I'm seeing the expected 50%+ gains. Anyone else getting poor performance? Was just wondering if it's something in my setup or the drivers really are that bad. Luckily I do most of my gaming under Windows so it's not a huge deal but it'd still be nice to get full performance under OS X.

same feeling here, gtx 650ti ssc is laggy playing COD 7
 
Joined
Apr 4, 2013
Messages
7
Motherboard
ML 10.8.3 on Z77-GS3h
CPU
Intel i7 3.5GHz 3770k
Graphics
NVidia GTX 650
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. iOS
Article: Native Support for NVIDIA GTX 650 Ti and GTX 660 Graphics Cards in 10.8.3

Hi All,

I have a GTX 650 Ti working fine in 10.8.3 (at least it seems to be performing well with FCP X and Photoshop) and sleep / wake works perfectly however in my system info it shows as NVidia D14P2-30.

Does anyone know why this is?


S. :thumbup:
 
Joined
Jan 22, 2011
Messages
9
Motherboard
Z77-DS3H
CPU
i5-2500K OC @ 4.4GHz
Graphics
R9 280X
Mac
  1. MacBook
Mobile Phone
  1. iOS
Article: Native Support for NVIDIA GTX 650 Ti and GTX 660 Graphics Cards in 10.8.3

Hi All,

I have a GTX 650 Ti working fine in 10.8.3 (at least it seems to be performing well with FCP X and Photoshop) and sleep / wake works perfectly however in my system info it shows as NVidia D14P2-30.

Does anyone know why this is?


S. :thumbup:


Its just cosmetic in the next update of the OS X this will be fixed.
 
Joined
Aug 12, 2010
Messages
64
Motherboard
Gigabyte GA-Z77MX-D3H TH
CPU
i7-3770K
Graphics
GTX 600
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. Android
Having an issue with Gigabyte GTX 660: Can't get dual monitors.
One monitor is 23in and the other 20in. Both Apple cinema dvi-d

This is a fresh install of 10.8.3 with GraphicsEnabler set on "No"
Have not installed Nvidia drivers.

Any suggestions? Should I use the Nvidia drivers?

Thanks
 
Joined
Aug 16, 2012
Messages
385
Motherboard
Asus X299 DELUXE II
CPU
i9-10940X
Graphics
Vega 56
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
Article: Native Support for NVIDIA GTX 650 Ti and GTX 660 Graphics Cards in 10.8.3

Having an issue with Gigabyte GTX 660: Can't get dual monitors.
One monitor is 23in and the other 20in. Both Apple cinema dvi-d

This is a fresh install of 10.8.3 with GraphicsEnabler set on "No"
Have not installed Nvidia drivers.

Any suggestions? Should I use the Nvidia drivers?

Thanks

Same Graphics card,
I had the same problem when i used GraphicsEnabler=No, used YES and all ports Will works correctly.
 
Joined
Aug 12, 2010
Messages
64
Motherboard
Gigabyte GA-Z77MX-D3H TH
CPU
i7-3770K
Graphics
GTX 600
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. Android
Article: Native Support for NVIDIA GTX 650 Ti and GTX 660 Graphics Cards in 10.8.3

Same Graphics card,
I had the same problem when i used GraphicsEnabler=No, used YES and all ports Will works correctly.

Just tried it... I get the white screen and it holds there.

Have I missed out on a kext?
 
Joined
Aug 12, 2010
Messages
64
Motherboard
Gigabyte GA-Z77MX-D3H TH
CPU
i7-3770K
Graphics
GTX 600
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. Android
Article: Native Support for NVIDIA GTX 650 Ti and GTX 660 Graphics Cards in 10.8.3

Just tried it... I get the white screen and it holds there.

Have I missed out on a kext?

Well that screwed up my system!

Had to remove the 660 re-enable the on board graphics, boot up in safe mode, GraphicsEnabler to "No", put the gpu back in and start again.
 
Status
Not open for further replies.
Top