Contribute
Register

Native Support for Intel Haswell CPUs in OS X 10.8.5

Status
Not open for further replies.
Joined
May 8, 2013
Messages
3
Motherboard
10.9.4
CPU
i5 3470
Graphics
Zotak GTX 650Ti
Mac
  1. iMac
  2. Mac mini
Classic Mac
Mobile Phone
  1. iOS
Article: Native Support for Intel Haswell CPUs in OS X 10.8.5

:rolleyes:I have successfully installed 10.8.5 onto my newly build Hackintosh, Bluetooth that comes with the board works but not the wifi card. Anyway, I do have another Native Wifi card that works. Sleep/ Wake, Sounds, Internet, iMessage, Facetime and iTunes, iCloud work. My score on Geekbench is 17490.
Only issue is sometimes when I boot up, it would freeze and I have to reboot again to make it work. I guess is just some fine tuning.
Thank You so much to this Website especially to Macman for his work, Moderator for his replies.:headbang:

GA-Z87X-OC FORCE
I7 4770K


Fine. How did you fixed the problem?
 
Joined
Feb 21, 2013
Messages
12
Motherboard
10.8.2
CPU
Intel
Graphics
Nvidia
Mac
Classic Mac
Mobile Phone
Article: Native Support for Intel Haswell CPUs in OS X 10.8.5

I have the same issue with my ASROCK H87M-PRO4 It works well with 10.8.4. Everything but ALC982 Audio is fine.

How did you get H87M-PRO4 working with 10.8.4?

I tried 10.8.5 patched kernel I found in the forum on 10.8.4 that is working fine in LGA775 box, but my ASROCK H87M-PRO4 reboots the same as with retail 10.8.5 install.

Could you please share your BIOS settings?

Thanks
 
Joined
Feb 21, 2013
Messages
12
Motherboard
10.8.2
CPU
Intel
Graphics
Nvidia
Mac
Classic Mac
Mobile Phone
Article: Native Support for Intel Haswell CPUs in OS X 10.8.5

I use the Default BIOS settings except for selecting the PCIe Graphics ( GTX 650 ) and a slightly higher memory voltage ( 1.27 V instead of nominal 1.25 ) which Windows 8 seems to require. Everything else is standard.
Hmm, I didn't mess with voltages since Win8 is working fine for me. I did set PCIe Graphics (but I don't see how one could disable one in CPU like on other boards that others report might help)...and it still just reboots once kexts are parsed... I will try to overvolt a bit tonight... What kernel parameters did you use exactly for 10.8.4?

I started a thread in the forum, so perhaps we should move discussion there
http://www.tonymacx86.com/mountain-lion-desktop-support/110415-10-8-5-asrock-h87m-pro4.html

I used UniBeast to build the USB then followed the MultiBeast procedure with Haswell Helper. Did you remember to manually copy the mach_kernel following installation as per the Haswell Helper instructions ?
Do you have a link to Haswell Helper... I am pretty sure I did everything but it won't hurt to double check... Essentially, I just replaced mach_kernel in working 10.8.4 (in LGA 775 and 1155) and updated chameleon to latest SVN (Chimera in MultiBeast reports lower numbers and some mentioned that latest chameleon is very important) and it works in other boards just not in ASROCK.

Unfortunately, the same procedure does not work for 10.8.5 because I can't get past the first stage of booting from a UniBeast USB built with 10.8.5

I could never boot off UniBeast USB (same reboots), so I built 3 drives using my existing macs with 10.8.4, 10.8.5 and 10.9.0 and none could go past immediate reboot...
 
Joined
Sep 12, 2013
Messages
7
Motherboard
Z87N-WIFI
CPU
4770K
Graphics
HD 4600
Mac
  1. MacBook
Classic Mac
Mobile Phone
  1. Android
Hey guys, first timer and tonymacx86 n00b here just trying to get 10.8.5 going on the newest customac haswell rig... after some minor issues I finally got mountain lion installed and restarted only to get stuck at the lines:

**** [IOBluetoothHostControllerUSBTrasport][configurePM] -- ERROR -- waited 30 seconds and still did not get the commandWakeup () notification -- this = 0xffffff8021766800 ****
[IOBluetoothHCIController::setConfigState] calling registerService

After this it just hangs (I'm using verbose mode and it would otherwise be the grey apple screen with grey spinning pinwheel) and I can't seem to get past this. :(

HALP!
 
Joined
Feb 28, 2012
Messages
72
Motherboard
Asus Z87 deluxe quad
CPU
i7-4770K
Graphics
NVIDIA GT
Mobile Phone
  1. iOS
In my asus p5w dh deluxe, the Belkin Components F8T013 Bluetooth Adapter (http://www.pjcomputers.net/belkinf8t013-1bluetoothusbadapter.aspx) works correctly in 10.8.4, But after update to 10.8.5, when I plug the USB, the PC hangs up without any message. Or if I try to boot with the BT connected. The system doesn't boot.

Somebody can help me?
Thanks

PD: I have installed "usb legacy support" from multibeast.
 
Joined
May 21, 2013
Messages
1
Motherboard
Mac Pro (début 2009)
CPU
2 x 3,46 GHz 6-Core Intel Xeon
Graphics
Radeon RX Vega 64 8 Go graphismes
Mac
  1. Mac Pro
Article: Native Support for Intel Haswell CPUs in OS X 10.8.5

My fisrt install :(

and the same message

**** [IOBluetoothHostControllerUSBTrasport][configurePM] -- ERROR -- waited 30 seconds and still did not get the commandWakeup () notification -- this = 0xffffff8021766800 ****​

[IOBluetoothHCIController::setConfigState] calling registerService​


After this it just hangs (I'm using verbose mode and it would otherwise be the grey apple screen with grey spinning pinwheel) and I can't seem to get past this. :(

Maybe I try install 10.8.4 with previous​
UniBeast ????


Thks for your help :banghead:
 
Joined
Aug 27, 2013
Messages
4
Mac
Classic Mac
Mobile Phone
Article: Native Support for Intel Haswell CPUs in OS X 10.8.5

:rolleyes:I have successfully installed 10.8.5 onto my newly build Hackintosh, Bluetooth that comes with the board works but not the wifi card. Anyway, I do have another Native Wifi card that works. Sleep/ Wake, Sounds, Internet, iMessage, Facetime and iTunes, iCloud work. My score on Geekbench is 17490.
Only issue is sometimes when I boot up, it would freeze and I have to reboot again to make it work. I guess is just some fine tuning.
Thank You so much to this Website especially to Macman for his work, Moderator for his replies.:headbang:

GA-Z87X-OC FORCE
I7 4770K

Did sound work for you? Is there anything on your board that did not work? Trying to find the right board to replace my asrock with.
 
Joined
Sep 21, 2013
Messages
6
Motherboard
PC
CPU
AMD 8350
Graphics
AMD 7890
Mac
Classic Mac
Mobile Phone
Article: Native Support for Intel Haswell CPUs in OS X 10.8.5

Please post the steps that you had to take to get it working. Thank you
 
Status
Not open for further replies.
Top