Contribute
Register

nⓩxtMac Pro - i9-9900k - Gigabyte Aorus z390 Pro - macOS Mojave - Sapphire Vega 64 Reference

Joined
Sep 13, 2014
Messages
46
Motherboard
Gigabyte Aorus z390 Pro
CPU
i9-9900k
Graphics
Vega 64
Mac
MacBook Pro
Mobile Phone
Android, iOS
Thanks, I changed my SMBios to 19.1 and it seems to be working completely fine :)
 
Last edited:
Joined
Apr 21, 2019
Messages
3
I have one issue... when I put Smbios like yours, just one of my two monitors work... I don't know what to do...
 
Joined
May 4, 2018
Messages
123
Motherboard
Gigabyte Z390 Aorus Pro
CPU
i9-9900K
Graphics
Vega 64
Mac
iMac, MacBook Pro, Mac Pro
Mobile Phone
iOS
I have one issue... when I put Smbios like yours, just one of my two monitors work... I don't know what to do...
Hi friend! Can I have a little more details, please? Current SMBIOS in use, system build specs, macOS Version, Clover Version, etc..
 
Joined
Sep 27, 2014
Messages
38
Motherboard
Z390 AORUS PRO
CPU
i9-9700K
Graphics
Vega 64
hey @MESwan any chance you could post your most up to date EFI folder?

I have tried to follow your first post to the letter (with and without the OC). Unfortunately though my machine (i9 + saphire 64) keeps suffering from:

1. random reboots
2. random screen going fully white and me having to reboot
3. random screen going black and all fans going to max

I'm at a loss in terms of what to do, or even where I could look for diagnostics to find out what's going on.
 
Joined
Jan 22, 2018
Messages
62
Motherboard
Asus Strix Z370-E
CPU
i9-9900K OC @ 5.0Ghz
Graphics
VEGA 64
Mac
iMac
Mobile Phone
iOS
hey @MESwan any chance you could post your most up to date EFI folder?

I have tried to follow your first post to the letter (with and without the OC). Unfortunately though my machine (i9 + saphire 64) keeps suffering from:

1. random reboots
2. random screen going fully white and me having to reboot
3. random screen going black and all fans going to max

I'm at a loss in terms of what to do, or even where I could look for diagnostics to find out what's going on.
Do you have the regular Sapphire Vega 64 or the Nitro+? I have similar issues with my Nitro+.
 
Joined
May 28, 2019
Messages
6
Motherboard
Z390 Aorus Pro
CPU
i9-9900K
Graphics
RX 570
Mac
Mac mini
Mobile Phone
iOS
Hello Team,

I have the same build but have different GPU. Do I need some extra settings for my Sapphire RX 570 Pulse 8GB after installing Mojave 10.14.5. Or I need to use only your DSDT.aml attached files?

P.S. my first language is not English, and I can make some mistakes in text, sorry for that.
 
Last edited:
Joined
May 28, 2019
Messages
6
Motherboard
Z390 Aorus Pro
CPU
i9-9900K
Graphics
RX 570
Mac
Mac mini
Mobile Phone
iOS
Hello Team,

I have the same build but have different GPU. Do i need some extra settings for my Sapphire RX 570 Pulse 8GB after installing Mojave 10.14.5. Or i need to use only your DSDT.aml attached files?

P.S. my first language is not English and i can make some mistakes in text, sorry for that.
Installed 10.14.5 using you guide. External USB HDD’s works.

But sleep have an issue. When I test it, display is turned off, but all leds on motherboard still work, and, after minute or half shutdown, all led’s, and turn it on motherboard back but display stay off. Try to wake it using Apple keyboard and Magic TrackPad (all using weird connections for now). After that, PC have reboot themselves, and now I have an boot error like “Couldn’t allocated runtime area”.

Even if I try to boot via bootable USB for installing, I still have this error and can’t load macOS. Can anybody help me please? Sleep kill macOS?

Update: i change from 64 to 32 and now can boot again in mscOS

Chipset → DVMT Pre-Alloc → 64M (change to 32M)
 

Attachments

Last edited:
Joined
May 28, 2019
Messages
6
Motherboard
Z390 Aorus Pro
CPU
i9-9900K
Graphics
RX 570
Mac
Mac mini
Mobile Phone
iOS
Hello Team,

I have stack on boot now. (See screenshot, please.) Anybody can help, please?

UPDATE: I reinstalled macOS using other BIOS settings. Now run well.. need more time to test all.
 

Attachments

Last edited:
Joined
May 23, 2019
Messages
8
Motherboard
Ga-x299-Designare EX
CPU
i9-7920X
Graphics
AMD Radeon VII
Why using UserKernelCache=No ? Does it had an influence on the performances or anything ?
 
Top