Contribute
Register

Mystery Kexts

Joined
Mar 31, 2017
Messages
35
Motherboard
ASUS Z170-WS
CPU
i7 6700
Graphics
GTX 1050 Ti
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Hi! I noticed an issue with older kext versions being reported with kextstat | grep -v com.apple. For example, Lilu 1.3.9 is shown but EFI/EFI/CLOVER/kexts/other has 1.4.2 installed (and I've verified there are NO other versions anywhere in my EFI subfolders or /S/L/E or /L/E. I'm definitely looking at the right EFI (the ONLY EFI) for my boot volume. I've rebuilt the kext cache and restarted multiple times in the course of my searching/experimenting.

Even weirder: WhateverGreen 1.3.4 is showing via kextstat but that's no longer installed (I removed it awhile back) and I can't figure out where it's even getting loaded from.

I used kextfind to list all paths and searched for Lilu and WhateverGreen but they don't appear anywhere (I assume because they're injected from somewhere). Hackintool also shows WhateverGreen as being installed. None of these tools tell me from where they're installed, though, so I'm really struggling here.

I've been searching the forums but can't find a post that quite hits this (maybe I'm not using the right terms). It's time to ask for help. :)
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
24,241
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
Maybe they are cached.

In Terminal :
Code:
sudo kextcache -i /
 
Top