Contribute
Register

My new hackintosh restart after shut down

Status
Not open for further replies.
Joined
Jan 19, 2018
Messages
220
Motherboard
Gigabyte Z390UD
CPU
i9-9900
Graphics
UHD 630 + RX 580
Mac
  1. iMac
Mobile Phone
  1. Android
Joined
Jan 19, 2018
Messages
220
Motherboard
Gigabyte Z390UD
CPU
i9-9900
Graphics
UHD 630 + RX 580
Mac
  1. iMac
Mobile Phone
  1. Android
Easy way : download KextBeast from the tools download section of this website (put kext to update on desktop and follow KextBeast instructions - add it in L/E)

Hello @favoriti
I have tried to install KextBeast, but problem still exist.
Then I tried to have a fresh install of High Sierra. This time, I put the option of FakeSMC (previously wasn't), does not install USB Limit and then update with KextBeast. The system properly shuts down when keyboard is connected directly to USB port, but not when the keyboard is connected through USB Hub.
Even with keyboard connected directly to USB port, and hub connected to other port with no devices attached to it, the system stil shutdown and then restart again.

At least, now I have a way to properly shut down the system (taking out the Hub before shutdown). Yet, it will be good if one day any update can fix the problem with the USB hub.

Thanks.
 
Joined
Jul 22, 2017
Messages
82
Motherboard
ASUS H170 Pro Gaming
CPU
i5-7600
Graphics
GTX 750 TI
Mac
  1. iMac
Classic Mac
  1. Classic
  2. LC
Mobile Phone
  1. Android
  2. iOS
Hello @favoriti
I have tried to install KextBeast, but problem still exist.
Then I tried to have a fresh install of High Sierra. This time, I put the option of FakeSMC (previously wasn't), does not install USB Limit and then update with KextBeast. The system properly shuts down when keyboard is connected directly to USB port, but not when the keyboard is connected through USB Hub.
Even with keyboard connected directly to USB port, and hub connected to other port with no devices attached to it, the system stil shutdown and then restart again.

At least, now I have a way to properly shut down the system (taking out the Hub before shutdown). Yet, it will be good if one day any update can fix the problem with the USB hub.

Thanks.
What USB HUB did you attach to mobo? 2.0 or 3.0 type?
We wonder that issue can be new update of High Sierra changed the UBS table interpretation and power management involved, if possible, maybe you can try making SSDT for USB table, it's mobo specific I believe. Waiting for a universal fix yet.
https://www.tonymacx86.com/threads/10-11-0-10-11-3-skylake-starter-guide.179221/
 
Joined
Jan 19, 2018
Messages
220
Motherboard
Gigabyte Z390UD
CPU
i9-9900
Graphics
UHD 630 + RX 580
Mac
  1. iMac
Mobile Phone
  1. Android
What USB HUB did you attach to mobo? 2.0 or 3.0 type?
I use a USB hub with USB2.0 and USB3.0,each port with a on/off switch. I tried connecting this hub to front port USB3.0 and USB2.0,but the problem still exist. It only solve when I disconnect the hub completely during shutdown. Connecting the hub with all ports switched off also not helping.

We wonder that issue can be new update of High Sierra changed the UBS table interpretation and power management involved, if possible, maybe you can try making SSDT for USB table, it's mobo specific I believe. Waiting for a universal fix yet.
https://www.tonymacx86.com/threads/10-11-0-10-11-3-skylake-starter-guide.179221/
I will need to learn on this SSDT, as I am still a noob in this hackintosh. However, I found thread on intel integrated graphics power management, that I will look and try to implement on my machine. Appreciate very much if you can share a link about SSDT that I can explore further.
 
Joined
Jan 19, 2018
Messages
220
Motherboard
Gigabyte Z390UD
CPU
i9-9900
Graphics
UHD 630 + RX 580
Mac
  1. iMac
Mobile Phone
  1. Android
Today check again on my machine.
When I plug keyboard only in USB3.0,the system restart again. But when I change to USB2.0, the system can shutdown properly. Both without any USB hub connected to any ports.
I hope it is not becoming a random occurence, as it will make things more difficult.
Any hint will be very helpful.
 
Joined
Nov 26, 2017
Messages
283
Motherboard
Dell Inspiron 5379 - 1.13 - open core
CPU
i5-8250U
Graphics
UHD 620, 1920x1080
Mac
  1. iMac
  2. MacBook Air
Mobile Phone
  1. Android
fix the problem with the USB hub
You can also try different bios power settings depending on your mobo (enable ERP, disable wake on lan) or High Sierra energy saver settings (disable network reactivation) - also check you have last bios revision
Good luck !
 
Joined
Apr 15, 2018
Messages
2
Motherboard
GIGABYTE Z370 AORUS Gaming 7
CPU
Intel Core i7-8700K
Graphics
MSI NVIDIA GeForce GTX 1050 Ti Gaming
When I plug keyboard only in USB3.0,the system restart again. But when I change to USB2.0, the system can shutdown properly. Both without any USB hub connected to any ports.
I hope it is not becoming a random occurence, as it will make things more difficult.
Any hint will be very helpful.

Thank you! This helps. I had the same situation. I have a USB hub and the shutdown does not work and after three seconds the system restarts. After changing the USB port for the hub the system shutdowns and stays in the shutdown state! And I got managed to disabled the LEDs as well. BIOS => RGB Fusion => Off.
 
Joined
Dec 27, 2018
Messages
5
Motherboard
ASUS Strix Z370-G
CPU
Intel Core i7 8700K
Graphics
AMD Radeon RX 580 8GB
Today check again on my machine.
When I plug keyboard only in USB3.0,the system restart again. But when I change to USB2.0, the system can shutdown properly. Both without any USB hub connected to any ports.
I hope it is not becoming a random occurence, as it will make things more difficult.
Any hint will be very helpful.
This was the solution for my same problem. Wouldn't had expect this. Thanks so much!
 
Joined
Jun 15, 2013
Messages
236
Motherboard
GA-Z77X-UP4 TH
CPU
i7 3770K OC:4.2GHz
Graphics
GTX960 (Asus strix)
Mac
  1. MacBook Pro
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
I fixed my shutdown problem when i upgraded from Sierra to High Sierra by removing GeneralUSBXHCI.kext from /Library/Extensions. It seems USB3 still works.
 
Status
Not open for further replies.
Top