Contribute
Register

My Hackintosh doesn't recognize the ASUS Rog Strix RX580

Joined
Aug 17, 2019
Messages
10
Motherboard
Gigabyte B360m DS3H
CPU
Intel i7 8700
Graphics
Intel UHD 630
Hello Forum I introduce myself, I'm Dannyelpeluo and this is my first thread in this forum and thanks to him I build my first Hackintosh.

I tried installing with the CLOVER the .KEXT of Lilu and Whatevergreen and the RadeonDeInit and the iGPU intel 630 still appears. It´s my first Hackintosh and so far it has been working with the iGPU, I am a beginner and would appreciate some help.

MotherBoard: GigaByte B360M
CPU: Intel i7 8700
Ram: x2 modules of 8 Gb corsair 3000 mHz
PS: corsair TX650

Thanks
 

Attachments

pastrychef

Moderator
Joined
May 29, 2013
Messages
11,223
Motherboard
Asus ROG Strix Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
Hello Forum I introduce myself, I'm Dannyelpeluo and this is my first thread in this forum and thanks to him I build my first Hackintosh.

I tried installing with the CLOVER the .KEXT of Lilu and Whatevergreen and the RadeonDeInit and the iGPU intel 630 still appears. It´s my first Hackintosh and so far it has been working with the iGPU, I am a beginner and would appreciate some help.

MotherBoard: GigaByte B360M
CPU: Intel i7 8700
Ram: x2 modules of 8 Gb corsair 3000 mHz
PS: corsair TX650

Thanks
Disable RadeonDeInit.
 
Joined
May 11, 2011
Messages
691
Motherboard
Asrock B365M Phantom Gaming
CPU
i5-9600KF
Graphics
RX 580
Mobile Phone
iOS
Hello Forum I introduce myself, I'm Dannyelpeluo and this is my first thread in this forum and thanks to him I build my first Hackintosh.

I tried installing with the CLOVER the .KEXT of Lilu and Whatevergreen and the RadeonDeInit and the iGPU intel 630 still appears. It´s my first Hackintosh and so far it has been working with the iGPU, I am a beginner and would appreciate some help.

MotherBoard: GigaByte B360M
CPU: Intel i7 8700
Ram: x2 modules of 8 Gb corsair 3000 mHz
PS: corsair TX650

Thanks
In Bios enable Multi Monitor support and PEG (RX580) as primary, plug in the hdmi cable into the RX 580 and boot into macOS, also use whatevergreen and lilu.
 
Joined
Jun 7, 2013
Messages
40
Motherboard
Alienware Aurora R7
CPU
i7-8700
Graphics
RX 580
Mac
MacBook Pro, Mac mini
Mobile Phone
iOS
Do not disable RadeonDeInit

Instead

either remove WhateverGreen or add this agdpmod=pikera boot flag
 
Joined
Aug 17, 2019
Messages
10
Motherboard
Gigabyte B360m DS3H
CPU
Intel i7 8700
Graphics
Intel UHD 630
Sorry i try disable the RadeonDeInit and now i turn on the hackintos whit an hdmi to the GPU but now i can't see nothin after the loading apple logo but the monitor have singnal. now there is any singnal from iGPU whit the WGA
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
11,223
Motherboard
Asus ROG Strix Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
Sorry i try disable the RadeonDeInit and now i turn on the hackintos whit an hdmi to the GPU but now i can't see nothin after the loading apple logo but the monitor have singnal. now there is any singnal from iGPU whit the WGA
There's not supposed to be any signal from IGPU. Make sure that you have your RX 580 set as primary display in BIOS. Make sure that your monitor is connected to your RX 580.
 
Joined
Aug 17, 2019
Messages
10
Motherboard
Gigabyte B360m DS3H
CPU
Intel i7 8700
Graphics
Intel UHD 630
There's not supposed to be any signal from IGPU. Make sure that you have your RX 580 set as primary display in BIOS. Make sure that your monitor is connected to your RX 580.
[
There's not supposed to be any signal from IGPU. Make sure that you have your RX 580 set as primary display in BIOS. Make sure that your monitor is connected to your RX 580.
The only thing similar in the Gigabyte BIOS is Initial Display output and this selected PCle 1 Slot continues to do the same, the GPU fans turn on at startup but stop quickly, the ROG RGB turns on and off in red. in case it is important
1572050270439972090621499761979.jpg

15720501726966191185647940898104.jpg15720503145974423742391077733857.jpg
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
11,223
Motherboard
Asus ROG Strix Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
Joined
Aug 17, 2019
Messages
10
Motherboard
Gigabyte B360m DS3H
CPU
Intel i7 8700
Graphics
Intel UHD 630
Now I don't know how to start Hackintosh again. I can only see the apple logo almost loaded, with the VGA it does not work.
I don't know what I've touched ...
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
11,223
Motherboard
Asus ROG Strix Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
Now I don't know how to start Hackintosh again. I can only see the apple logo almost loaded, with the VGA it does not work.
I don't know what I've touched ...
Whatever change you made, you can change it back in the Clover boot menu.
 
Top