Contribute
Register

My First G5 Mod (Wolf in Sheep's Clothing) [Upgraded]

Joined
Jun 11, 2012
Messages
357
Motherboard
GA-Z87X-UD3H
CPU
i7-4770K
Graphics
GTX 960
Mac
MacBook Pro
Classic Mac
Apple, Centris, LC, Plus, Power Mac, PowerBook, SE
Mobile Phone
iOS
Very nice machine. The cable management and attention to detail inside the box is first-rate. Thanks for the detailed pics and descriptions!

Thanks! I appreciate your comments.
 
Joined
Aug 1, 2012
Messages
5
Motherboard
Gigabyte H77N
CPU
3770K
Graphics
GTX580
Mac
MacBook Air, MacBook Pro
Mobile Phone
Android, iOS
very nice mod, if i could get my hands on a G5 case, i will use this as my guide...

thanks...
 
Joined
Mar 6, 2013
Messages
1
Motherboard
.
CPU
.
Graphics
.
Mac
Classic Mac
Mobile Phone
What part of the PSU did you screw into in order to attach it to the top shelf?
 
Joined
Jun 11, 2012
Messages
357
Motherboard
GA-Z87X-UD3H
CPU
i7-4770K
Graphics
GTX 960
Mac
MacBook Pro
Classic Mac
Apple, Centris, LC, Plus, Power Mac, PowerBook, SE
Mobile Phone
iOS
There are 4 screws around the fan holding the fan grille to the power supply body. I used 3 of them. I drilled holes in the top shelf that lined up with them and then removed the screws and re-inserted them first through the holes drilled in the top shelf into the power supply.

chaos
 
Joined
Jun 11, 2012
Messages
357
Motherboard
GA-Z87X-UD3H
CPU
i7-4770K
Graphics
GTX 960
Mac
MacBook Pro
Classic Mac
Apple, Centris, LC, Plus, Power Mac, PowerBook, SE
Mobile Phone
iOS
My First G5 Mod (Wolf in Sheep's Clothing)

UPDATE:
Wolf has been upgraded to Haswell and Mavericks!

- Intel Core i7 4770K Unlocked Quad Core LGA1150 3.5Ghz Haswell
- GigaByte GA-Z87X-UD3H Z87 Express chipset
- 2x8GB Kingston HyperX DDR3-1600 XMP Dual Channel
- ASUS Geforce GTX 660 OC


Here are my install procedures:

BIOS Settings
--------------
Ensure Version F7
- Press F7 to load Optimized Defaults
- Performance > X.M.P. > Profile 1
- Peripherals > xHCI Mode > AUTO
- Peripherals > xHCI Hand-OFF > ENABLED
- Peripherals > EHCI Hand-OFF > ENABLED
- Power Management > Wake on Lan > DISABLED


Instructions to install Max OSX 10.9.1
-------------------------------------
** Graphics card is installed and monitor is plugged in via DVI **


1) Built Unibeast Installer using Mavericks 10.9.1 and Unibeast 10.9.1
2) Insert a USB2 4 Port Slot Adapter
3) Connect USB stick to USB 2.0 port on slot adapter, ensure keyboard/mouse is also connected to the adapter
4) Boot USB stick (F12)
5) Install Mavericks to fresh hard drive
6) Boot into Mavericks install
7) Run Multibeast and install
Quick Start > DSDT Free
Drivers > Audio Realtek ALCxxx > Without DSDT > ALC898
Drivers > Audio Realtek ALCxxx > Without DSDT > HDAEnabler
Drivers > Disk > 3rdPartySATA
Drivers > Misc > FakeSMC
Drivers > Misc > FakeSMC PlugIns
Drivers > Misc > FakeSMC HWMonitor App
Drivers > Misc > USB3.0 Universal
Drivers > Network > hnak's AppleIntelE1000e v2.4.14
Drivers > System > AppleRTCPatch for CMOS Reset
BootLoaders > Chimera 2.2.1
BootLoaders > Boot Options > Basic Boot Options
BootLoaders > Boot Options > GenerateCPUStates
BootLoaders > Boot Options > Hibernate Mode - Desktop
BootLoaders > Boot Options > Use Kernel Cache
BootLoaders > Boot Options > 1080p Display (Modified to 1920x1200x32)
BootLoaders > System Definition > Mac Pro 3,1
BootLoaders > Themes > tonymacx86 Black



8) Run ChameleonWizard
Edit SMBIOS
Randomize Serial and Set MacPro 3.1 designation

9) Copy Modules/FileNVRAM.dylib to Extras folder
 
Joined
Jun 11, 2012
Messages
357
Motherboard
GA-Z87X-UD3H
CPU
i7-4770K
Graphics
GTX 960
Mac
MacBook Pro
Classic Mac
Apple, Centris, LC, Plus, Power Mac, PowerBook, SE
Mobile Phone
iOS
It was time to upgrade again.

New Hardware:
- Intel i7 4790K 4.0/4.4 Ghz Quad Core CPU (Devil's Canyon)
- 4x8 (32GB) Kingston HyperX DDR3-1866 CL10 Black
- EVGA GeForce GTX 960 2GB
- Crutial MX100 2.5" 512GB SSD
- 3 Additional 3TB Hard Drives

The operating system has been updated to El Capitan 10.11.5

BIOS Settings
-------------
Flashed BIOS to F9
Load User Defaults
Set NumLock OFF
System Information > Intel Virtualization Technology: OFF
System Information > Windows 8 Features: OtherOS <default>
Peripherals > Serial Port A: Disabled
Peripherals > XHCI Handoff: Enabled <default>

Only Target HD (512GB) installed in system
Uniboot USB in USB2 (black) on rear (bottom of motherboard)

INSTALL
-------
Remove Graphics Card and all HD's not involved in install
Boot from USB (using Clover)
Boots to Installer
Launched DiskUtility and erased 320HD, named ElCapHD
Installed on ElCapHD (16 minutes) - completes and then reboots
<another progress bar>
Welcome!
Select Region, Keyboard, Create Account, Select Time Zone
Arrive at Desktop!

Working:
- About this Mac:
iMac (27-inch Late 2013)
3.99Ghz Intel Core i7
32GB 1777 Mhz DDR3
EVGA GeForce GTX 960 2GB
- Networking

Run Software Update
- Installed iTunes 12.4

Run MultiBeast
QuickStart > UEFI Boot Mode
Drivers > Audio Realtek ALCxxx > ALC898
Drivers > Disk > 3rd Party SATA
Drivers > Disk > 3rd Party eSATA
Drivers > Misc > FakeSMC v6.18-313-g671f3.1c.1707
Drivers > Misc > FakeSMC Plugins v6.18-313-g671f3.1c.1707
Drivers > Misc > FakeSMC HWMonitor Application v6.18-313-g671f3.1c.1707
Drivers > Network > Intel > AppleIntelE1000e v3.3.3
Drivers > USB > 7/8/9 Series USB Support
Bootloaders > Clover v2.3k r3423 UEFI Boot Mode
Customize >System Definitions > iMac > iMac 14,2
Drivers > Graphics > Inject NVIDIA

- Sound
Orange Port is First Line Out in Sound Prefs list
Black Port is Second Line Out in Sound Prefs list
Ensure that both "Output" and "Sound Effects > Play sound effects through" are set to the same Line Out for port in use above

- USB 3 works (speed not verified)
- HW Monitor working
- Installed NVidia Web Drivers for OS X
- Needed to Inject NVidia into Clover to fix colored snow images

chaos
 
Last edited:
Joined
Jun 11, 2012
Messages
357
Motherboard
GA-Z87X-UD3H
CPU
i7-4770K
Graphics
GTX 960
Mac
MacBook Pro
Classic Mac
Apple, Centris, LC, Plus, Power Mac, PowerBook, SE
Mobile Phone
iOS
I just updated to 10.11.6 using the combo updater from here:https://support.apple.com/kb/DL1885?locale=en_US

I rebooted, and then installed the latest NVIDIA beta drivers, and then rebooted a second time.

Everything works perfectly. Easiest update ever, guys. Kudos!

chaos
 
Joined
Jun 11, 2012
Messages
357
Motherboard
GA-Z87X-UD3H
CPU
i7-4770K
Graphics
GTX 960
Mac
MacBook Pro
Classic Mac
Apple, Centris, LC, Plus, Power Mac, PowerBook, SE
Mobile Phone
iOS
Photobucket decided that hosting my images was costing them too much money and so asked me to upgrade my free account to one that would cost $400 per year. I decided to remove my 250 or so photos from Photobucket and host them myself. So... photos have been restored! :)

- chaos
 
Joined
Jun 11, 2012
Messages
357
Motherboard
GA-Z87X-UD3H
CPU
i7-4770K
Graphics
GTX 960
Mac
MacBook Pro
Classic Mac
Apple, Centris, LC, Plus, Power Mac, PowerBook, SE
Mobile Phone
iOS
Photos restored
 
Joined
Jun 11, 2012
Messages
357
Motherboard
GA-Z87X-UD3H
CPU
i7-4770K
Graphics
GTX 960
Mac
MacBook Pro
Classic Mac
Apple, Centris, LC, Plus, Power Mac, PowerBook, SE
Mobile Phone
iOS
Photo links restored.
/J
 
Top