Contribute
Register

MultiBeast Failure: Failed to bless helper. not in safe mode.

Status
Not open for further replies.
Joined
Sep 23, 2013
Messages
3
Motherboard
GA-Z87MX-D3H
CPU
i7-4770
Graphics
4600, GTX670
Mac
  1. MacBook
Mobile Phone
  1. iOS
New install on ssd. the system is up and running but i can not do the post install. I have not found a reason for the failure.

Failed to bless helper. Error: Error Domain=CFErrorDomainLaunchd Code=2 "(null)"
  1. macOS version: macOS 10.13.6 (17G65)
  2. MultiBeast version: MultiBeast 10.4.0-20180812
  3. MultiBeast choices: Below
  4. Destination files system type: APFS
  5. MultiBeast.log contents: Below
  6. install.log contents for the choices that you are installing: Below
System Software Overview:
System Version: macOS 10.13.6 (17G65)
Kernel Version: Darwin 17.7.0
Boot Volume: Light
Boot Mode: Normal
User Name: wb (admin)
Secure Virtual Memory: Enabled
System Integrity Protection: Disabled

MultiBeast Configuration - 2018-10-26 22:41:09 ----------------------------------------------------------------- Quick Start > Clover UEFI Boot Mode
Drivers > Audio > Realtek ALCxxx > ALC892 Drivers > Misc > FakeSMC
Bootloaders > Clover UEFI Boot Mode
Customize > System Definitions > iMac > iMac 14,2


MultiBeast.log contents:
10/26/18 20:20:51 - Starting MultiBeast 10.4.0-20180812
10/26/18 20:21:08 - Failed to bless helper. Error: Error Domain=CFErrorDomainLaunchd Code=2 "(null)"
10/26/18 22:09:55 - Starting MultiBeast 10.4.0-20180812
10/26/18 22:10:30 - Failed to bless helper. Error: Error Domain=CFErrorDomainLaunchd Code=2 "(null)"
10/26/18 22:12:16 - Failed to bless helper. Error: Error Domain=CFErrorDomainLaunchd Code=2 "(null)"
10/26/18 22:18:09 - Starting MultiBeast 10.4.0-20180812
10/26/18 22:18:34 - Failed to bless helper. Error: Error Domain=CFErrorDomainLaunchd Code=2 "(null)"




install.log contents for the choices that you are installing: macOS 10.13.6
2018-10-26 21:57:59-07 localhost Installer Progress[81]: Progress UI App Starting
2018-10-26 21:58:04-07 iMac storagekitd[287]: Starting SKDaemon...
2018-10-26 21:58:04-07 iMac storagekitd[287]: Client entitled for destructive operations
...
2018-10-26 21:59:10-07 iMac deleted[567]: diskmanagement: [DMManager(PrivateMethods) clientConforms:error:]: currentThread=5891=0x1703 expectedThread=21003=0x520b
2018-10-26 21:59:10-07 iMac system_installd[575]: installd: Starting
2018-10-26 21:59:10-07 iMac installd[571]: installd: Starting
2018-10-26 21:59:10-07 iMac installd[571]: installd: uid=0, euid=0
2018-10-26 21:59:10-07 iMac system_installd[575]: installd: uid=0, euid=0
2018-10-26 21:59:10-07 iMac Setup Assistant[550]: SUSoftwareUpdateController: Authorizing now
2018-10-26 21:59:10-07 iMac softwareupdated[440]: SUUpdateServiceClient: (Setup Assistant) is Apple Signed!
2018-10-26 21:59:10-07 iMac softwareupdated[440]: Adding client SUUpdateServiceClient pid=550, uid=503, installAuth=NO rights=(), transactions=0 (/System/Library/CoreServices/Setup Assistant.app/Contents/MacOS/Setup Assistant)
2018-10-26 21:59:10-07 iMac deleted[567]: diskmanagement: [DMManager(PrivateMethods) clientConforms:error:]: currentThread=23299=0x5b03 expectedThread=21003=0x520b
2018-10-26 21:59:10-07 iMac Installer Progress[551]: Quitting: There are no connected processes and there is no UI showing
2018-10-26 21:59:10-07 iMac Installer Progress[551]: Quiting Progress App
2018-10-26 21:59:10-07 iMac Installer Progress[551]: Setting window alpha values to 0.0
2018-10-26 21:59:10-07 iMac deleted[567]: diskmanagement: [DMManager(PrivateMethods) clientConforms:error:]: currentThread=24323=0x5f03 expectedThread=21003=0x520b
2018-10-26 21:59:10-07 iMac system_installd[575]: PackageKit: Adding client PKInstallDaemonClient pid=440, uid=200 (/System/Library/CoreServices/Software Update.app/Contents/Resources/softwareupdated)
2018-10-26 21:59:10-07 iMac softwareupdated[440]: SUScan: Scan for client pid 440 (/System/Library/CoreServices/Software Update.app/Contents/Resources/softwareupdated)
2018-10-26 21:59:10-07 iMac deleted[567]: diskmanagement: [DMManager(PrivateMethods) clientConforms:error:]: currentThread=41987=0xa403 expectedThread=21003=0x520b
2018-10-26 21:59:10-07 iMac softwareupdated[440]: Got status 200
2018-10-26 21:59:11-07 iMac softwareupdated[440]: SUScan: Using catalog https://swscan.apple.com/content/ca...ion-snowleopard-leopard.merged-1.sucatalog.gz
2018-10-26 21:59:11-07 iMac systemmigrationd[556]: Connected to daemon. Language set to: English
2018-10-26 21:59:11-07 iMac Setup Assistant[550]: Connected to daemon. Language set to: English
2018-10-26 21:59:11-07 iMac Setup Assistant[550]: Connected to daemon. Language set to: English
2018-10-26 22:16:12-07 iMac softwareupdated[507]: xpc_add_bundle /System/Library/PrivateFrameworks/SoftwareUpdate.framework/XPCServices/ManualProductStasherService.xpc
2018-10-26 22:16:12-07 iMac softwareupdate_notify_agent[506]: Notifying with params: {
UpdateNotificationsOnly = 1;
}
2018-10-26 22:16:12-07 iMac softwareupdate_notify_agent[506]: appstoreupdateagent notified
2018-10-26 22:16:12-07 iMac softwareupdate_notify_agent[506]: AssertionMgr: Cancel com.apple.softwareupdate.NotifyAgentAssertion-LoginDone assertion for pid 506, id 0x80CD
2018-10-26 22:16:12-07 iMac softwareupdated[507]: SUUpdateServiceClient: (storeassetd) is Apple Signed!
2018-10-26 22:16:12-07 iMac softwareupdated[507]: Adding client SUUpdateServiceClient pid=511, uid=503, installAuth=NO rights=(), transactions=0 (/System/Library/PrivateFrameworks/CommerceKit.framework/Versions/A/Resources/storeassetd)
2018-10-26 22:16:12-07 iMac storeassetd[511]: Query for available updates: FINISHED
 
Last edited:
Joined
Sep 23, 2013
Messages
3
Motherboard
GA-Z87MX-D3H
CPU
i7-4770
Graphics
4600, GTX670
Mac
  1. MacBook
Mobile Phone
  1. iOS
Found the answer to my trouble by following the post #5 from
https://www.tonymacx86.com/threads/multibeast-error-failed-to-install-check-log-please-help.145181/

MacMan"
To around this requires you to execute the following commands in Terminal:

Code:
sudo launchctl unload /Library/LaunchDaemons/com.tonymacx86.InstallHelper
sudo rm /Library/LaunchDaemons/com.tonymacx86.InstallHelper.plist
sudo rm /Library/PrivilegedHelperTools/com.tonymacx86.InstallHelper

Then download and run MultiBeast again."


Now I am on to getting my GTX670 to work properly
 
Joined
Jan 27, 2018
Messages
111
Motherboard
ASUS Prime Z390-A
CPU
i7-9700K
Graphics
HD 630, RX 580
Mac
  1. Mac mini
Mobile Phone
  1. iOS
sudo launchctl unload /Library/LaunchDaemons/com.tonymacx86.InstallHelper.plist

This command gives me:

/Library/LaunchDaemons/com.tonymacx86.InstallHelper.plist: Could not find specified service

sudo rm /Library/LaunchDaemons/com.tonymacx86.InstallHelper.plist sudo rm /Library/PrivilegedHelperTools/com.tonymacx86.InstallHelper
This deletes files. But then I even re-download and run MultiBeast 11.0.1 - Mojave - got the same error in its log:

03/27/19 21:34:07 - Starting MultiBeast 11.0.1-1
03/27/19 21:34:35 - Failed to bless helper. Error: Error Domain=CFErrorDomainLaunchd Code=9 "(null)"


Please help me..


1. 10.14.4 (18E226)
2. MB 11.0.1-1
3. Any I select in MB is failed. I tried just change SMBIOS
4. All my disks is APFS
5.
MultiBeast.log:
03/28/19 01:46:56 - Starting MultiBeast 11.0.1-1
03/28/19 01:47:03 - Failed to bless helper. Error: Error Domain=CFErrorDomainLaunchd Code=9 "(null)"

var.log: iMac system_installd[510]: PackageKit: Install sandbox purging reclaimed Zero KB
 
Last edited:
Joined
Jan 27, 2018
Messages
111
Motherboard
ASUS Prime Z390-A
CPU
i7-9700K
Graphics
HD 630, RX 580
Mac
  1. Mac mini
Mobile Phone
  1. iOS
Sadly, to "fix" this, I have to reinstall my system from scratch..
 
Status
Not open for further replies.
Top