Contribute
Register

Multibeast 9.2 didn't copy the sound & network kexts to EFI/Clover/kexts/10.12

Status
Not open for further replies.
Joined
Feb 25, 2017
Messages
17
Motherboard
ASRock B75M-ITX
CPU
i7-3770
Graphics
GTX 660
I'm new to hackintosh installs but I followed the guide on installing Sierra to the letter. I must have done 5-10 different installs trying to get this to work. I found that MultiBeast 9.2 installation completed after I mounted the EFI drive with Clover. After installation completed the ethernet network & sound didn't work. I had to copy the RealtekRTL8111.kext & VoodooHDA.kext manually

from | /Library/Extensions/
to | EFI/Clover/kexts/10.12

Then the network and sound started working. But I still have a bunch of .kext files sitting in /Library/Extensions/ folder. Here's a list

➜ Extensions ls
ACS6x.kext FakePCIID.kext HighPointIOP.kext
AHCI_3rdParty_SATA.kext FakePCIID_XHCIMux.kext HighPointRR.kext
AHCI_Intel_Generic_SATA.kext FakeSMC.kext NullCPUPowerManagement.kext
ATTOCelerityFC8.kext FakeSMC_ACPISensors.kext PromiseSTEX.kext
ATTOExpressSASHBA2.kext FakeSMC_CPUSensors.kext RealtekRTL8111.kext
ATTOExpressSASRAID2.kext FakeSMC_GPUSensors.kext SoftRAID.kext
ArcMSR.kext FakeSMC_LPCSensors.kext VoodooHDA.kext
CalDigitHDProDrv.kext GenericUSBXHCI.kext
➜ Extensions pwd
/Library/Extensions

  • Is this expected?
  • Should I copy these kext files manually to EFI/Clover/kexts/10.12 folder?

System this is installed on
  • Core i7 3770
  • GTX 660
  • ASRock B75M-ITX
    • Realtek ALC892 Audio Codec
    • Realtek RTL8111E LAN
 
Joined
Feb 25, 2017
Messages
17
Motherboard
ASRock B75M-ITX
CPU
i7-3770
Graphics
GTX 660
Did you read the descriptions in MultiBeast or the pdf before running it?
I took at look at it more closely again and see what you're saying. So it's expected to install in /Library/Extensions. Is having to copy to EFI volume to get those things working also expected or should the sound/networking work from /Library/Extensions?
 
Status
Not open for further replies.
Top