Contribute
Register

MSI Z490 Tomahawk + i7-10700k / Catalina 15.5.5 / OpenCore

Status
Not open for further replies.
Joined
Jul 7, 2015
Messages
159
Motherboard
MSI Z490-a Pro
CPU
i7-10700k
Graphics
UHD 630
Mobile Phone
  1. iOS
Update: I thought my hack was working fine now after redoing the open core from the website instructions, but there is still some slight jittering / lag in performance. When I boot, it lists a few errors and then boots in successfully, and I wonder if those errors are related. Is there no way to use Clover on a z490 build? I never had issues with clover (since Mavericks days), but open core is having audio drops, lag, freezes etc like when I had an AMD hack.
 
Joined
Feb 22, 2019
Messages
67
Motherboard
Gigabyte Z390M
CPU
i5-9400
Graphics
RTX 580
Mac
  1. iMac
I think we all would agree that Clover is not compatible with 10th generation processors (z490 motherboards). Maybe in 6-12 months, but not now. OC is the only option. Unfortunately for me, I can't even boot using OC yet.
 
Joined
Feb 22, 2019
Messages
67
Motherboard
Gigabyte Z390M
CPU
i5-9400
Graphics
RTX 580
Mac
  1. iMac
Nineniner....Could you post your EFI?
 
Joined
Feb 22, 2019
Messages
67
Motherboard
Gigabyte Z390M
CPU
i5-9400
Graphics
RTX 580
Mac
  1. iMac
Thanks. I tried your EFI (once I generated my own Serial) and getting to the installer OSX screen; however, it's in a different language and when I click install, it gives some time of error message.
 
Joined
Jul 7, 2015
Messages
159
Motherboard
MSI Z490-a Pro
CPU
i7-10700k
Graphics
UHD 630
Mobile Phone
  1. iOS
Thanks. I tried your EFI (once I generated my own Serial) and getting to the installer OSX screen; however, it's in a different language and when I click install, it gives some time of error message.
My OS was already installed before using open core. I already had a working clover config, and updated my mobo and CPU because clover wasn’t working.
 
Joined
Jun 10, 2017
Messages
31
Motherboard
MSI Z270 Gaming Pro Carbon
CPU
i7 6700k
Graphics
7850
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I give up. :|
The language issue is because the default Opencore Mac recovery language is Russian. you need to make change under your config file to make it back to English.
under the NVRAM
NVRAM -> Add -> 7C436110-AB2A-4BBB-A880-FE41995C9F82 -> prev-lang:kbd
by default is "ru-RU:252" should probably be "en-US:0" for US Eng

the Opencore method works from recovery mode.. so you need to have a working internet to reinstall Catalina.. i.e. your ethernet should be working and properly configured in your config and drivers/kexts.
 
Joined
Aug 2, 2019
Messages
1
Motherboard
Aorus z390 pro wifi
CPU
intel core i7 8700k
Graphics
Asus ROG RX Vega 56
Hi Guys,

Need some help. I am using MSI z490 gaming carbon wifi board with 10700k. I successfully installed Catalina 15.5. I added both LucyRTL8125Ethernet.kext and IntelMausiEthernet.kext on my Kexts but it says that the cable is unplugged cant connect. Thanks in advance.
 
Joined
Jun 10, 2017
Messages
31
Motherboard
MSI Z270 Gaming Pro Carbon
CPU
i7 6700k
Graphics
7850
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Hi Guys,

Need some help. I am using MSI z490 gaming carbon wifi board with 10700k. I successfully installed Catalina 15.5. I added both LucyRTL8125Ethernet.kext and IntelMausiEthernet.kext on my Kexts but it says that the cable is unplugged cant connect. Thanks in advance.

have you tried removing the IntelMausiEthernet.kext and cleaning your config file?? I don't think IntelMausiEthernet.kext is required. you only need Lucy kext. remove intelmausi kext and remove its reference/entry from config file.

and have you tried configuring it manually in system pref>network>(ethernet) advanced>hardware. it resolves most of the issues. even the developer of the kext suggests so. set the parameters as follows:
configure: Manual
Speed: 1000baseT
Duplex: full duplex
MTU standard 1500

play around a bit and hopefully it works.
 
Last edited:
Status
Not open for further replies.
Top