Contribute
Register

MSI PRO Z690 A DDR4 + i7-12700K + AMD RX 580

aol

Joined
Apr 14, 2011
Messages
502
Motherboard
MSI PRO Z690-A DDR4
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
Installed Ventura and my machine (running this build except with a 6800 XT) doesn't see the Ethernet controller at all. Can't add it. Hackintool just shows the wireless card as en0. Any suggestions? Monterey on a second drive sees the Ethernet controller fine (did apply the force to 1000 fix above to get it to work in Monterey).
 
Joined
Nov 15, 2021
Messages
93
Motherboard
MSI Pro Z690-A DDR4
CPU
i5-12600K
Graphics
RX560
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Installed Ventura and my machine (running this build except with a 6800 XT) doesn't see the Ethernet controller at all. Can't add it. Hackintool just shows the wireless card as en0. Any suggestions? Monterey on a second drive sees the Ethernet controller fine (did apply the force to 1000 fix above to get it to work in Monterey).
Very strange.
I have the same mobo, there isn't any troubles with Ethernet (i225-V) in Ventura.
I tried this one in Ventura beta - all OK. Last night upgraded my Monterey 12.6.0 to Ventura - the same. Ethernet works on 2500 fine, without fixing the speed.

1. What OC version are you using?
2. Do you using the last mobo BIOS?
 
Joined
May 31, 2016
Messages
27
Motherboard
MPG Z690 FORCE WIFI
CPU
i5-12600k
Graphics
RX 5700 XT
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Hello NorthAmTransAm I have an MSI z690 Force and a 12600k I already own and I am considering giving it a go , i will also be using the 5700xt from my Designare z390 build , is there a chance your EFI would work for me ?
 

NorthAmTransAm

Moderator
Joined
Jul 26, 2018
Messages
1,950
Motherboard
MSI Pro Z690-A DDR4
CPU
i7-12700k
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
Installed Ventura and my machine (running this build except with a 6800 XT) doesn't see the Ethernet controller at all. Can't add it. Hackintool just shows the wireless card as en0. Any suggestions? Monterey on a second drive sees the Ethernet controller fine (did apply the force to 1000 fix above to get it to work in Monterey).
I'll be updating towards the end of November as i've got some Pro Tools sessions to run and can't risk something not working. Keep scouring the forum though, I bet you you someone else has the same ethernet controller issue as we'll all be updating. Most likely its something super simple.

@danofun thanks for the kind words! I've had a busy touring schedule since June so i've been a bit absent but plan to dive back into this stuff as soon as i'm back. Thanks for keeping the thread alive and being helpful.

@Nikos87 this would be a sweet machine for you. My EFI, though not completely current, should work fine for you just read over post #1 as there are some nuances and knowing how it works is crucial--we are our own troublshooters. Also I believe you'll need to add the boot arg
Code:
agdpmod=pikera
for your 5700xt. Is that right @Feartech?
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
29,035
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
I'll be updating towards the end of November as i've got some Pro Tools sessions to run and can't risk something not working. Keep scouring the forum though, I bet you you someone else has the same ethernet controller issue as we'll all be updating. Most likely its something super simple.

@danofun thanks for the kind words! I've had a busy touring schedule since June so i've been a bit absent but plan to dive back into this stuff as soon as i'm back. Thanks for keeping the thread alive and being helpful.

@Nikos87 this would be a sweet machine for you. My EFI, though not completely current, should work fine for you just read over post #1 as there are some nuances and knowing how it works is crucial--we are our own troublshooters. Also I believe you'll need to add the boot arg
Code:
agdpmod=pikera
for your 5700xt. Is that right @Feartech?
or:
Code:
agdpmod=pikera
 

aol

Joined
Apr 14, 2011
Messages
502
Motherboard
MSI PRO Z690-A DDR4
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
Hi @sonny362 thanks for the response, and others.
I'm using OC 0.8.5, which I created by basically syncing the sample config plist in the 0.8.5 release back to the plist from @NorthAmTransAm 's 8.0 config posted in this thread. There are actually very few changes, mainly, they removed a few things. I'm using the same MOBO BIOS as posted in this thread, configured exactly the same, because when I started tweaking things, I started getting WindowServer crashes (that could have been bios tweaks or config tweaks, the 8.0 EFI posted in this thread is slightly different than the config as described in OP; I am using the 8.0 EFI config).
I would say the only significant difference between my system and the OP is that I have the 6800 XT GPU and I run dual monitors over DP ports. In fact this had been the main weirdness I had not resolved, when the system boots, only one monitor comes up, and the second monitor doesn't come up unless the system sleeps and resumes, or I manually replug in the second monitor.
One thing I'll try right now is booting Monterey on this 0.8.5 config.

Edit: booted Monterey using the 0.8.5 config, and Ethernet works fine, and shows up in Hackintool under peripherals as expected. I guess I need to look in the logs for messages around Ethernet.
 
Last edited:
Joined
Nov 15, 2021
Messages
93
Motherboard
MSI Pro Z690-A DDR4
CPU
i5-12600K
Graphics
RX560
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hi @aol.
I'm using OC 0.8.5 too, and my Ethernet is written in DeviceProperties only:

PciRoot(0x0)/Pci(0x1c,0x0)/Pci(0x0,0x0)
<dict>
<key>AAPL,slot-name</key>
<string>Internal@0,28,0/0,0</string>
<key>device-id</key>
<data>8xWGgA==</data>
<key>device_type</key>
<string>Ethernet controller</string>
<key>model</key>
<string>Intel Ethernet controller i225-V</string>
</dict>


It's enough to Ventura for me.
I can upload my EFI to you, if you need it.

I'm using two monitors too (HDMI + DP connectors on my GPU). Do you're using direct cables without and adapters? macOS is very sensitive to any kind of adapter. I have similar trouble with monitor connected by HDMI-HDMI cable with DP-HDMI adapter (under Windows all works fine), i changed this to cable DP-HDMI - all works fine.
 
Joined
May 31, 2016
Messages
27
Motherboard
MPG Z690 FORCE WIFI
CPU
i5-12600k
Graphics
RX 5700 XT
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Thanks Man! will give it a go and report back. My next move is going to be purchasing a TB card. I read in post #1 that the best bet is the Titan Ridge. Is Maple ridge a complete no go, or is it a matter of some features not working? All I need the TB card for is to connect the Apollo X4 and that’s it. So I am likely to avoid flashing the Titan.
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
29,035
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Thanks Man! will give it a go and report back , my next move is going to be purchasing a TB card.I read in post #1 that the best bet is the Titan Ridge , is Maple ridge a complete no go , or is it a matter of some features not working ? All I need the TB card for is to connect the Apollo X4 and that’s it , so I am likely to avoid flashing the Titan
please update your hardware profile to allow others to help you easier
 

NorthAmTransAm

Moderator
Joined
Jul 26, 2018
Messages
1,950
Motherboard
MSI Pro Z690-A DDR4
CPU
i7-12700k
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
Thanks Man! will give it a go and report back , my next move is going to be purchasing a TB card.I read in post #1 that the best bet is the Titan Ridge , is Maple ridge a complete no go , or is it a matter of some features not working ? All I need the TB card for is to connect the Apollo X4 and that’s it , so I am likely to avoid flashing the Titan
Even without flashing I find it safest to roll with a GC-Titan.
 
Top