Contribute
Register

MSI PRO Z690 A DDR4 + i7-12700K + AMD RX 580

NorthAmTransAm

Moderator
Joined
Jul 26, 2018
Messages
1,774
Motherboard
MSI Pro Z690-A DDR4
CPU
i7-12700k
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS

NorthAmTransAm

Moderator
Joined
Jul 26, 2018
Messages
1,774
Motherboard
MSI Pro Z690-A DDR4
CPU
i7-12700k
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
On MSI after BIOS upgrade the CFG Lock setting enabled. You have to disable it.

Thats my guess too. I started making the adjustment in my config instead though.
 
Joined
Feb 16, 2016
Messages
25
Motherboard
MSI PRO Z690-A WIFI
CPU
i7-12700K
Graphics
UHD 770, RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
  3. Other
I am making a comeback (trying) to Hackintosh. It's really hard to find guides and support for Intel 12th gen, this website is exception, so I have taken your OC 8.0 EFI, done following changes:

- Removed AirportBrcmFixup.kext, and Switched "Enabled" Boolean true -> false on config.plist.
- Enabled AirportItlwm.kext by switching boolean false->true on config.plist.
- Added SystemSerialNumber, MLB, SystemUUID.
- Added name of CPU and GPU.

Everything else is untouched. I am attaching the EFI (I have removed unique entries with #Omitted to share.)

I am getting following error:

OCS: No schema for SerialInit at 6 index, context <Debug>
OC: Deleting NVRAM 4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102: - Invalid Parameter
OC: Driver HfsPlus.efi at 0 cannot be loaded. -Access Denied!
Halting on critical error
 

Attachments

  • EFI.zip
    24.2 MB · Views: 25
Last edited:

Feartech

Moderator
Joined
Aug 3, 2013
Messages
28,410
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
I am making a comeback (trying) to Hackintosh. I have taken your OC 8.0 EFI, done following changes:

- Removed AirportBrcmFixup.kext, and Switched "Enabled" Boolean true -> false on config.plist.
- Enabled AirportItlwm.kext by switching boolean false->true on config.plist.
- Added SystemSerialNumber, MLB, SystemUUID.
- Added name of CPU and GPU.

Everything else is untouched. I am attaching the EFI (I have removed unique entries with #Omitted to share.)

I am getting following error:
you have:
Code:
<key>4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102</key>
            <array>
                <string>rtc-blacklist</string>
                <string>opencore-version</string>
                <string>revcpuname</string>
                <string>revcpu</string>
                <string></string>
            </array>

should only be:
Code:
<key>4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102</key>
            <array>
                <string>rtc-blacklist</string>
                <string>opencore-version</string>
                <string>revcpuname</string>
                <string>revcpu</string>
            </array>

needs to be removed:
Code:
<key>SerialInit</key>
            <false/>
 
Joined
Feb 16, 2016
Messages
25
Motherboard
MSI PRO Z690-A WIFI
CPU
i7-12700K
Graphics
UHD 770, RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
  3. Other
@Feartech Wow! Thank you for prompt response.

I have made the changes.
But I am still getting the following error

Rich (BB code):
OC: Driver HfsPlus.efi at 0 cannot be loaded. -Access Denied!
Halting on critical error

Also attaching updated EFI with spoof PlatformInfo.
 

Attachments

  • EFI copy.zip
    24.3 MB · Views: 11
Joined
Nov 15, 2021
Messages
83
Motherboard
MSI Pro Z690-A DDR4
CPU
i5-12600K
Graphics
RX560
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I am getting following error:
OC: Driver HfsPlus.efi at 0 cannot be loaded. -Access Denied!
Halting on critical error

Set in BIOS Secure Boot "Disabled".
 
Last edited:
Joined
Feb 16, 2016
Messages
25
Motherboard
MSI PRO Z690-A WIFI
CPU
i7-12700K
Graphics
UHD 770, RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
  3. Other


***OpenCore 0.8.0 EFI***

Note: If you are using the Wifi variant of this board and would like to use your Intel Wifi then you need to remove AirportBrcmFixup.kext and add the OpenIntelWireless drivers. OpenCore will not boot with CNVW (onboard Intel Wifi) enabled in BIOS unless you have the driver installed.


Lastly, you'll need to add your own Platform Info.
Both of the steps are done, I have successfully installed macOS 12.5 (with some novice mistakes, but thanks to @Feartech @sonny362), but, my internet is not working. Ethernet is detected and even show green dot, it's like system is connected to internet but there is no data transfer even of 0 bits, so everything has time out error.
On Hackintool, en0 is builtin (with grey tick).

Wi-‏Fii & Bluetooth toggle is not turning on.
 
Joined
May 10, 2011
Messages
2,725
Motherboard
Gigabyte B550 Vision D
CPU
Ryzen 5900X
Graphics
RX 6800
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
Both of the steps are done, I have successfully installed macOS 12.5 (with some novice mistakes, but thanks to @Feartech @sonny362), but, my internet is not working. Ethernet is detected and even show green dot, it's like system is connected to internet but there is no data transfer even of 0 bits, so everything has time out error.
On Hackintool, en0 is builtin (with grey tick).

Wi-‏Fii & Bluetooth toggle is not turning on.
@Wuttodo,

That's because the settings are incomplete. Enabling the Intel I225-V 2.5Gbe LAN in Monterey is easy. Simply add e1000=0 to the NVRAM boot-arg and add the following details below to your device properties. LAN driver kext is no longer needed because it is now natively supported by macOS and it will work.

Screen Shot 2022-10-02 at 11.58.00 PM.png


As for the Intel BT & WiFi, that's also easy. Grab the three kexts IntelBluetoothFirmware, BluetoolFixup.kext and Airportitlwm.kext (Monterey stable) from the OpenIntelWireless and PatchRAM3 Github repos and enable those.
 
Joined
Nov 15, 2021
Messages
83
Motherboard
MSI Pro Z690-A DDR4
CPU
i5-12600K
Graphics
RX560
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Both of the steps are done, I have successfully installed macOS 12.5 (with some novice mistakes, but thanks to @Feartech @sonny362), but, my internet is not working. Ethernet is detected and even show green dot, it's like system is connected to internet but there is no data transfer even of 0 bits, so everything has time out error.
On Hackintool, en0 is builtin (with grey tick).

Wi-‏Fii & Bluetooth toggle is not turning on.
You can try the simple solution with I-225V Ethernet: fix in the network card settings the transmission speed from auto to 1000Gbs (or to 2500, if yo're using it). It works for me.
 
Last edited:
Top