Contribute
Register

MSI PRO Z690 A DDR4 + i7-12700K + AMD RX 580

Joined
Jan 7, 2016
Messages
78
Motherboard
MSI z690 A
CPU
i7-12700
Graphics
RX 580
Mac
  1. iMac
  2. Mac Pro
Mobile Phone
  1. Android

***OpenCore 0.8.0 EFI***


A few notes about some custom SSDT's and Patches
  • I've edited SSDT-PLUG-ALT to have only the CPU threads I'm using. I renamed it SSDT-PLUG-ALT-12700K.
  • I've added a patch labeled (commented) Null \_GPE.DTIN. It prevents a 3 second boot hang that exist when Thunderbolt is enabled in Bios.
  • I've included my own USBMap.kext that covers most internal connectors and the back panel I/O. The internal USB 2.0 connection is set to 255 for Bluetooth or USB 2.0 from a Thunderbolt card. No need for any mapping on this build, just follow my guide.
  • AirportBrcmFixup.kext is optional.
Note: If you are using the Wifi variant of this board and would like to use your Intel Wifi then you need to remove AirportBrcmFixup.kext and add the OpenIntelWireless drivers. OpenCore will not boot with CNVW (onboard Intel Wifi) enabled in BIOS unless you have the driver installed.

Please refer to this chart for graphics cards as you might need to add the boot argument agdpmod=pikera



Also, please set Intel Speed Step Technology to Enabled in BIOS. Setting to Auto isn't enough.

Lastly, you'll need to add your own Platform Info.
wow, just released so fast updated.. thanks
 

NorthAmTransAm

Moderator
Joined
Jul 26, 2018
Messages
1,736
Motherboard
MSI Pro Z690-A DDR4
CPU
i7-12700k
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
j

wow, just released so fast updated.. thanks

I've been using it for a couple weeks. I like to test as they're working on it.

 

NorthAmTransAm

Moderator
Joined
Jul 26, 2018
Messages
1,736
Motherboard
MSI Pro Z690-A DDR4
CPU
i7-12700k
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
Okay im fine, so its noch crashed anymore :D ! But im woundering, he shows me a i5 12600k but i have a i7 12700k?

You can edit this in your config. Since Apple doesn't use any Alder Lake Cpus we have to type it in manually. Not sure why its missing from the EFI, oops.


Screen Shot 2022-04-19 at 8.38.16 AM.png
 
Last edited:
Joined
Dec 31, 2013
Messages
793
Motherboard
Huawei Matebook D
CPU
i5-8250U
Graphics
UHD 620
Mobile Phone
  1. iOS
Hi all,

I'm trying to boot a MSI Z690-A PRO WiFi DDR4 but regardless of the EFI I always get a grey screen with a working mouse pointer trying to boot Big Sur installer.
I had the same thing a month ago trying a B660 motherboard...

Both cases, different EFIS, same result: grey screen after the installer boots and moves beyond the verbose section.
Basically I am at the installer but the language selection doesn't load.

Can anyone help?
Is it a Bios issue?
Thanks a lot...
 
Joined
Oct 4, 2018
Messages
886
Motherboard
Gigabyte C246-WU4
CPU
E-2278G
Graphics
WX7100
Mac
  1. MacBook Pro
  2. Mac mini
I'm trying to boot a MSI Z690-A PRO WiFi DDR4 but regardless of the EFI I always get a grey screen with a working mouse pointer trying to boot Big Sur installer.
There's a specific thread for this board:

I had the same thing a month ago trying a B660 motherboard...

Both cases, different EFIS, same result: grey screen after the installer boots and moves beyond the verbose section.
Basically I am at the installer but the language selection doesn't load.
Make sure that 'prev-lang:kdb' is defined as <data>, or at least as a non-empty string.
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
27,552
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Hi all,

I'm trying to boot a MSI Z690-A PRO WiFi DDR4 but regardless of the EFI I always get a grey screen with a working mouse pointer trying to boot Big Sur installer.
I had the same thing a month ago trying a B660 motherboard...

Both cases, different EFIS, same result: grey screen after the installer boots and moves beyond the verbose section.
Basically I am at the installer but the language selection doesn't load.

Can anyone help?
Is it a Bios issue?
Thanks a lot...
As per rules, please update your hardware profile to allow others to help you easier
 
Joined
Dec 31, 2013
Messages
793
Motherboard
Huawei Matebook D
CPU
i5-8250U
Graphics
UHD 620
Mobile Phone
  1. iOS
There's a specific thread for this board:


Make sure that 'prev-lang:kdb' is defined as <data>, or at least as a non-empty string.
Thanks for the reply.

- The EFI from the MSI Z690-A PRO WiFi DDR4 thread doesn't even see the installer on the USB drive

- Modifying prev-lang:kdb both with empty data or with non-empty string doesn't make a difference.
 

NorthAmTransAm

Moderator
Joined
Jul 26, 2018
Messages
1,736
Motherboard
MSI Pro Z690-A DDR4
CPU
i7-12700k
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
Thanks for the reply.

- The EFI from the MSI Z690-A PRO WiFi DDR4 thread doesn't even see the installer on the USB drive

- Modifying prev-lang:kdb both with empty data or with non-empty string doesn't make a difference.
Change scan policy to 0 or press spacebar at picker menu. Make sure you're using the 0.8.0 EFI that I just added as well.

What in God's sake, or in Sake of the Japanese, should I be doing now to switch to the motherboard thread without being killed, outlawed, pointed out, or sent through Putin's assassination?
Don't sweat it--just keeping the site clean and organized and avoiding redundancies. No one is upset with you.
 
Top