Contribute
Register

MSI Krait and GTX 970 stuck at boot before installation.

Status
Not open for further replies.
Joined
Dec 15, 2013
Messages
7
Motherboard
MSI Z97S Kriat Edition
CPU
i5 4690k
Graphics
Gigabyte Gaming G1 GTX 970
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. iOS
[SOLVED] MSI Krait and GTX 970 stuck at boot before installation.

Hello everyone. First or second time using the forums here with my new build.
MSI Krait Z97 SLI
GTX 970 Gigabyte G1
16 GB Ram (3 DIMMs)
Intel i5 4690k

I have created the Unibeast installation disk and can almost get into installation. It stops after IOBluetooth controller -- Completed. It is very frustrating

Thanks for the help in advance!:)
 
Joined
Aug 5, 2013
Messages
648
Motherboard
Gigabyte Z97N-Wifi
CPU
i7-4790K
Graphics
HD4600
boot with these flags -v -x dart=0 nv_disable=1
 
Joined
Dec 15, 2013
Messages
7
Motherboard
MSI Z97S Kriat Edition
CPU
i5 4690k
Graphics
Gigabyte Gaming G1 GTX 970
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. iOS
Ok I will give it a try and will return with my results.
 
Joined
Dec 15, 2013
Messages
7
Motherboard
MSI Z97S Kriat Edition
CPU
i5 4690k
Graphics
Gigabyte Gaming G1 GTX 970
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. iOS
boot with these flags -v -x dart=0 nv_disable=1

Those boot flags got me into installation! I will post here if I need more help.
 
Joined
Aug 26, 2015
Messages
9
Motherboard
Asus Sabertooth P67
CPU
Intel i5-2500K
Graphics
Geforce GTX 970
Mac
Classic Mac
Mobile Phone
Hello and greetings from Sudan! And excellent selection of Videocard might I add! :headbang:

I had similar problems (which you will likely face after installing the Nvidia web driver) and I solved all of them after switching the DVI-VGA cable to HDMI-HDMI. Weird but I have never had trouble booing into mac with the HDMI cable and nvda_drv=1

And in case that doesn't work (although I am 99.9% it will) try
- Modifying AppleGraphicsDevicePolicy kext
- Selecting a different SMBIOs.plist
- PCIRootUID=1 boot flag +/- the npci=0x3000 boot flags

Please respond and I will happily oblige.
 
Joined
Dec 15, 2013
Messages
7
Motherboard
MSI Z97S Kriat Edition
CPU
i5 4690k
Graphics
Gigabyte Gaming G1 GTX 970
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. iOS
Joined
Aug 5, 2013
Messages
648
Motherboard
Gigabyte Z97N-Wifi
CPU
i7-4790K
Graphics
HD4600
now install the Nvidia Web drivers and switch to nvda_drv=1
 
Joined
Dec 15, 2013
Messages
7
Motherboard
MSI Z97S Kriat Edition
CPU
i5 4690k
Graphics
Gigabyte Gaming G1 GTX 970
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. iOS
I already got the web drivers and once I restarted and chose to use the Web drivers, it is working just fine. thanks again. I even had to deal with the boot0 error, but got it taken care of.
 
Status
Not open for further replies.
Top