Contribute
Register

MSI GS60 2QE Ghost Pro, HD5600 QE/CI 7mb problem (10.11.3)

Joined
Apr 1, 2016
Messages
68
Motherboard
MSI GE62 2QD Apache Pro (Clover)
CPU
i7-5700HQ/HM87
Graphics
HD5600, GTX960M, 1920x1080
Holy cr... I don't know what(and how) you did (it), but QE finally works! I used your EFI folder and added HFSPlus.efi and voila. One thing, getting it to boot is a very icky experience. I'm having trouble booting even with the slightest change of config.plist(laptop boots to clover but it sees zero partitions)... but it may be something else that's preventing me from booting. I'll report back after I've fiddled around with it a little.
View attachment 196802
what is your OS X version? and how did you get your Facetime worked, and how did you solve your audio card problem (probably ALC892)?
surprisingly, I also have perfect HD5600 with this EFI and more amazing is this DSDT not only gives me variable frequency CPU, but also with perfect sleep and awaken, one more thing I can adjust backlight of screen.
So amazing!
Reaaly appreciated for Traykun's sharing.
 
Joined
Apr 1, 2016
Messages
68
Motherboard
MSI GE62 2QD Apache Pro (Clover)
CPU
i7-5700HQ/HM87
Graphics
HD5600, GTX960M, 1920x1080
I wonder how can you change dvmt value?

You mentioned #1 post. Bios is lock

Did you downgrade old bios for dvmt?
I think biso was encrypted for MSI laptop even you could make some changes by EFI Shell or Advanced settings.
 
Joined
Mar 6, 2012
Messages
192
Motherboard
15ZD960-GX3DK
CPU
Intel Core i3-6100U
Graphics
Intel HD Graphics 520
Mobile Phone
Android
I think biso was encrypted for MSI laptop even you could make some changes by EFI Shell or Advanced settings.
what kind of you laptop bios?

insydeh20?

i cant use efi shell and also dont have advanced setting in bios.
 
Joined
Jun 7, 2015
Messages
124
Motherboard
MSI GE62-2QF
CPU
i7-5700HQ / HM87
Graphics
Intel HD5600 + GTX970M
Mobile Phone
iOS
Okay, here's a short list of what works and what doesn't:

Shutdown - works
Sleep/wake - works... kind of (internal display goes black, but that might be because I had a HDMI monitor plugged in. The monitor worked fine)
HDMI - works... kind of (if I keep it plugged in while booting I only get a black screen on both displays. If I plug it in after boot it works perfectly)
Backlight control - works
WiFi - doesn't work (obviously, since the laptop comes with an Intel card preinstalled. Can easily be remedied by buying a new one)
Ethernet - works (but you'll have to add the kext for the onboard Killer LAN yourself as it's not included in Traykun's EFI folder)
Bluetooth - works (but you can't turn it off)
QE/CI - works
Audio - doesn't work
Built-in keyboard/trackpad - works (keyboard backlight doesn't work, and the trackpad doesn't recognize two-finger scrolling with the provided kext)
Webcam - doesn't work

I haven't checked for PM implementation for both the CPU and the iGPU yet. I'll get around to doing that once I get Clover up and running on my hard drive. Getting audio and the webcam working seems like an easy fix.

Also Traykun, if it wouldn't be asking too much, do you mind sharing with us exactly how you managed to get graphics accelerated? Many thanks for sharing your EFI folder, by the way!
 
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
190,989
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Also Traykun, if it wouldn't be asking too much, do you mind sharing with us exactly how you managed to get graphics accelerated? Many thanks for sharing your EFI folder, by the way!
I think you just need to inject ig-platform-id 0x16260006.

There is a fake device-id being injected, but I'm guessing that is not needed.

There are also a few other properties such as graphic-options, but all tests I have done have shown that property to have no effect on previous systems, although if you look at real Mac ioreg, you will see it there.

Note: HDMI can probably be fixed by implementing HDMI audio patches. But of course, you need audio working first...
 
Last edited:
Joined
Jun 7, 2015
Messages
124
Motherboard
MSI GE62-2QF
CPU
i7-5700HQ / HM87
Graphics
Intel HD5600 + GTX970M
Mobile Phone
iOS
I think you just need to inject ig-platform-id 0x16260006.

There is a fake device-id being injected, but I'm guessing that is not needed.

There are also a few other properties such as graphic-options, but all tests I have done have shown that property to have no effect on previous systems, although if you look at real Mac ioreg, you will see it there.

Note: HDMI can probably be fixed by implementing HDMI audio patches. But of course, you need audio working first...
As happy as I am to see that QE is finally working after months of agonizing, I'm not really a fan of all those DSDT/SSDT files so I'll definitely try that out... though I'm not holding my breath. I think I've tried changing ig-platform-id about a million times already.
 
Joined
Apr 1, 2016
Messages
68
Motherboard
MSI GE62 2QD Apache Pro (Clover)
CPU
i7-5700HQ/HM87
Graphics
HD5600, GTX960M, 1920x1080
Okay, here's a short list of what works and what doesn't:

Shutdown - works
Sleep/wake - works... kind of (internal display goes black, but that might be because I had a HDMI monitor plugged in. The monitor worked fine)
HDMI - works... kind of (if I keep it plugged in while booting I only get a black screen on both displays. If I plug it in after boot it works perfectly)
Backlight control - works
WiFi - doesn't work (obviously, since the laptop comes with an Intel card preinstalled. Can easily be remedied by buying a new one)
Ethernet - works (but you'll have to add the kext for the onboard Killer LAN yourself as it's not included in Traykun's EFI folder)
Bluetooth - works (but you can't turn it off)
QE/CI - works
Audio - doesn't work
Built-in keyboard/trackpad - works (keyboard backlight doesn't work, and the trackpad doesn't recognize two-finger scrolling with the provided kext)
Webcam - doesn't work

I haven't checked for PM implementation for both the CPU and the iGPU yet. I'll get around to doing that once I get Clover up and running on my hard drive. Getting audio and the webcam working seems like an easy fix.

Also Traykun, if it wouldn't be asking too much, do you mind sharing with us exactly how you managed to get graphics accelerated? Many thanks for sharing your EFI folder, by the way!
Hi guys,
Do you make the audio work by implementing appleHDA?
 
Last edited:
Joined
Jun 7, 2015
Messages
124
Motherboard
MSI GE62-2QF
CPU
i7-5700HQ / HM87
Graphics
Intel HD5600 + GTX970M
Mobile Phone
iOS
Hi guys,
Do you make the audio work by implementing appleHDA?
If you make it work, would you mind for sharing your files?
I'm thinking of working on audio once I've figured out what makes Traykun's setup work. Why not try working on it yourself though, the whole process seems to be documented pretty well by RehabMan.
 
Joined
Apr 1, 2016
Messages
68
Motherboard
MSI GE62 2QD Apache Pro (Clover)
CPU
i7-5700HQ/HM87
Graphics
HD5600, GTX960M, 1920x1080
I'm thinking of working on audio once I've figured out what makes Traykun's setup work. Why not try working on it yourself though, the whole process seems to be documented pretty well by RehabMan.
allright, eh eh eh eh, I'm working on it, but the config.plist seems abnormal as even a tiny modification could lead to odd problems, may be this is just case-by-case.
 
Top