Contribute
Register

MSI GP60 2PE Leopard El Capitan kexts pack

Status
Not open for further replies.
Joined
Sep 17, 2016
Messages
13
Could you elaborate on why it is not per guide?

In any case, I'll start over following that guide once, but I would like to know why is it that my current method is not working.

Thanks :)
 
Joined
Sep 17, 2016
Messages
13
YES, I DID IT! Thanks to your link, I went and got the config.plist for HD4600 and it worked! Thanks a lot man, now just wanted to ask about installing kexts for my trackpad and keyboard, and also the wifi. I am almost clueless about how they work, so any link to any guide or anything will do.

Edit: I now got almost everything to work, except ethernet and wifi. I have no idea how to get it done, so if you can please help me out :)

Thanks a lot for all the help guys, this means a lot to me, as it was so important to me, and just could not afford a Mac. I really appreciate all the time you guys have taken for it. :)))))
 
Last edited:

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,101
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
YES, I DID IT! Thanks to your link, I went and got the config.plist for HD4600 and it worked! Thanks a lot man, now just wanted to ask about installing kexts for my trackpad and keyboard, and also the wifi. I am almost clueless about how they work, so any link to any guide or anything will do.

Edit: I now got almost everything to work, except ethernet and wifi. I have no idea how to get it done, so if you can please help me out :)

Thanks a lot for all the help guys, this means a lot to me, as it was so important to me, and just could not afford a Mac. I really appreciate all the time you guys have taken for it. :)))))

http://www.tonymacx86.com/el-capita...faq-read-first-laptop-frequent-questions.html
 
Joined
Sep 17, 2016
Messages
13
Ok, so after trying a lot of stuff, it seems that nothing really worked for WiFi. My Wireless Network Adapter is Realtek RTL8723AE, so please let me know what else I can do to make this happen. Thank you :)
 
Joined
May 20, 2016
Messages
13
Ok, so after trying a lot of stuff, it seems that nothing really worked for WiFi. My Wireless Network Adapter is Realtek RTL8723AE, so please let me know what else I can do to make this happen. Thank you :)
Wifi is the only thing that also didn't work for me. I bought an Asus N10 Nano wireless usb adapter. Drivers are available at their website, https://www.asus.com/Networking/USBN10_NANO/HelpDesk_Download/. Works like a charm.

For the Ethernet drivers, read this part from my first post:
Install Killer LAN
To make your Killer Lan adapter work, do the following:
Download/Launch Clover Configurator
Mount EFI Partition by going to Mount EFI -> Mount EFI Partition
Download /Launch Multibeast
Go to Drivers->Network->Atheros and check the lastest AtherosE2200Ethernet (in my case v2.2.0d0)
Go to Build and click install. Restart Your Laptop.
Only apply this if you have the same Ethernet adapter

And thanks RehabMan for jumping in!
 
Last edited:
Joined
Sep 17, 2016
Messages
13
Oh, so I will need an external one. Alright then will look for the same one as yours. Thanks a lot :))))))
 
Joined
May 20, 2016
Messages
13
Oh, so I will need an external one. Alright then will look for the same one as yours. Thanks a lot :))))))
You have a different adapter then i got, so maybe there is a driver for you. If you indeed can't find it, the external wifi adapter is a good option.
Do'nt forget to see the changes in my previous reply, added part for Killer Lan, if you got the same adapter
 
Joined
May 20, 2016
Messages
13
Happy to hear almost everything works now :). I'm slowly thinking to also try to dual boot OSX again :shifty:
 
Joined
May 20, 2016
Messages
13
Can i update OSX to 10.12 Sierra?
Yes, but not without changing some things!
And i advice to do a fresh install, but it should be possible to update.

First, install the lastest version of clover bootloader with the following settings:
- Install for UEFI motherboards
- Install clover in the ESP
- In themes, select all
- In Drivers64UEFI, select EmuVariableUefi-64 and OsxAptioFix2Drv-64 (also on USB, otherwise the USB wont boot as well!
- RC scripts on target volume
- Install all RC scripts on other volumes

Then, install the audio and graphics kexts again.
For the graphics, use the new kexts from https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/!!!
 
Joined
May 20, 2016
Messages
13
Fix sleep black screen & brightness fn buttons
In clover configurator, go to Acpi -> Fixes -> New way -> check AddPNLF
 
Status
Not open for further replies.
Top