Contribute
Register

MSI GP60 2PE Leopard El Capitan kexts pack

Joined
May 20, 2016
Messages
14
After hours of trial and error i finally managed to install El Capitan on my MSI GP60 2PE Leopard laptop.

To make life easier, i wanted to share the kexts i used to get this done.
There is a description in each folder for each kext you need to install.
Please follow those instructions, because ignoring them could cause kernel panics.

My system specs. If one of your specs is different, the kext that belongs to that part of the system could not work!
MSI GP60 2PE Leopard
System manufacturer: Micro-star International
Bios: E16GHIMS.10H
Processor: Intel i7-4700HQ (8CPU) 2,40GHz
RAM: 12GB
DirectX: 12
On-board graphics: Intel HD Graphics 4600 1920x1080 32 bit 59Hz
External graphics: NVIDIA GeForce 840M 2gb
Audio: Realtek High Definition Audio WDM 100
Cardreader: Realtek PCIE Cardreader
Bluetooth: Intel PROSet
CD/DVD station: HL-DT-ST DVDRAM GTA0N
Touchpad: ELAN Smart-Pad
LAN: Killer E2200 Gb LAN
WLAN: Dual Band Wireless-AC 3160
Keyboard: Steelseries qwerty

Package contents
Download at the bottom of this post
Battery kext [ACPIBatteryManager]
Clover Conifg file
Graphics kexts [FakePCID and FakePCID_Intel_HD_Graphics]
Sound installer (!For Microphone read the bottom of the howto file!) [VoodooHDA_2.8.8]
Touchpad and keyboard kext [ApplePS2SmartTouchPad] (see http://forum.osxlatitude.com/index.php?/topic/1948-elan-focaltech-and-synaptics-smart-touchpad-driver-mac-os-x/)

Installing OSX El Capitan
To prevent kernel panics during the El Capitan installation, use the following bootflags:
-v -f ncpi=0x2000 nv_disable=1 cpus=1
If this does not work you can add -x as well, but this is not necessary.
For running OSX El Capitan after install i used clover bootloader.

Clover config
If you are applying my clover config, make sure you install the sound and graphics kexts BEFORE you reboot. If you don't you will get kernel panics.
I am also using the bluemac theme. Install the bluemac theme yourself or install one of your choice.

Wifi support
The internal WLAN driver is not supported by apple. I bought the Asus N10 Nano Wifi Adapter and downloaded the drivers from the Asus website (driver is also inside this kext pack)

Install Killer LAN
To make your Killer Lan adapter work, do the following:
Download/Launch Clover Configurator
Mount EFI Partition by going to Mount EFI -> Mount EFI Partition
Download /Launch Multibeast
Go to Drivers->Network->Atheros and check the lastest AtherosE2200Ethernet (in my case v2.2.0d0)
Go to Build and click install. Restart Your Laptop.

Shutdown issues
Have problems shutting down your pc? Does it not shutdown completely or do you have another shutdown problem?
Use clover configurator, load your config file and go to ACPI. Check the FixShutdown option. Then restart your pc. After the restart shutting down should work normally.

Nvidia
The Nvidia 840m graphics card is not supported by apple and has to be disabled by adding the nv_disable=1 boot flag.

Can i update OSX to 10.11.5?
Yes you can BUT remember that on the first boot after the update, you need to install the audio and graphics kexts again!
 

Attachments

Last edited:
Joined
Jun 27, 2015
Messages
36
Motherboard
HP Pavilion Power 15
CPU
Intel i5-7300HQ
Graphics
Intel HD 630 + GTX 1050 2GB
Mac
MacBook, MacBook Pro, Mac mini
Mobile Phone
Android, iOS
Hey!
I have a GS70 (nearly same spec)
and the fan of my 970M is on maximum running
how can I fix that
 
Joined
Sep 17, 2016
Messages
13
Bro, I am using GP60 20D, and I used your bootflags but it dithis, didn't work out too well. I wanted to ask that when you did this, did you still have windows or did you remove it? if you did, please let me know the best way I can clear everything and install Hackintosh. thanksss :))))
 
Joined
May 20, 2016
Messages
14
Bro, I am using GP60 20D, and I used your bootflags but it dithis, didn't work out too well. I wanted to ask that when you did this, did you still have windows or did you remove it? if you did, please let me know the best way I can clear everything and install Hackintosh. thanksss :))))
Hello dinzhd,

I will try to help you, but I got no reference anymore because my laptops hard disk was replaced by the manifacturer, so I lost my hackintosh.

I made an extra partition on my hard drive (right click start button -> Disk management). This way I was able to keep my windows. In my bios I changed my boot mode (Boot->UEFI/BIOS boot mode) from legacy to UEFI (or the other way around, cannot remember exactly).

I used clover bootloader to be able to choose if I want to boot windows or OSX.

If you have any more questions feel free to ask :) I will try the best I can to answer them, if I can.
 
Joined
Sep 17, 2016
Messages
13
Alright bro, thanks to you, I have managed to install the El Capitan, and even install windows. However, I am not able to boot my Hackintosh without the USB. I tried the Multibeast tutorial, but nothing seemed to work out. Please guide me on what I need to do next in order to be able to dual boot. Thanks :):)

Edit: One more thing, I have no idea how to handle the kexts. I am also not sure whether I should take of the kexts first before dual booting or not. Help me out pls...
 
Last edited:
Joined
May 20, 2016
Messages
14
Alright bro, thanks to you, I have managed to install the El Capitan, and even install windows. However, I am not able to boot my Hackintosh without the USB. I tried the Multibeast tutorial, but nothing seemed to work out. Please guide me on what I need to do next in order to be able to dual boot. Thanks :):)

Edit: One more thing, I have no idea how to handle the kexts. I am also not sure whether I should take of the kexts first before dual booting or not. Help me out pls...
Have you now set USB boot to default in your bios? Or does it crash without USB? If you could explain what is happening there that would help. Any errors there?
It may sound stupid, but maybe clover is configured to boot from USB by default (for me it was). Try taking the usb out.

Installing the kexts is something you can do when booted in OSX. I used kextwizard for this. After installing the kexts most functionalities should work after the next boot. If you get kernel panics, this means some kexts are not made for your system. For that reason, install them one by one for easier bugfixing. After every kext install reboot the system.

Like you may have noticed, installing osx can be a pain in the ass :silent:. It took me 2 weeks with full days working to have everything running like it should, and I got help from a friend as well :p. So I hope it will work for you!
 
Joined
Sep 17, 2016
Messages
13
Not sure if this is important, but I guess I should mention that my boot mode is Legacy, and not UEFI, because setting as UEFI gave me the 'No media present' error.

Ok, so here is the situation. I have installed El Capital with a USB to a partition. Once I was done installing, I installed Windows to another partition.

Now, if I remove my USB, my laptop automatically boots to Windows.
However, even if I inserted my El Capitan USB, I will still need to open boot menu and select the USB, before being able to boot my Hackintosh.

In a tutorial that I followed, I was told that I must use Multibeast and select 'Legacy Boot Mode', and then build. However, despite doing that, nothing really happened. I had to still connect my USB in order to boot Hackintosh.

I am not sure what I should do from here. I do not want to use my USB in order to boot any OS. Any ideas?

Thanks a lot again for your help man, it gives me immense hope that I can do this lol.
 
Joined
May 20, 2016
Messages
14
Legacy is OK.

Maybe take a look in the clover config.
I can remember that there are some options there for auto booting in an OS.
1 option is the timer for how long it takes to auto boot.
And the other option is what OS to boot.
At first I would advise to search for that timer option, and see if it is set to 0 seconds, because that would cause windows to boot up immediately.
 
Top