Contribute
Register

MSI gf63 thin 9sc

Joined
Nov 5, 2011
Messages
16
Motherboard
Gigabyte Z390 Aorus Master
CPU
i9-9900K
Graphics
Radeon VII
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
iMac
Mobile Phone
iOS
Hi all hope someone can help me with this odd problem i am having with gf63 thin 9sc laptop I recently installed Mac OS Catalina onto the laptop using the usb install found on this site with no problem and the OS runs perfect the problem i am having is with the boot UEFI partition with clover.
I have done all settings in the Bios and on boot F11 to get the list the UEFI will not show up ? I can only boot the system from the USB stick.
I have also taken the ssd hdd out and tried it in my other hackintosh and loaded perfect.
I have also updated the Bios with no luck both my usb stick and clover install to the ssd is using EFI and all the settings in the Bios is set correctly for booting OSX as it is finding usb stick EFI and booting the OS plus installed OSX onto the ssd but i am not able to get the OS booting from EFI on the ssd hdd?.
Any help with this ?
thanks
 
Last edited:
Joined
Dec 16, 2019
Messages
6
Motherboard
MSI GF63 Thin
CPU
i5-9300H
Graphics
GTX 1050 - UHD 630
Which is the guide you followed for the installation?
 
Joined
Jan 27, 2013
Messages
4
Motherboard
Gigabyte GA-H61M-DS2
CPU
Intel Celeron G1620
Graphics
GeForce 210
Mac
Classic Mac
Mobile Phone
hello i have the same laptop, i tried to boot from usb but without succes. how did you boot? Which is the guide you followed for the installation ?

thanks
 
Joined
Nov 5, 2011
Messages
16
Motherboard
Gigabyte Z390 Aorus Master
CPU
i9-9900K
Graphics
Radeon VII
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
iMac
Mobile Phone
iOS
Hi sorry for the late reply i used the laptop guide here on this site but to make things easier for you please find my working EFI folder below, this laptop will not install OSX directly you will need to take out the 2.5 hard drive or m.2 card which ever one your using plug it into a other Tosh or mac VAI usb or internal up to you and install the OSX after install re-install back your drive into the laptop and use the EFI below to boot into your OSX.
This Laptop will not see the EFI partiton from your hard drive so you will need to put the EFI folder below onto your USB EFi partition and boot your system using the USB.
in your BIOS the only thing you need to change is under
1: Security/Secure Boot/Secure Boot (( Disabled ))
2:Boot/BootUP NumberLock State ((OFF ))
3:Boot/Fast Boot (( Disabled ))
4:Boot/ Boot Option 1 (( Set To The USB ))
Save and exit bios
added kext ApplePS2SmartTouchPad.kext / ACPIBatteryManager.kext / VoodooPS2Trackpad.kext
and BroadcomWiFiInjector.kext / i changed my wifi m.2 card to Broadcom BCM94352Z Wireless-AC 867Mbps WiFi Bluetooth 4.0 NGFF M.2 Card in order to get my wifi working hope this helps.
But theres still the problem with getting Intel UHD 630 graphics working i am getting 4mb not running fully
This Efi is running Mac OSX 10.15.2 Catalina
 

Attachments

Last edited:
Joined
Nov 5, 2011
Messages
16
Motherboard
Gigabyte Z390 Aorus Master
CPU
i9-9900K
Graphics
Radeon VII
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
iMac
Mobile Phone
iOS
Hope this help you all its not easy getting OSX running but it works once up if there is anyone that can help with getting Intel UHD 630 graphics working fully please let me know my EFI folder is above so have a look and let me know what i am doing wrong please
 
Last edited:
Joined
Mar 13, 2020
Messages
2
Motherboard
intel
CPU
intel
Graphics
nvidia
Mobile Phone
Android
Hi all hope someone can help me with this odd problem i am having with gf63 thin 9sc laptop I recently installed Mac OS Catalina onto the laptop using the usb install found on this site with no problem and the OS runs perfect the problem i am having is with the boot UEFI partition with clover. I have done all settings in the Bios and on boot F11 to get the list the UEFI will not show up ? I can only boot the system from the USB stick. I have also taken the ssd hdd out and tried it in my other hackintosh and loaded perfect. I have also updated the Bios with no luck both my usb stick and clover install to the ssd is using EFI and all the settings in the Bios is set correctly for booting OSX as it is finding usb stick EFI and booting the OS plus installed OSX onto the ssd but i am not able to get the OS booting from EFI on the ssd hdd?. Any help with this ? thanks
i have the exact same model. while i have dual booted various linux versions, i have never booted macos. can you point me to some detailed guide which you followed? i have only weekend to try. if i am not able to boot macos then i will have to go back to windows. and macos will be really helpful in my work, till i get actual mac(which is not happening anytime soon)
 
Joined
Mar 13, 2020
Messages
2
Motherboard
intel
CPU
intel
Graphics
nvidia
Mobile Phone
Android
All i need is ability to run android studio and ios emulator. thats it. i don't mind other bugs. i have exact same model. can you share the guide which you followed. i am newbie when it comes t this. i am tried to follow one guide but i get stuck at i am able to format my drive and then proceed with installation, but when it reboots, and i seletc boot from macos hardrive, i end up with some logs and its freezes at that screen. i am sure that i am missing something since everyone here with exact same model was atleast able to boot into macos
 
Joined
Jan 27, 2013
Messages
4
Motherboard
Gigabyte GA-H61M-DS2
CPU
Intel Celeron G1620
Graphics
GeForce 210
Mac
Classic Mac
Mobile Phone
Hi sorry for the late reply i used the laptop guide here on this site but to make things easier for you please find my working EFI folder below, this laptop will not install OSX directly you will need to take out the 2.5 hard drive or m.2 card which ever one your using plug it into a other Tosh or mac VAI usb or internal up to you and install the OSX after install re-install back your drive into the laptop and use the EFI below to boot into your OSX.
This Laptop will not see the EFI partiton from your hard drive so you will need to put the EFI folder below onto your USB EFi partition and boot your system using the USB.
in your BIOS the only thing you need to change is under
1: Security/Secure Boot/Secure Boot (( Disabled ))
2:Boot/BootUP NumberLock State ((OFF ))
3:Boot/Fast Boot (( Disabled ))
4:Boot/ Boot Option 1 (( Set To The USB ))
Save and exit bios
added kext ApplePS2SmartTouchPad.kext / ACPIBatteryManager.kext / VoodooPS2Trackpad.kext
and BroadcomWiFiInjector.kext / i changed my wifi m.2 card to Broadcom BCM94352Z Wireless-AC 867Mbps WiFi Bluetooth 4.0 NGFF M.2 Card in order to get my wifi working hope this helps.
But theres still the problem with getting Intel UHD 630 graphics working i am getting 4mb not running fully
This Efi is running Mac OSX 10.15.2 Catalina
thank you!
 
Joined
Jul 31, 2020
Messages
80
Motherboard
MSI GF63 Thin 9SC
CPU
Intel Core i9-9750H
Graphics
Intel UHD 630
Mac
iMac
Mobile Phone
Android
Hi sorry for the late reply i used the laptop guide here on this site but to make things easier for you please find my working EFI folder below, this laptop will not install OSX directly you will need to take out the 2.5 hard drive or m.2 card which ever one your using plug it into a other Tosh or mac VAI usb or internal up to you and install the OSX after install re-install back your drive into the laptop and use the EFI below to boot into your OSX.
This Laptop will not see the EFI partiton from your hard drive so you will need to put the EFI folder below onto your USB EFi partition and boot your system using the USB.
in your BIOS the only thing you need to change is under
1: Security/Secure Boot/Secure Boot (( Disabled ))
2:Boot/BootUP NumberLock State ((OFF ))
3:Boot/Fast Boot (( Disabled ))
4:Boot/ Boot Option 1 (( Set To The USB ))
Save and exit bios
added kext ApplePS2SmartTouchPad.kext / ACPIBatteryManager.kext / VoodooPS2Trackpad.kext
and BroadcomWiFiInjector.kext / i changed my wifi m.2 card to Broadcom BCM94352Z Wireless-AC 867Mbps WiFi Bluetooth 4.0 NGFF M.2 Card in order to get my wifi working hope this helps.
But theres still the problem with getting Intel UHD 630 graphics working i am getting 4mb not running fully
This Efi is running Mac OSX 10.15.2 Catalina
Hi, I have this laptop and would like to install macOS Catalina on it. I arrive at the installation point and the Apple logo remains stuck on the screen. It doesn't go on. I followed the steps you wrote. What could be the problem?
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
18,488
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
iMac
Mobile Phone
iOS
Hi, I have this laptop and would like to install macOS Catalina on it. I arrive at the installation point and the Apple logo remains stuck on the screen. It doesn't go on. I followed the steps you wrote. What could be the problem?
boot verbose to see the issue

also check in windows device manager to see if you have intel graphics and update your hardware profile


please read the faq for proper hardware profile setup:
 
Top