Contribute
Register

MSI CX61 2OD816XRU

Joined
Nov 5, 2015
Messages
5
Motherboard
MSI
CPU
Intel i5 4210M
Graphics
nvidia 740M
Mac
Classic Mac
Mobile Phone
Hello!
I'm not totaly noob in this, not-so-easy job, i've already spend over 9000 hours at notebook and reading tonymacx86, applelife, insanelyi forums. First time i've installed El Capitain and i don't know how i did it, so i just run OS X, looked at glitchez and installed win7 instead. This time i want to do my job to the logical end. My target is recieve help and give it to others.
So, i have MSI CX61 2OD816XRU for free. It's HW:
Chipset: Intel HM86 Express
Processor: Intel Core i5 2600 MHz Haswell(4210M)
RAM: 4096 Мб DDR3-1600MHz
GPU: NVIDIA GeForce GT 740M, 2048+1632 Mb and Intel HD Graphics 4600, 64+1632 Mb
Audio: Intel HDA (Realtek ACL888s)
Wi-Fi+BT: AzureWave NB114H (RTL8723AE)
LAN: 10/100/1000
So. I lost a week(yeah, i had an error with Stop sign) to launch and install properly OSX (Later i would write more about this process)
Video - in "About this MAC" shows me that i've Intel HD4600 VRAM:1536 mb and PCIe Nvidia VRAM: 0mb. Yeah, i still have graphical glitches in system, no graphical acceleration. I have Nvidia with Optimus technology, so now i try to off this card via DSDT.
WiFi+Bt: Sad story.
On different forums i've readed that RTL8723AE not supports by MAC thousand times.But i'm still have faith in my own hands and that not all is ended. Progging is not for me, so i just would try to edit existing kexts and what is possible. One man on Applelife forums was experimented with this card and i hope he would succes in this because he is more expirienced than me.
Now only one way for me is using Win7 on same notebook. Replace for this card i didn't find in Russian stores. They sales only in Ebay or something like this(about 40-45$)
RAM is detected by OSX correctly without any settings - that is plus.
From different things, not so important:
1. Cam is not working
2. Cardreader not tried
3. HDMI and VGA not tried
4. Headphones is working
5. Mic not tried but could be working
6. AppStore and Apple services not working(Can't identify your Mac or Device)
7. Now screen brightness and loudness can be adjusted by Fn+Up/Down, Fn+Left/Right, also sleep and turning of a screen is fixed, it is works now as should. (Fixed by properly installed Clover so, READ MANUAL)
8. Battery Indication have been added by simple installing the ACPIBatteryManager by RehabMan.
9. Ethernet is working correctly with Qualcomm Atheros Killer E2200
10. Trackpad by Synaptics is working with VoodooPS2Controller and SmartTouchPad, but scrolling by swiping on the side of pad is not available.

This post is updating when system have improvements in work.
 
Last edited:
Top