Contribute
Register

Mountain Lion HDMI Audio

Status
Not open for further replies.
Joined
May 16, 2011
Messages
178
hi, Toleda
I'm using a gts 250, but every time I connect the HDMI cable the system hangs
I was wondering if you can help me fix this and if it's possible to have HDMI sound working.
Thank you!
 

toleda

Moderator
Joined
May 20, 2010
Messages
23,008
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
hi, Toleda
I'm using a gts 250, but every time I connect the HDMI cable the system hangs
I was wondering if you can help me fix this and if it's possible to have HDMI sound working.
Thank you!
What does Console say?
I don't know how to solve a Nvidia HDMI video problem (look at NVCAP). A work around is a DVI2HDMI adapter.
The GTS 250 does not have an HDMI audio codec. If you get HDMI video to work, you can connect motherboard SPDIF (2 wire) to GTS 250 SPDIF for "HDMI" audio.
 
Joined
Jul 29, 2012
Messages
158
Motherboard
OsX Mountain Lion 10.8.2
CPU
Intel Core I5 3570K 3.4 GHZ
Graphics
Intel HD 4000 Integrated Graphics
Mac
Classic Mac
Mobile Phone
  1. iOS
hi, Toleda
I'm using a gts 250, but every time I connect the HDMI cable the system hangs
I was wondering if you can help me fix this and if it's possible to have HDMI sound working.
Thank you!

Mirone, about HDMI video, you might as well ask help in the NVEnabler development topic (ProjectOSX): they have success reports even with cards like the 9800GT, which is usually reported as a nigh-impossible card to get working.

Good luck!

P.S.: How about the 620?

P.P.S.: It appears 10.8.3 broke NVEnabler.
 
Joined
May 16, 2011
Messages
178
Mirone, about HDMI video, you might as well ask help in the NVEnabler development topic (ProjectOSX): they have success reports even with cards like the 9800GT, which is usually reported as a nigh-impossible card to get working.

Good luck!

P.S.: How about the 620?

P.P.S.: It appears 10.8.3 broke NVEnabler.

My Graphics Card Geforce Gt620 works well,
I'll look that suggested I thank you!
 

wildwillow

Moderator
Joined
Jun 26, 2012
Messages
4,107
Motherboard
Z170 Deluxe
CPU
i5-6600K
Graphics
GTX 970
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
  2. Other
Hi, Toleda.

Great guide and Thanks very much.

I am trying to help a friend with HDMI audio with HD4000, We followed your guide yet we are unable to get HDMI audio working. We had no compile errors and used your editing kit thanks. Is it possible for you to take a look at the files I have uploaded and see if there is something that we have missed. The motherboard is Z77-DS3H. ALC887. Much appreciated.

EDIT Anyone interested in the DSDT.aml file it is for Bios version F5. Use at your own risk.
 

Attachments

  • DSDT.aml.zip
    13.5 KB · Views: 60
  • io reg.zip
    444.8 KB · Views: 60

toleda

Moderator
Joined
May 20, 2010
Messages
23,008
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
Hi, Toleda.

Great guide and Thanks very much.

I am trying to help a friend with HDMI audio with HD4000, We followed your guide yet we are unable to get HDMI audio working. We had no compile errors and used your editing kit thanks. Is it possible for you to take a look at the files I have uploaded and see if there is something that we have missed. The motherboard is Z77-DS3H. ALC887. Much appreciated
Missed this step, Post #1:
Mountain Lion HDMI audio - Verify S/L/E ....
1. Delete any and all audio enablers (HDAEnabler1, ....
 

wildwillow

Moderator
Joined
Jun 26, 2012
Messages
4,107
Motherboard
Z170 Deluxe
CPU
i5-6600K
Graphics
GTX 970
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
  2. Other
Missed this step, Post #1:
Mountain Lion HDMI audio - Verify S/L/E ....
1. Delete any and all audio enablers (HDAEnabler1, ....

Outstanding. Deleted the HDAEnabler1.kext from S/L/E.. and HDMI is working. Thanks very much for your guide, help and fast reply. Really Appreciate it.
 
Joined
Aug 3, 2012
Messages
17
CPU
Intel I5 3570K
Graphics
GTX 660
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hello toleda,

My HDMI audio is 99% working after I followed your guide and applied a custom patch from you in this post

http://www.tonymacx86.com/hdmi-audio/70765-mountain-lion-hdmi-audio-84.html#post578839

Thanks again!

There is still one issue that happens when the system wakes from sleep, the HDMI sound is lost, the system preference, the menubar and apps using sound devices, like iTunes, XBMC, Parallels, Chrome will stop responding forever :beachball:. Force quit and run them again won't resolve it. Have to restart. Meanwhile, the rest of the system still works normal.

Could this be fixed by a further patch? When you have a chance please take a look at the current IOReg one more time (attached below). Thanks a lot!!
 

toleda

Moderator
Joined
May 20, 2010
Messages
23,008
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
There is still one issue that happens when the system wakes from sleep, the HDMI sound is lost, the system preference, the menubar and apps using sound devices, like iTunes, XBMC, Parallels, Chrome will stop responding forever
Don't see any problems in IOReg. Install the native dsdt, restart and verify sleep. Reply with result.
 
Status
Not open for further replies.
Top