Contribute
Register

Mountain Lion HDMI Audio

Joined
Oct 13, 2012
Messages
17
Motherboard
ga-z77n-wifi - 2x 4gb ram
CPU
i3 3225
Graphics
i-4000
Mac
Classic Mac
Mobile Phone
The Capri edit is correct. You did not edit AppleHDA.kext, Step 2.


ooh

sorry thought that was cause of my question with spdif -

when i looked at this in the morning - there was a replay with a preedetit 992 edited hda.kext.

dont find it anymore -

i will try to absolve step 2 - and put io-reg afterwards

thanks a lot

regards
 
Joined
Apr 7, 2012
Messages
66
Motherboard
Asus P8Z77-M-Pro
CPU
i5 3570K
Graphics
HD4000
Mac
  1. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Other
With your help I have HDaudio using LayoutID:3. I have now changed to LayoutID:1 in order to add my GT210 graphics card, but with it plugged in I am unable to boot with hdmi from mb or graphics card. I have modified NVDANV50.kext to include info.plist lines at bottom for VendorID (0x10de) and DeviceID (0x0a65), fixed permissions and caches with Kext Editor without success.
The files below are therefore with the graphics card removed.
Can you help further please?
 

Attachments

  • Eric’s MacPro.zip
    396.8 KB · Views: 29
  • dsdt.aml.zip
    18.5 KB · Views: 37
  • org.chameleon.Boot.plist.zip
    925 bytes · Views: 34

toleda

Moderator
Joined
May 20, 2010
Messages
24,258
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
With your help I have HDaudio using LayoutID:3. I have now changed to LayoutID:1 in order to add my GT210 graphics card, but with it plugged in I am unable to boot with hdmi from mb or graphics card. I have modified NVDANV50.kext to include info.plist lines at bottom for VendorID (0x10de) and DeviceID (0x0a65), fixed permissions and caches with Kext Editor without success.
The files below are therefore with the graphics card removed.
Can you help further please?
For HD4000, the Audio ID is 3. If you want to add the GT 210, the Audio ID is still 3. The problem with booting HD4000 and GT 210 is not device_ids. Use PCIRooID=1 as a boot flag or add it to org.chameleon.Boot.plist.
 
Joined
Oct 13, 2012
Messages
17
Motherboard
ga-z77n-wifi - 2x 4gb ram
CPU
i3 3225
Graphics
i-4000
Mac
Classic Mac
Mobile Phone
The attached IOReg does not show working HDMI audio, it shows the first HDMI connector connected to a DP connector in the framebuffer.


2. See Procedure 10. 2x HD3000/HD4000 HDMI Audio, Customizing the Mountain Lion Optimized AppleHDA.

hi toleda,

after trying since many hours i need some help please

trying to step2 - procedure 10

i deleted item3 in platforms.xml


but i am stuck now

i opened info.plist from the appleHDAHardwareConfigDriver.kext with plistedit pro
but there i can find "21671c30 21671d60 21671e01 21671f01 several times - do i have to edit all off them or change only the first one?





is this the right info.plist i use? if it is an other one - please tell me where i can find it.


do i use the right editor for both changes (10a and 10b) ? i use plistedit pro

please forgive me being such a noob - and thx for your patience with me
regards
 

Attachments

  • deleted item3 in platforms-xml.tiff
    228.8 KB · Views: 45
Last edited by a moderator:

toleda

Moderator
Joined
May 20, 2010
Messages
24,258
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
hi toleda,

after trying since many hours i need some help please

trying to step2 - procedure 10

i deleted item3 in platforms.xml
You are in CommonPeripheralDSP which is wrong. Start over with a fresh 892 Optimized ML AppleHDA.kext.
I assume you are deleting Item 3 Line Out
PlistEditPro/Open Platforms.xml/Open Pathmaps/Open Item 11/
Verify PathMapID 392
The is what you should see:
Screen Shot 2012-10-18 at 4.42.33 PM.png
Delete Item 3
Save. Install

PlistEditPro/Open Info.plist/IOKitPersonalities/HDAHardwareConfigResource/HDAConfigDefault/Open Item 12/
Verify CodecID: 283904146 (892) & LayoutID: 3
The is what you should see:
Screen Shot 2012-10-18 at 4.47.56 PM.jpg
Edit ConfigData
Find: 21671c30 21671d60 21671e01 21671f01
Replace: 21671ca0 21671d01 21671e43 21671f99
Save. Install


Install edited AppleHDA,kext with KextBeast. Restart.
 
Joined
Apr 7, 2012
Messages
66
Motherboard
Asus P8Z77-M-Pro
CPU
i5 3570K
Graphics
HD4000
Mac
  1. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Other
Thanks again, toledo. Issue is sorted, using PCIRootUID=1.
 
Joined
May 18, 2011
Messages
94
Motherboard
Mac Mini
CPU
i5 2500k
Graphics
Intel 3000HD
Mac
Classic Mac
Mobile Phone
Here it is after deleting HDAenabler.
 

Attachments

  • dsdt-prguy85.zip
    26 KB · Views: 27
  • ioreg-prguy85.zip
    399.9 KB · Views: 28
Joined
Jun 30, 2011
Messages
49
Motherboard
Gigabyte GA-Z87MX-D3H
CPU
Core i3 4330
Graphics
HD4600
Mobile Phone
  1. iOS
Finally took some time out to upgrade from Patched 10.6.4 AppleHDA ['Advanced Method' GT 240] to Patched 10.8.2 AppleHDA. Proud to say I have both HDMI and on-board audio working. The editing kit is one heck of a lot easier than the 'manual' way. Thanks toleda!

1) Download Native (virgin) DSDT.aml from [tonymac DSDT database].
2) Patch Native DSDT.aml with [HD3000_Award_hdmi_audio_dsdt_editing_kit.zip]. Kept default layout-id 1 (by choice)
3) /Extra/ -> replaced current DSDT.aml with new patched DSDT.aml

4) S/L/E -> deleted ALC8xxHDA.kext
5) Multibeast 5.1.2 -> Audio -> w/DSDT -> ALC 889

6) /Extra/org.chameleon.Boot.plist edited **Important** I had this as 'No' from the old Patched 10.6.4 AppleHDA guide. Make sure to change to 'Yes' for this 10.8.2 guide.
Code:
	<key>GraphicsEnabler</key>
	<string>Yes</string>

7) Restart
 

Attachments

  • Screen Shot 2012-10-19 at 5.37.57 AM.png
    Screen Shot 2012-10-19 at 5.37.57 AM.png
    96.8 KB · Views: 107
  • Screen Shot 2012-10-19 at 5.38.25 AM.png
    Screen Shot 2012-10-19 at 5.38.25 AM.png
    85.7 KB · Views: 168
  • Screen Shot 2012-10-19 at 5.42.41 AM.jpg
    Screen Shot 2012-10-19 at 5.42.41 AM.jpg
    193.2 KB · Views: 151
Top