Contribute
Register

Mountain Lion (10.8) Unable to sign into App Store, iCloud or FaceTime

Joined
Sep 24, 2010
Messages
10
Motherboard
asus p6x58d premium
CPU
i930
Graphics
ati radeon hd 5850
Mac
Classic Mac
Mobile Phone
Hi,

I have an Asus p6x58d premium machine that is dual booting win7 and mountain lion. I was able to install 10.8 onto a drive using unibeast. I do not use chameleon, but boot off the unibeast usb drive to choose the hackintosh drive when I want to boot into the Mac. The unibeast install did not, however, have the yukon ethernet kext, and so I had to manually install it using kextbeast (using the IONetworkingFamily.kext file). I also used the latest multibeast to install the HDA audio for the built in ALC 889 audio. I have not been able to log into the App store or iCloud, getting "an unknown error has occurred". I also cannot log into facetime, getting "The server encountered an error processing registration. Please try again later."

For facetime I tried editing the /etc/hosts.equiv file as some web tutorials have suggested, but with no success.

I have seen a number of suggested fixes for the icloud/ appstore suggesting to run EFI Studio. I ran both the 1.o and 1.1 versions, added an ethernet device, and had the software write to com.apple.Boot.plist. These instructions then said to add the key which gets added by EFI tools to the com.apple.Boot.plist file in /Extra - but I do not have such a directory (as I do not run chameleon, and do not have a DSDT for my asus p6x58d premium board). I went on to delete the network file from /Library/Preferences/SystemConfiguration directory, and removed all my devices from the network control panel. I then rebooted and added back my network connections, starting with the ethernet connection. Despite doing all of this, I still get the above mentioned error for logging into icloud and the appstore.

Any suggestions on how to fix this problem would be a huge help.

Cheers,

GH
 
Joined
Jul 12, 2012
Messages
22
Motherboard
GA-H61M-S2-B3-F3
CPU
Core i3 - Sandy Bridge
Graphics
Galaxy Nvidia GT520
Mac
Classic Mac
Mobile Phone
iOS
I have the same exact issue as you, went down the same exact rode. If I come across the fix I will let you know.

I think you might be on to something with the ethernet kext, I am using the AtherosL1cEthernet.kext myself. But then again, everything worked in SL and Lion like a dream.
 
Joined
May 12, 2012
Messages
76
Motherboard
Big Ben
CPU
Intel Dual Core 2.4ghz
Graphics
Nvidia 8600GT
Mac
Mac mini
Classic Mac
Mobile Phone
iOS
Could this serial issue also cause Quicktime to not work right? With 10.6.8, I was able to watch WMVs that were embedded an an asx file from work, but I haven't been able to do so since I did a clean install of 10.8.
 
Joined
Jan 31, 2011
Messages
998
Motherboard
asus sabertooth x58
CPU
i7-950
Graphics
nvidia gtx 750ti
Classic Mac
Performa, Power Mac, SE
Mobile Phone
Android
try this
quote from tonymac:
Issue: Can't log into iCloud.
Solution: Update to latest Chimera

Issue: Still can't log into iCloud- first time setting it up on any device.
Solution: Change /Extra/smbios.plist serial number- for example:

Code:
<key>SMserial</key>
<string>G88451235J4</string>


change 845123 to something between 750xxx to 905xxx

Code:
<key>SMserial</key>
<string>G88451005J4</string>


then reboot. After setting it up for the first time- you will be able to return your serial number to the previous MultiBeast default.
 
Joined
Jul 12, 2012
Messages
22
Motherboard
GA-H61M-S2-B3-F3
CPU
Core i3 - Sandy Bridge
Graphics
Galaxy Nvidia GT520
Mac
Classic Mac
Mobile Phone
iOS
I have the same exact issue as you, went down the same exact rode. If I come across the fix I will let you know.

I think you might be on to something with the ethernet kext, I am using the AtherosL1cEthernet.kext myself. But then again, everything worked in SL and Lion like a dream.
I managed to finally get it working, there is some good information in my thread that may help.


http://www.tonymacx86.com/mountain-lion-desktop-support/64547-icloud-app-store-facetime-messages-unable-authenticate.html
 
Joined
Mar 9, 2011
Messages
611
Motherboard
Gigabyte Z390 UD
CPU
i9-9900K
Graphics
Vega 56
Mac
iMac, MacBook Pro, Mac Pro
Classic Mac
iMac
Mobile Phone
iOS
Joined
Jul 9, 2011
Messages
17
Motherboard
Gigabyte GA-Z77X-UD5H
CPU
i7 4800
Graphics
Dual Radeon HD6870
Mac
MacBook Pro
Mobile Phone
iOS
ive done everything yet i could only get icloud and app store to work, messages and facetime still wont allow me to login successfully
 
Top