Monterey/Ventura on HP EliteDesk 800 G4/G5 Mini - The Perfect MacMini8,1 Hackintosh - OpenCore

Hi, Everyone. Final I find the problem of Dell DW1820A why cann't work on my Ventura 13.1. What I need to do is change the USBPort-16.kext, delete SS10. Then for the WiFi we need the Broadcom AirportBrcmFixup, When we load this kext, there will show three kext in OC config.plist(for its package have two Plugins), what we need to do is disable "AirPortBrcm4360_injector.kext and and enable AirPortBrcmNIC_Injector", with the AirPortBrcmFixup.kext. After Reboot, My Dell DW1820A CN-08PKF4 and Lenovo 00JT494(BCM94350) WiFi and Bluetooth all works fine now. at the same time the long time start waiting bing shorter much. Wow!

Replenish:The Dell DW1820A sometimes can work, sometimes doesn't work. even some time there will be stack on the white Apple Logo. I have tried many times, this WiFi card still unstable. I have tried to reset the NVRAM many times. Can any one help.


  • WechatIMG6.jpeg
    54.3 KB · Views: 43
  • WechatIMG7.jpeg
    47.4 KB · Views: 38
  • WechatIMG8.jpeg
    40.2 KB · Views: 43
  • WechatIMG9.jpeg
    165.1 KB · Views: 42
Last edited:
I have changed to BCM94360NG, all works fine. This is the easiest way to me.
I have changed to BCM94360NG, all works fine. This is the easiest way to me.
I replaced the one that came in my HP ProDesk 600 G4 mini with an BCM94360NG card which works perfectly OOB.
This was an interesting adventure.
Used a created Ventura install USB.
At first the installer kept hanging with kernel panics.
I can’t stress hard enough that is CRITICAL to have a proper USB mapping kext made. Find one that works for you from the EFI’s in this post.
In Ventura any kind of all ports injected doesn’t work. After I fixed the USB mapping, I had no other issues after that.
The installation went smoothly, and runs great!
Updated efi file for post 1 that includes a working USB map.
Anyone else able to test it on there's you will need to add all your serial information again.
Havent updated to the latest version of open core yet but will do over the next few weeks


  • EFI Edited
    4.3 MB · Views: 145

ADT-Link M.2 key M NVMe External Graphics Card Stand Bracket with PCIe3.0 x4 Riser Cable 25cm 50cm 32Gbs For ITX STX NUC VEGA64 GTX1080ti (50CM,R43SG)

and these Dell 220W DA-2 AC Power Supply Adapter (MK394)

any one tried thid with the hp minis?
Just updated to Monterey 12.6.4, no issues so far. Verified WiFi/BT working.

EliteDesk 800 G4 DM (Mini)
Same here! Plus updated to the latest BIOS version. Works flawlessly :)
updated to 13.3.1 of ventura no issues so far
Can you upload your configuration EFI file?I upgraded 13.2 and kept getting stuck in the white apple interface。thank you