Contribute
Register

Mojave upgrade: "Error verifying firmware"

Joined
Nov 8, 2013
Messages
57
Motherboard
Gigabyte Z87X-U3DH
CPU
i7-4770K
Graphics
GT 640
Mobile Phone
Android
Hi all -
Updating 10.13.6 -> 10.14.1
Gets to the second black screen, progress bar gets to about 35-40%, then it quits, saying the upgrade failed - "Error verifying firmware." Tried restarting it again, same result, have to boot back into 10.13.6.

Looking through an older thread (same issue on install of High Sierra), I found that some fields need to be filled in the SMBIOS section. Did that, but still no go. Screenshot of SMBIOS attached. Any thoughts?

Screen Shot 2018-11-16 at 17.53.10.png

Thanks very much, in advance!
 
Joined
Apr 1, 2010
Messages
87
Motherboard
GA Z170X-GAMING 5
CPU
i7-6700
Graphics
RX 580
Mac
MacBook, MacBook Pro, Mac mini
Mobile Phone
iOS
try clean install.
 
Joined
Jan 26, 2014
Messages
1,381
Motherboard
Asus P5LP-LE
CPU
Core 2 Duo
Graphics
Nvidia GeForce GT 640
Mac
Mac Pro
Mobile Phone
iOS
That would be a last resort. Any other ideas?
it's actually best to not fill out those fields and just update clover and it will inject the current correct data
 
Joined
Nov 8, 2013
Messages
57
Motherboard
Gigabyte Z87X-U3DH
CPU
i7-4770K
Graphics
GT 640
Mobile Phone
Android
OK, all -

Waited for 10.14.3 to come out. Downloaded it and the latest Unibeast and Multibeast, created new install USB. Backed up startup MacOS 10.13.6 SSD. Installed Clover is v. 4658 on one box and 4741 on the other. Tried the install again. It almost got through the second pass (progress bar about 3mm from the end), then got this again (see pic). Same problem as before (see original post). Tried it on both machines. BIOS settings are as advised. Could this have anything to do with the fact that I'm running 10.13.6 on HFS+ rather than APFS?

On top of this, now, on boot to High Sierra, my mouse no longer works (it works fine when booting to Linux or Windows on the same box). :-/

Any advice appreciated.
 

Attachments

Joined
Nov 8, 2013
Messages
57
Motherboard
Gigabyte Z87X-U3DH
CPU
i7-4770K
Graphics
GT 640
Mobile Phone
Android
It did on my last install, when I gave up and used APFS all went well. Hope you figure it out on your end, as reformatted to disk I used to install to make mine work.

I've resigned myself to being stuck with APFS on Mojave - from what I see, there's no choice if you're installing to an SSD. I thought that the install did the conversion automatically. Am I wrong on that?

So, you wound up having to do a clean install? Any way around that? If I could restore my apps and data from a Time Machine backup, that would be OK, but I've not had to do that before as upgrades have gone pretty smoothly, for the most part, until these issues with Mojave.
 
Joined
Nov 8, 2013
Messages
57
Motherboard
Gigabyte Z87X-U3DH
CPU
i7-4770K
Graphics
GT 640
Mobile Phone
Android
Perhaps may you try iMac15,1 SMBIOS : i have a similar build with an i5 4460 and it woks fine with .
Hmmm. Might be worth a try, but then I'd have to come up with a new serial number. Already having ongoing issues with FaceTime and authentication (though iCloud works fine).
 
Top