Contribute
Register

Mojave Running Slower Probably due to Some Problem with Memory Map Allocation

Joined
Jul 22, 2017
Messages
4
Motherboard
Dell Inspiron 3542
CPU
i5-4210U
Graphics
Intel HD 4400, GT 840m, 1366X768
Mac
MacBook Pro
Mobile Phone
Android
I installed Mojave a few weeks ago on my laptop (dual boot with sierra) .
Felt it was running a bit slower than sierra. Navigation through the system and animations were all smooth. But opening apps and switching between them felt slower. Like Chrome usually took around 12-20 sec to show up a new window. (Only For the 1st time after boot, after that it open ups new windows almost instantly)

Searched a lot in forums. I came to know about UEFI64 drivers within clover. Tried switching between drivers. Switching between AptioMemoryFix, OsxAptioFixDrv and OsxAptioFix3Drv, resulted in slight variations in app opening time. I tried all 3 different drivers multiple times from different clover builds (both stable and beta versions).
They simultaneously affected the performance of both the OSes. Some made them both run even slower while some improved the performance.
Variation in performance was noticable and none of them helped mojave run as snappy as sierra.

Right now Sierra works best with AptioMemoryFix(clover r4810), earlier it ran better with OsxAptioFix3Drv(clover r4809).
Now Sierra takes around 3-4 sec to launch chrome, while currently mojave takes around 8-12 sec to launch chrome (No matter which memory fix I use, It never took less than that, while some made took ever more).

Scenario is same with all most all the applications.

Switching to AptioMemoryFix (clover r4809) makes even sierra run as slow as mojave.

What should i do to make Mojave run as snappy as sierra?

My Laptop Specs:

i5 4210U

4 gb DDR3 RAM

2gb 840m gpu (disabled)

1TB HDD
 

Attachments

Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,075
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I installed Mojave a few weeks ago on my laptop (dual boot with sierra) .
Felt it was running a bit slower than sierra. Navigation through the system and animations were all smooth. But opening apps and switching between them felt slower. Like Chrome usually took around 12-20 sec to show up a new window. (Only For the 1st time after boot, after that it open ups new windows almost instantly)

Searched a lot in forums. I came to know about UEFI64 drivers within clover. Tried switching between drivers. Switching between AptioMemoryFix, OsxAptioFixDrv and OsxAptioFix3Drv, resulted in slight variations in app opening time. I tried all 3 different drivers multiple times from different clover builds (both stable and beta versions).
They simultaneously affected the performance of both the OSes. Some made them both run even slower while some improved the performance.
Variation in performance was noticable and none of them helped mojave run as snappy as sierra.

Right now Sierra works best with AptioMemoryFix(clover r4810), earlier it ran better with OsxAptioFix3Drv(clover r4809).
Now Sierra takes around 3-4 sec to launch chrome, while currently mojave takes around 8-12 sec to launch chrome (No matter which memory fix I use, It never took less than that, while some made took ever more).

Scenario is same with all most all the applications.

Switching to AptioMemoryFix (clover r4809) makes even sierra run as slow as mojave.

What should i do to make Mojave run as snappy as sierra?

My Laptop Specs:

i5 4210U

4 gb DDR3 RAM

2gb 840m gpu (disabled)

1TB HDD
No ioreg in the attached debug zip. Please check your files carefully before upload.
 
Joined
Jul 22, 2017
Messages
4
Motherboard
Dell Inspiron 3542
CPU
i5-4210U
Graphics
Intel HD 4400, GT 840m, 1366X768
Mac
MacBook Pro
Mobile Phone
Android
No ioreg in the attached debug zip. Please check your files carefully before upload.
Here's the updated debug zip with ioreg.

I wanna add that, I just tried updating to the latest stable build of clover(r4813). Using that now sierra feels even better! Chrome earlier took 4-5 sec to open, now takes only 2-3 sec to open up! VLC media player also earlier took 4+ sec to load now loads up in 2-3 sec. I don't understand what's going on, but no luck with Mojave, it's still slow.

I then tried upgrading drivers from clover(r4822) beta version, that made Sierra work as slow as Mojave, with no improvement in Mojave's performance.

I think the problem is with those drivers, as changing them affects the performance of Sierra too.

I also wanna add that boot up time of Mojave is also slower than Sierra. Sierra takes around 60sec to boot up while Mojave takes around 80-90sec to boot up (both from HDD).

While booting Mojave , It takes a lot of time mostly between these 2 statements (around 15-20 sec):
Code:
localhost com.apple.xpc.launchd[1] <Notice>:Early boot complete. Continuing system boot.[/INDENT]
Waiting for DSMOS...
Also while turning Off Mojave some additional lines come up that i have never seen with Sierra :
Code:
vm_map_delete: map <ptr> [0x10a0f0000...0x10a0f8000] nothing at 0x10a0f0000
and a few more with different hexadecimal values.​
just added as I thought it might help!
 

Attachments

Last edited:

Feartech

Moderator
Joined
Aug 3, 2013
Messages
13,359
Motherboard
Asus N752VX-Clover
CPU
i7-6700HQ / HM170
Graphics
HD530 + GTX 950m 1920 x 1080
Mac
iMac
Mobile Phone
iOS
Here's the updated debug zip with ioreg.

I wanna add that, I just tried updating to the latest stable build of clover(r4813). Using that now sierra feels even better! Chrome earlier took 4-5 sec to open, now takes only 2-3 sec to open up! VLC media player also earlier took 4+ sec to load now loads up in 2-3 sec. I don't understand what's going on, but no luck with Mojave, it's still slow.

I then tried upgrading drivers from clover(r4822) beta version, that made Sierra work as slow as Mojave, with no improvement in Mojave's performance.

I think the problem is with those drivers, as changing them affects the performance of Sierra too.

I also wanna add that boot up time of Mojave is also slower than Sierra. Sierra takes around 60sec to boot up while Mojave takes around 80-90sec to boot up (both from HDD).

While booting Mojave , It takes a lot of time mostly between these 2 statements (around 15-20 sec):
Code:
localhost com.apple.xpc.launchd[1] <Notice>:Early boot complete. Continuing system boot.[/INDENT]
Waiting for DSMOS...
Also while turning Off Mojave some additional lines come up that i have never seen with Sierra :
Code:
vm_map_delete: map <ptr> [0x10a0f0000...0x10a0f8000] nothing at 0x10a0f0000
and a few more with different hexadecimal values.​
just added as I thought it might help!
As per rules, please update your hardware profile to allow others to help you easier
https://www.tonymacx86.com/account/

please read the faq for proper hardware profile setup:
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
 
Top