Contribute
Register

Mojave on Intel DX79SI

Joined
Mar 29, 2012
Messages
21
Motherboard
Intel DX79 SI
CPU
i7-3930K
Graphics
GTX 680
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
triton, thank you I'm aware of it. I was able to move to stage two where I'm booting from CBM and choosing Boot from OSX Mojave then its stack at less then minute remaining message.
 
Joined
Mar 29, 2012
Messages
21
Motherboard
Intel DX79 SI
CPU
i7-3930K
Graphics
GTX 680
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
you

Obviously , this problem has nothing to do with the installer file . Your CPU and video card is different from mine ,esp. the video card , also you MOBO is slightly different from mine (the DSDT, SSDT files should change to your own ones ,or just hot patches ), you may take these things into consideration.Wish you good luck !
Hi, Finally got free time from work to return to my build. I extracted native ACPI files from BIOS of my Intel DX79SI at Clover boot screen and having hard time disassembling ACPI files in terminal using refs.txt for patching in MacIASL. Can some one please help me to compile it?
 

Attachments

  • EFI.zip
    3.5 MB · Views: 60
Joined
Mar 21, 2011
Messages
16
Motherboard
Homebrew
CPU
i7-3770
Graphics
Radeon 6770
Mac
Classic Mac
Mobile Phone
Are you still struggling with your DX79SI or do you finally have a stable build? I have this board and have been struggling to boot any installer successfully. Will try following the advice on this thread tomorrow.
 
Joined
Mar 29, 2012
Messages
21
Motherboard
Intel DX79 SI
CPU
i7-3930K
Graphics
GTX 680
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
Are you still struggling with your DX79SI or do you finally have a stable build? I have this board and have been struggling to boot any installer successfully. Will try following the advice on this thread tomorrow.
Hi TonyBurn. I'm still running on OS X 10.9.3 Mavericks. Since I have to do some 3D rendering work, so I temporary stopped trying with this install for now. I will continue when I'll have free time from my job. Really need to upgrade to newer OS. I wish you luck on your build and please feel free to post here your progress. I will definitely post too when I return to mine installation process. Hope all as well!
 
Joined
Oct 23, 2020
Messages
2
Motherboard
Intel DX79SI
CPU
Intel(R) Core(TM) i7-3930K CPU @ 3.20GHz
Graphics
Zontag GeForce GTX 680
Mac
  1. iMac
  2. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
Some how I was able to complete WELCOME screen in Mojave, after adding kexts AppleAHCIPort and AppleUSBXHCI. Patches EHC1 to EH01, EHC2 to EH02.
I turned off usb3 ports in BIOS.
I noticed that Mojave created 3 partitions:
Boot macOS Install Prebooter from Preboot
Boot macOS Install from Mojave
Boot Recovery from Recovery

Booting from USB to Mojave -x -v npci=0x2000 cpus=1 , Mojave starts in safe mode which disables mount efi and edit CLOVER config.plist.
I have tried several EFI mounters and terminal as well.

Booting from USB to Mojave -v npci=0x2000 cpus=1 PCIRootUID=1 dart=0 args shows macOS could not be installed on your computer. An error occurred while updating firmware.
After pressing restart got SATA WARNING: Enable Drive PHY PM failed.
Wondering why its starts upgrade process anyway? maybee full install not compleeted?
What did I missed?
I've included my bootlog file
 

Attachments

  • Screenshot 2020-10-23 at 12.48.10.png
    Screenshot 2020-10-23 at 12.48.10.png
    2.7 MB · Views: 35
  • Screenshot 2020-10-24 at 06.40.50.png
    Screenshot 2020-10-24 at 06.40.50.png
    1.9 MB · Views: 33
  • Screenshot 2020-10-24 at 06.51.07.png
    Screenshot 2020-10-24 at 06.51.07.png
    2.5 MB · Views: 40
  • Screenshot 2020-10-24 at 07.02.50.png
    Screenshot 2020-10-24 at 07.02.50.png
    2.2 MB · Views: 32
  • Screenshot 2020-10-24 at 12.06.45.png
    Screenshot 2020-10-24 at 12.06.45.png
    1.1 MB · Views: 28
  • Screenshot 2020-10-24 at 23.20.33.png
    Screenshot 2020-10-24 at 23.20.33.png
    63.2 KB · Views: 31
  • Screenshot 2020-10-24 at 23.40.27.png
    Screenshot 2020-10-24 at 23.40.27.png
    136.1 KB · Views: 32
  • Screenshot 2020-10-24 at 23.40.46.png
    Screenshot 2020-10-24 at 23.40.46.png
    384.5 KB · Views: 32
  • Screenshot 2020-10-24 at 23.42.04.png
    Screenshot 2020-10-24 at 23.42.04.png
    109.1 KB · Views: 34
  • Screenshot 2020-10-24 at 23.43.03.png
    Screenshot 2020-10-24 at 23.43.03.png
    164.1 KB · Views: 27
  • IMG_4495.JPG
    IMG_4495.JPG
    865.8 KB · Views: 28
  • IMG_4498.JPG
    IMG_4498.JPG
    382.9 KB · Views: 32
  • bootlog.txt
    33.4 KB · Views: 26
Last edited:
Joined
Mar 29, 2012
Messages
21
Motherboard
Intel DX79 SI
CPU
i7-3930K
Graphics
GTX 680
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
Are you still struggling with your DX79SI or do you finally have a stable build? I have this board and have been struggling to boot any installer successfully. Will try following the advice on this thread tomorrow.
Hi Tony Burn I can send you my Clover folder and you can mount your UFI partition and replace it with mine, just back up you clover config somewhere. I'm able to boot in safe mode only(( Need to figure out what causing boot error and message (OSX couldn't be installed on your computer) in regular boot from clover. Is there any way to change date in Clover to Mojave release date, then it's might work. Let me know if you had success with your build or need my Clover Folder with clover.config file
 
Joined
Mar 29, 2012
Messages
21
Motherboard
Intel DX79 SI
CPU
i7-3930K
Graphics
GTX 680
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
He it is bootable Clover folder for Intel DX79SI Mobo
 

Attachments

  • Mojave 10.14.6 EFI Boot.zip
    20.9 MB · Views: 27
Joined
Dec 22, 2020
Messages
1
Motherboard
Intel DX79SI
CPU
Xeon E5 1650
Graphics
AMD Radeon RX590
He it is bootable Clover folder for Intel DX79SI Mobo
Hey! I have a MOBO intel dx79si with a Xeon e5 1650v1 processor (Sandy-Bridge EP) with powerColor RX 590 discrete graphics. I used your EFI settings from the link. But I get a black screen instead of starting the installation. I really want a hackintosh, but I don't understand anything about it. Thank you! Sorry for my English, im from Russia=)
 
Top