Contribute
Register

Mojave on Asus Rog G771JW

Joined
Jul 2, 2018
Messages
31
Motherboard
Asus ROG G771JW
CPU
i7 4720HQ
Graphics
HD 4600
Mobile Phone
iOS
Your USB configuration is still wrong (should disable EHCI or use FakePCIID_XHCIMux.kext with appropriate EH01/EH02/HUB1/HUB2 configuration, XHC configuration is wrong [wrong UsbConnector values for some of the HSxx ports]).
Here is the new USB Configuration, hope is alright now.

Thanks.
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,692
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Here is the new USB Configuration, hope is alright now.

Thanks.
Did you disable USB3 in BIOS?
Or did the OEM just decide not to use Intel xHCI (for USB3) in this laptop?
 
Joined
Jul 2, 2018
Messages
31
Motherboard
Asus ROG G771JW
CPU
i7 4720HQ
Graphics
HD 4600
Mobile Phone
iOS
Did you disable USB3 in BIOS?
Or did the OEM just decide not to use Intel xHCI (for USB3) in this laptop?
you told me to disable the xHCI in the bios and remake the configuration and that’s what i did ... but after that i have read some more about the xHCI and in bios i have enable, disable and smart auto and since i disable it that means that the usb3 now is acting like usb2 and another thing now is that if i put the laptop on sleep it’s restarting afters sleep.
Should i remake the usb configuration on xHCI? is there any problem or difference between eh1/eh2 and xhci on osx?

By the way, i have 4 usb ports on the laptop and only one is usb3.

I have attached all the configuration possible with xhci enable/disable and FakePCIID_XHCIMux.kext

UPDATE:

With xHCI Smart Auto on bios and FakePCIID_XHCIMux.kext in test the USB3 Flash drive is working on XHC>SSP1, but after i apply the SSDT-UIAC-ALL when i connect the USB3 Flash drive is loaded on EH01>PR11>HP11
I'm totally lost now.
 

Attachments

Last edited:
Joined
Jul 2, 2018
Messages
31
Motherboard
Asus ROG G771JW
CPU
i7 4720HQ
Graphics
HD 4600
Mobile Phone
iOS
should disable EHCI or use FakePCIID_XHCIMux.kext with appropriate EH01/EH02/HUB1/HUB2
ok. in the previous reply you have all my test with xhci active or disabled and what i have done and what i get ...

Please check the picture
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,692
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
ok. in the previous reply you have all my test with xhci active or disabled and what i have done and what i get ...

Please check the picture
No idea what you're referring to.
You will need to write clear/concise questions.
 
Joined
Jul 2, 2018
Messages
31
Motherboard
Asus ROG G771JW
CPU
i7 4720HQ
Graphics
HD 4600
Mobile Phone
iOS
Hi,
So, i've tried all my best on fixing all the problems and now i have a perfect fuctional audio, functional usb where the usb3 are now listed in SSP and usb2 in HP.
Also now when i connect my hdmi on the sound settings my tv appears there but i dont get any sounds on the tv, so if you can give me an ideea on what the problem should be.

As a bonus bug, i dont know if is common or not, but if i connect my hdmi before i start my laptop the boot image goes in the tv and every time is loading the boot my laptop restarts, so i have to connect it after i get to the desktop.

Thanks.
 

Attachments

Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,692
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hi,
So, i've tried all my best on fixing all the problems and now i have a perfect fuctional audio, functional usb where the usb3 are now listed in SSP and usb2 in HP.
Also now when i connect my hdmi on the sound settings my tv appears there but i dont get any sounds on the tv, so if you can give me an ideea on what the problem should be.
Change settings in "Audio MIDI Setup.app".

As a bonus bug, i dont know if is common or not, but if i connect my hdmi before i start my laptop the boot image goes in the tv and every time is loading the boot my laptop restarts, so i have to connect it after i get to the desktop.
Typical.
 
Joined
Jul 2, 2018
Messages
31
Motherboard
Asus ROG G771JW
CPU
i7 4720HQ
Graphics
HD 4600
Mobile Phone
iOS
Change settings in "Audio MIDI Setup.app"
Done that but the master volume and L/R are disabled. Is there anything that i can change? Also do you think that i need some more changes/tweaks to my configuration?

By the way, my usb read/write speeds are very low, 9Mb on write and 90Mb on read on USB3 and even lower on USB2.

Thanks.
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,692
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Top