Contribute
Register

Mojave on Asus Rog G771JW

Joined
Jul 2, 2018
Messages
31
Motherboard
Asus ROG G771JW
CPU
i7 4720HQ
Graphics
HD 4600
Mobile Phone
iOS
So, i quit the ideea of using applehda for my sound card because is pure chinese for me, i wish i could understand what to do because everything that i have tried didnt work.
Now, on of the last problem that i wanna fix is that after my laptop is going to sleep in the next second is restarting i'm not sure what the problem could be, if you can help me with that.

Thanks.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,716
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
So, i quit the ideea of using applehda for my sound card because is pure chinese for me, i wish i could understand what to do because everything that i have tried didnt work.
Now, on of the last problem that i wanna fix is that after my laptop is going to sleep in the next second is restarting i'm not sure what the problem could be, if you can help me with that.

Thanks.
No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.
 
Joined
Jul 2, 2018
Messages
31
Motherboard
Asus ROG G771JW
CPU
i7 4720HQ
Graphics
HD 4600
Mobile Phone
iOS

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,716
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Here you go.
ACPI/origin files are too old. Today is July 19, but they are marked July 17.
Please read "Problem Reporting" carefully.

Note: It appears you did not patch for "instant wake".
See _PRW patches as mentioned in the ACPI patching guide:
https://www.tonymacx86.com/threads/guide-patching-laptop-dsdt-ssdts.152573/

Actually, looking further at your patched/DSDT.aml, you didn't even patch for _OSI("Darwin"). It is one of the most important patches ("OS Check Fix...").
 
Joined
Jul 2, 2018
Messages
31
Motherboard
Asus ROG G771JW
CPU
i7 4720HQ
Graphics
HD 4600
Mobile Phone
iOS
ACPI/origin files are too old. Today is July 19, but they are marked July 17.
Please read "Problem Reporting" carefully.

Note: It appears you did not patch for "instant wake".
See _PRW patches as mentioned in the ACPI patching guide:
https://www.tonymacx86.com/threads/guide-patching-laptop-dsdt-ssdts.152573/

Actually, looking further at your patched/DSDT.aml, you didn't even patch for _OSI("Darwin"). It is one of the most important patches ("OS Check Fix...").
What do you think now? my laptop goes on sleep now but it takes like 5 minutes for deep sleep when in the first seconds only the screen goes off. If i press any button on the keyboard goes on, but just like it was shuted down, not like an instant wake up.

Thanks.
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,716
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Joined
Jul 2, 2018
Messages
31
Motherboard
Asus ROG G771JW
CPU
i7 4720HQ
Graphics
HD 4600
Mobile Phone
iOS
Missing any kind of "OS Check Fix" patch.

See common patches as per ACPI patching guide https://www.tonymacx86.com/threads/guide-patching-laptop-dsdt-ssdts.152573/
Here are my new files ... i've succeded on making my soundcard to work with applehda.kext by patching it and i dont have tat problem anymore.
if you can tell me what i can do more to improve it.
All that i havent succeded is to make my hdmi sound to work and the airplay.

Also i wanna ask you if you know why if i use an usb 3.0 flash drive on the usb 2.0 port the usb drive is not working? the flash drive is working on the usb 3.0 port and the 2.0 flash drive is working on 2.0 port also my mouse is working on both 2.0 and 3.0

Thanks
 

Attachments

Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,716
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Here are my new files ... i've succeded on making my soundcard to work with applehda.kext by patching it and i dont have tat problem anymore.
if you can tell me what i can do more to improve it.
All that i havent succeded is to make my hdmi sound to work and the airplay.

Also i wanna ask you if you know why if i use an usb 3.0 flash drive on the usb 2.0 port the usb drive is not working? the flash drive is working on the usb 3.0 port and the 2.0 flash drive is working on 2.0 port also my mouse is working on both 2.0 and 3.0

Thanks
Your USB configuration is wrong.
See guide:
https://www.tonymacx86.com/threads/guide-creating-a-custom-ssdt-for-usbinjectall-kext.211311/
 
Joined
Jul 2, 2018
Messages
31
Motherboard
Asus ROG G771JW
CPU
i7 4720HQ
Graphics
HD 4600
Mobile Phone
iOS
I've patched the USB configuration and i hope that now is alright.
All seems to work good, i dont have any restart after sleep but it still takes a lot of time to go on sleep.

Now my last two problems are the HDMI video and HDMI audio:
1. video is working but if i have my tv connected when i boot, my laptop goes on restart, so i have to plug the cable and use it only after the osx is up.
1.1 the mirroring option it doesnt work and also the airplay doesnt work.(show mirroring otion in the menu bar - in yosemite was working)

2. audio is not working and i know that there are so many ways and patches but if you can guide me through whats the most usefull way to make it work - i will prefer the SSDT way with looks to be a more proper way to patch

Thanks for all your time.
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,716
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I've patched the USB configuration and i hope that now is alright.
All seems to work good, i dont have any restart after sleep but it still takes a lot of time to go on sleep.

Now my last two problems are the HDMI video and HDMI audio:
1. video is working but if i have my tv connected when i boot, my laptop goes on restart, so i have to plug the cable and use it only after the osx is up.
1.1 the mirroring option it doesnt work and also the airplay doesnt work.(show mirroring otion in the menu bar - in yosemite was working)

2. audio is not working and i know that there are so many ways and patches but if you can guide me through whats the most usefull way to make it work - i will prefer the SSDT way with looks to be a more proper way to patch

Thanks for all your time.
Your USB configuration is still wrong (should disable EHCI or use FakePCIID_XHCIMux.kext with appropriate EH01/EH02/HUB1/HUB2 configuration, XHC configuration is wrong [wrong UsbConnector values for some of the HSxx ports]).

Try with MacBookPro11,1 or MacBookAir6,2.

Need to hotplug second monitor is typical, but it might work better once you implement audio correctly. You didn't implement audio/HDMI-audio yet.

For audio, see links in FAQ.
 
Top