Contribute
Register

Mojave on Asus Rog G771JW

Joined
Jul 2, 2018
Messages
31
Motherboard
Asus ROG G771JW
CPU
i7 4720HQ
Graphics
HD 4600
Mobile Phone
iOS
Any change requires new PR files.
None attached.

Note that a few of your other issues are addressed in the FAQ (which you probably did not read):
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/

Your audio "not remembering settings" issue is likely due to incorrect NVRAM implementation.
Don't forget that EmuVariableUefi-64.efi requires "RC scripts" (see Clover installer options).
But maybe you don't need EmuVariableUefi-64.efi at all (in which case native NVRAM may work).

i have read it again, but i think that i dont know how to apply, what and where.
about the audio problem, i have reinstalled clover with RC scripts for EmuVariableUefi-64.efi, i didnt use the dsdt and the problems are the same.

is there any chance to send you what i have been using, all the files and patches and give a look at them?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,259
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
i have read it again, but i think that i dont know how to apply, what and where.
about the audio problem, i have reinstalled clover with RC scripts for EmuVariableUefi-64.efi, i didnt use the dsdt and the problems are the same.

is there any chance to send you what i have been using, all the files and patches and give a look at them?
You still failed to attach new PR files.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,259
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Here you go.
What specific problem are you working on?
Work on one problem at a time.
Your ioreg shows IGPU working just fine, but you have not implemented backlight control (link is in the FAQ).

Your kextcache output still shows kexts installed to the wrong location.
As per FAQ, kexts go to /L/E (on 10.11 and later), not /S/L/E.
 
Joined
Jul 2, 2018
Messages
31
Motherboard
Asus ROG G771JW
CPU
i7 4720HQ
Graphics
HD 4600
Mobile Phone
iOS
What specific problem are you working on?
Work on one problem at a time.
Your ioreg shows IGPU working just fine, but you have not implemented backlight control (link is in the FAQ).

Your kextcache output still shows kexts installed to the wrong location.
As per FAQ, kexts go to /L/E (on 10.11 and later), not /S/L/E.
Ok. So, i have reinstalled Mojave, i used now L/E for the kext and your config.plist for the HD4600.
Now i wanna fix one problem at the time as you said, and the first one is about the audio settings not been saved.
I have done a test if i have native NVRAM and i have and it looks that is saving. Also imessages, facetime and icloud are working, so maybe the problem is from the kext?

Thank you.
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,259
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Ok. So, i have reinstalled Mojave, i used now L/E for the kext and your config.plist for the HD4600.
Now i wanna fix one problem at the time as you said, and the first one is about the audio settings not been saved.
I have done a test if i have native NVRAM and i have and it looks that is saving. Also imessages, facetime and icloud are working, so maybe the problem is from the kext?

Thank you.
Audio issue then is probably VoodooHDA bug/problem.
See FAQ for details on patched AppleHDA.

See FAQ for iMessage guide/link.
 
Joined
Jul 2, 2018
Messages
31
Motherboard
Asus ROG G771JW
CPU
i7 4720HQ
Graphics
HD 4600
Mobile Phone
iOS
Audio issue then is probably VoodooHDA bug/problem.
See FAQ for details on patched AppleHDA.

See FAQ for iMessage guide/link.
I have check FAQ and done as in there and still nothing ... i also installed El Capitan, used the same clover and kext's and surprise, everything is working, the graphic card has no glitch and the audio is memorize the settings, so problably is an OSX Bug??
Also about the Graphic Card glitch on Mojave, i have connected my tv to the laptop and when i get to the login the image on the TV is perfectly fine and glitchy only on my laptop screen.

Now i wanna patch my DSDT and you said that the one that i have sent first time it had a lot of error's, and i wanna ask you, if you have some time, to help me on what patches and in what order should i use for my DSDT, if i have to keep and patch the SSDT to.

Thank you.
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,259
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
the graphic card has no glitch and the audio is memorize the settings, so problably is an OSX Bug??
If you have expectations that nothing needs to change in hack kexts/configuration/clover/etc when a new macOS is introduced by Apple, you haven't been around much...
Typically lots of things need changing with each major release. We should not be surprised.
And these problems are not macOS bugs at all, unless they affect real Apple hardware.

Also about the Graphic Card glitch on Mojave, i have connected my tv to the laptop and when i get to the login the image on the TV is perfectly fine and glitchy only on my laptop screen.
What do yo mean by "glitchy"?

Now i wanna patch my DSDT and you said that the one that i have sent first time it had a lot of error's, and i wanna ask you, if you have some time, to help me on what patches and in what order should i use for my DSDT, if i have to keep and patch the SSDT to.
See ACPI patching guide:
https://www.tonymacx86.com/threads/guide-patching-laptop-dsdt-ssdts.152573/
 
Joined
Jul 2, 2018
Messages
31
Motherboard
Asus ROG G771JW
CPU
i7 4720HQ
Graphics
HD 4600
Mobile Phone
iOS
What do yo mean by "glitchy"?
this is how is the image showed after booting on my laptop and on my TV. Even if i connect the TV or not, on my laptop is the same. to fix this i keep pressed for 2 seconds the power button, the screen goes off, i hit enter and the screen is back again and showing image normaly just like on the TV

image1.jpeg


and this is on my TV

image2.jpeg
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,259
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Top