Contribute
Register

Mojave on ASRock Z390 Phantom Gaming-ITX/ac

Status
Not open for further replies.
Joined
Dec 4, 2018
Messages
2
Motherboard
ASROCK Z390 PHANTOM GAMING ITX/AC
CPU
8700k
Graphics
GTX 1070ti
Hi!
How did you get the audio working? Seems no revision layout 1, 2, 5, 7, 11, 13 works
 

toleda

Moderator
Joined
May 20, 2010
Messages
24,092
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
Joined
May 13, 2014
Messages
168
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
Radeon VII
Joined
Dec 18, 2014
Messages
4
Motherboard
ASRock Z390 Taichi
CPU
i7-9700K
Graphics
Vega 64
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. 128K
  2. 512K
  3. Plus
  4. Power Mac
  5. PowerBook
  6. Quadra
  7. SE
Mobile Phone
  1. iOS
Hi everyone

I have a ASRock Z390 Taichi that I'm trying to get the final kinks ironed out.

Top on my list is getting Bluetooth to work. (I'm hardwired so don't care about Wi-Fi.) I've tried a Bluetooth dongle (IOGear GBU521) & a BRCM94360 (also reports as 20702) on a PCI-e card. The Intel Bluetooth didn't want to work. It can see my trackpad, but then errors out.

How did you, @telenkov88, get the Intel Bluetooth to work? That would solve my problem.

I added @pupin's patch, but that didn't work. I'm on BIOS 1.3.

I haven't gone the route of building out a DSDT.aml file.

I'm looking for hints or suggestions to try. Anything would be greatly appreciated. My machine is almost there. Bluetooth is the main thing. Then it'll be to control the Vega 64 fans. Sleep works super well.
 
Joined
Oct 9, 2017
Messages
38
Motherboard
ASUS RAMPAGE V EXTREME
CPU
i7-5820K
Graphics
GTX 1060
For all guys with problems on the new Asrock BIOSes (for this board, and for other Asrock boards), add in Clover's config.plist,
under ACPI\DSDT\Patches the following patch (I already posted my patch in the General Z390 thread):
Code:
        <dict>
          <key>Comment</key>
          <string>Fix AsRock Z390 BIOS DSDT Device(RTC) bug</string>
          <key>Disabled</key>
          <false/>
          <key>Find</key>
          <data>
          oAqTU1RBUwE=
          </data>
          <key>Replace</key>
          <data>
          oAqRCv8L//8=
          </data>
        </dict>


The problem his an uninitialized variable in Device(RTC) that makes OSX DSDT parser freak out.
I am quite sure AsRock will eventually fix this, but for now, it is a usable solution.

Hi Pupin, may I please ask what the entry would be like in Clover Configurator please?

To save you all the trouble, here it is:

Comment: Fix AsRock Z390 BIOS DSDT Device(RTC) bug
Find: A00A9353 54415301
Replace: A00A910A FF0BFFFF
 
Last edited:
Joined
Oct 28, 2012
Messages
43
Motherboard
ASRock > Need model # > See Rules!
CPU
i5 > Need model # > See Rules!
Graphics
Intel version # > See Rules!
Hi Pupin, may I please ask what the entry would be like in Clover Configurator please?

To save you all the trouble, here it is:

Comment: Fix AsRock Z390 BIOS DSDT Device(RTC) bug
Find: A00A9353 54415301
Replace: A00A910A FF0BFFFF
I have no idea, I am not using Clover Configurator.

On a different note, v1.50 BIOS is released, and the problem still exists (the same fix still works).
 
Joined
Feb 26, 2014
Messages
108
Motherboard
Asrock Z390 Phantom Gaming ITX
CPU
i9-9900K
Graphics
RX 580
@pupin @Benlehot
What Clover drivers64UEFI are you guys using? From what I understand I need EmuVariableUefi-64 and slide=0? Is that not the case with your patch?
 
Joined
Dec 31, 2013
Messages
730
Motherboard
Huawei Matebook D
CPU
i5-8250U
Graphics
UHD 620
Mobile Phone
  1. iOS
I use AptioMemoryFix-64.efi AND EmuVariableUefi-64.efi
Sleep runs perfectly from what I see. Tested multiple times in a row.

I'm on BIOS 1.5.

Audio is Fine

iGPU acceleration is fine

I have the USB unplug on sleep issue.
Does anyone know how to solve this?
Jettison ejects the USB drives but fails to mount them upon wake.

I cannot make USB Type C work.
But I can see in IOReg the thunderbolt listed

Anyone knows how to fix the USB eject issue?

Thanks a lot!!
 
Joined
Feb 26, 2014
Messages
108
Motherboard
Asrock Z390 Phantom Gaming ITX
CPU
i9-9900K
Graphics
RX 580
@pupin what does your patch accomplish exactly? Does it enable native NVRAM or will I still need EMUVariable-64?
 
Status
Not open for further replies.
Top