Contribute
Register

Solved > Mojave Installer Would Not Show Up, Stuck at "IOReturn IONVMeController::CreateSubmissionQueue"

Joined
Jul 18, 2019
Messages
3
Motherboard
ASRock Z390 Extreme 4
CPU
i7-8700
Graphics
UHD 630
Mac
MacBook Air
Mobile Phone
iOS
Goal

To install macOS Mojave 10.14.6 with Samsung M.2 SSD 970 EVO Plus.


Issue

I have followed UniBeast installation guide, but the installer would not show up.

The images of log with verbose mode are attached as "log-1_1.jpg" and "log-1_2.jpg".

log-1_1.jpeg log-1_2.jpeg

I found "AppleNVMe Assert failed" and "IOReturn IONVMeController::CreateSubmissionQueue" messages in the log, so
I tried removing M.2 NVMe SSD and rebooting.
However, the installer still didn't show up.
Here is the log of this trial.

The log of this trial are attached as "log-2_1.jpg" and "log-2_2.jpg".

log-2_1.jpeg log-2_2.jpeg

Related issues


Configuration

PC

Motherboard ASRock Z390 Extreme 4
CPU Intel i7-8700
GPU Intel UHD Graphics 630 (CPU integrated)
RAM CFD Crucial DDR4-2666 16GB x2
SSD Samsung M.2 SSD 970 EVO Plus
HDD Western Digital 4TB HDD WD40EZRZ-RT2 (SATA)
Combo Drive ASUS BC-12D2HT (SATA)
PSU RAIDMAX Cobra Power RX-800AE-M


Note that 970 EVO Plus needs firmware update, so I updated it.

BIOS

Ver. 2.30

I made the following changes from default setting:

Advanced\Chipset Configuration
VT-d: Enabled -> Disabled
Share Memory: Auto -> 64MB (https://www.tonymacx86.com/threads/solved-how-to-enable-uhd-630-on-mojave.264327/)

Advanced\Super IO Configuration
Serial Port: Enabled -> Disabled

Advanced\USB Configuration
XHCI Hand-off: Disabled -> Enabled


UniBeast/Clover

UniBeast 9.20
Clover EFI installer v2.4k r4920

I didn't make any modification on config.plist.


Host Mac

MacBook Air Mid 2012
 

Attachments

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
22,760
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS
with Samsung M.2 SSD 970 EVO Plus
Did you update the firmware ?

 
Joined
Jul 18, 2019
Messages
3
Motherboard
ASRock Z390 Extreme 4
CPU
i7-8700
Graphics
UHD 630
Mac
MacBook Air
Mobile Phone
iOS
Did you update the firmware ?

Thanks for the reply.
Yes, I updated it.

I downloaded "NVMe SSD-970 EVO Plus Firmware" from here and burned it to USB using Rufus on Windows 10.
Then I booted the USB from the machine I wanted install macOS, and I saw the log showing successfully updated the firmware.
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
22,760
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS
Looks remarkably similar to this :

If you use UEFI version 2203 or later the system will hang during the boot of macOS at apfs_module_start:1393. @mattystonnie has created a patch that fixes this.
 
Joined
Jul 18, 2019
Messages
3
Motherboard
ASRock Z390 Extreme 4
CPU
i7-8700
Graphics
UHD 630
Mac
MacBook Air
Mobile Phone
iOS
Looks remarkably similar to this :
Wow, that is exactly what I have looked for, totally overlooked.
Following the mentioned guide, I successfully have completed installation of Mojave on NVMe SSD.

Thanks a lot!
 
Top