Contribute
Register

Mojave install to HDD issue.

Joined
Apr 23, 2019
Messages
76
Motherboard
Asus ROG STRIX B360-I gaming
CPU
I7-8700 3.2 GHz 6-core
Graphics
XFX - AMD Radeon RX 560 4gb
Mobile Phone
iOS
okay, So after going through many threads.
First thing First, thank you Cmn699 for all your help, YOU DA BEST!
Check out Previous thread conversation below between Cmn699 and me to see where we started hopefully issues that are displayed in the tread can help you with your build.
This is my First Build so bear with me, please.
----------------------------------------------------
Previous thread conversation: https://www.tonymacx86.com/threads/black-screen-after-boot-on-mojave.272803/
---------------------------------------------------
I finally got Mojave to boot on my pc.
During installing Mojave on the hard drive, the screen froze at 2 mins remaining. so I forced rebooted the computer, now the apple logo with loading bar is displayed on the screen but it freezes or nest close to the end.
Bios has been updated and set to the correct setting, Motherboard and other hardware issue has been solved.
First Boot: went thought the boost fast and once I was at the 2min remaining it froze.
Second Boot: went to the apple loading bar screen got to the end of the load ( took about three hours) then froze.
Current Boot: installing maOS onto HDD.

reference the previous thread for all other details.

Bios Setting

Steps posted By ModMike that helped me get MacOs to boot without any issue the first time. Thank you ModMike!
I used his bios setting because we both are using an ASUS Motherboard, And it worked.
  1. In the main screen middle left, set X.M.P. to Enabled
  2. Advanced Items > CPU Configuration > Intel (VMX) Virtualization Technology > Enable - Absolutely required for Parallels
  3. Advanced Items > System Agent (SA) Graphics Configuration > Primary Display > PEG (leave on auto if you don’t have a separate graphics card)
  4. Advanced Items > System Agent (SA) Graphics Configuration > IGPU Multi-Monitor > Enabled for DGPU, Disabled for IGPU
  5. Save and reboot to activate the RC6 and DVMT settings
  6. Advanced Items > System Agent (SA) Graphics Configuration > RC6(Render Standby) > Off - This setting disables a power saving feature that could potentially crash the system
  7. Advanced Items > System Agent (SA) Configuration > Above 4G Decoding > Enable
  8. Advanced Items > System Agent (SA) Graphics Configuration > DVMT Pre-Allocated > 128
  9. Advanced Items > USB Configuration > Legacy USB Support > Disabled
  10. Advanced Items > USB Configuration > XHCI Hand Off > Enabled
  11. Boot Menu > Boot Option 1 > UEFI USB installer drive (or whatever you named it, UEFI will be automatically prepended)
  12. Exit > Save Changes
  13. Boot > Boot Configuration > Boot Logo Display > Disabled
  14. Boot > Boot Configuration > Post Report > 1 Sec
  15. Boot > Setup Mode > Advanced
These are the setting that finally made MacOS boot finally.

Boot Setting for USB Drive
Verbose
boot with the selected option

Boot setting for HDD
I selected Install MacoS Mojave to HDD ( which is what it is currently doing now)

The image below is where I am stuck at now, its been at the screen for about two hours now.
IMG_0642 2.JPG

Motherboard: Asus Rog Strix B360-I Gaming Mini Itx
CPU
: Intel core I7-8700 6 core
GPU: AMD XFX Radeon Rx 560
Ram: (2) Vengeance DDR4 16gb
HDD: WD 1T
SSD: None
Power Supply: Evga 750W
 
Last edited:

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
20,286
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS
This is my First Build so bare with me, please
Nobody here will be getting naked with you.

The image below is where I am stuck at now, its been at the screen for about two hours now
You have to boot in verbose mode in order to capture any information that may be useful for problem diagnosis.

Graphics cards manufactured by XFX are often problematical, use the forum Search tool to see if anyone has reported problems with your XFX Radeon Rx 560 (and for possible solutions).
 
Joined
Apr 23, 2019
Messages
76
Motherboard
Asus ROG STRIX B360-I gaming
CPU
I7-8700 3.2 GHz 6-core
Graphics
XFX - AMD Radeon RX 560 4gb
Mobile Phone
iOS
Nobody here will be getting naked with you.


You have to boot in verbose mode in order to capture any information that may be useful for problem diagnosis.

Graphics cards manufactured by XFX are often problematical, use the forum Search tool to see if anyone has reported problems with your XFX Radeon Rx 560 (and for possible solutions).
that's not what "bear with me" meaning thank you.
the graphics card is compatible, we have already gotten that issue fixed.
currently trying to get macOs to install on the hard drive.
it has paused here.
IMG_0643.JPG
 
Joined
Jul 25, 2012
Messages
6,468
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
HD 4000+GT 710
Mac
iMac, MacBook Pro
Mobile Phone
iOS
that's not what "bear with me" meaning thank you.
the graphics card is compatible, we have already gotten that issue fixed.
currently trying to get macOs to install on the hard drive.
it has paused here.
View attachment 408138
I selected Install MacoS Mojave to HDD
  • If this is the macOSMojave UEFI USB installer disk and the uploaded Verbose boot screen is while booting the macOSMojave UEFI USB installer from Clover Boot Manager (CBM) screen, then:
    • I see NO obvious Fatal errors on the Verbose boot screen
  • Watch USB's LED light and HDD LED light flashing to show file transfers to create a RAM disk during boot to the Disk Utility Screen.
  • Any mention of 'error" in the screen is all expected and the Clover will usually find ways to fix them and proceed toward the Installation screen.
  • Watchful expectancy and doing nothing but taking Photos to learn about normal booting that may appear to show errors is all that I would recommend at this time.
  • If it freezes it is often related to Graphics card from this stage on.
  • If it freezes, there will be no flashing of LED lights and no additional verbose output for a long time like 30 minutes or so.
 

Attachments

Joined
Apr 23, 2019
Messages
76
Motherboard
Asus ROG STRIX B360-I gaming
CPU
I7-8700 3.2 GHz 6-core
Graphics
XFX - AMD Radeon RX 560 4gb
Mobile Phone
iOS
  • If this is the macOSMojave UEFI USB installer disk and the uploaded Verbose boot screen is while booting the macOSMojave UEFI USB installer from Clover Boot Manager (CBM) screen, then:
    • I see NO obvious Fatal errors on the Verbose boot screen
  • Watch USB's LED light and HDD LED light flashing to show file transfers to create a RAM disk during boot to the Disk Utility Screen.
  • Any mention of 'error" in the screen is all expected and the Clover will usually find ways to fix them and proceed toward the Installation screen.
  • Watchful expectancy and doing nothing but taking Photos to learn about normal booting that may appear to show errors is all that I would recommend at this time.
  • If it freezes it is often related to Graphics card from this stage on.
  • If it freezes, there will be no flashing of LED lights and no additional verbose output for a long time like 30 minutes or so.
it's at the 2 min remaining now. My flash drive doesn't have blinking lights nor does my HDD.
using the CPU Graphics. btw
it appears it is frozen here, can't move the mouse but it just might be transferring. is that correct?
 
Joined
Apr 23, 2019
Messages
76
Motherboard
Asus ROG STRIX B360-I gaming
CPU
I7-8700 3.2 GHz 6-core
Graphics
XFX - AMD Radeon RX 560 4gb
Mobile Phone
iOS
okay, I fix that 2min remaining issue.
I also found the flashing light you were referencing.
but it still gets stuck at installing on HDD.
now it 17 min remaining, light is on but not flashing and the load bar is somewhat complete. IMG_0647.JPG

now I'm stuck at 2min again. no flashing light. ( 11:03 am)
 
Last edited:
Joined
Jul 25, 2012
Messages
6,468
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
HD 4000+GT 710
Mac
iMac, MacBook Pro
Mobile Phone
iOS
okay, I fix that 2min remaining issue.
I also found the flashing light you were referencing.
but it still gets stuck at installing on HDD.
now it 17 min remaining, light is on but not flashing and the load bar is somewhat complete. View attachment 408243

now I'm stuck at 2min again. no flashing light. ( 11:03 am)
okay, I fix that 2min remaining issue.
  • How or what did you do to solve that?
I also found the flashing light you were referencing.
but it still gets stuck at installing on HDD.
now it 17 min remaining, light is on but not flashing and the load bar is somewhat complete.
  • Waiting is your only option as long as the screen is lit up and LED is lit and preferably flashing at least every now and then like a small flicker from a candle wick.
  • If the LED light is blinking brighter and at a faster rate, it is more encouraging.
    • I'm sorry I cannot give you any more tips.
    • If you think you have optimized your installation environment (Hardware connected, BIOS setup, Clover and its config.plist) for the Installation , there is nothing more you can do but give the time for installation to complete.
 
Joined
Apr 23, 2019
Messages
76
Motherboard
Asus ROG STRIX B360-I gaming
CPU
I7-8700 3.2 GHz 6-core
Graphics
XFX - AMD Radeon RX 560 4gb
Mobile Phone
iOS
you have helped a lot! YOU DA BEST!
in the clover boot loader, I clicked preboot and that seems to fixed the 2 min thing. when I reboot from the previous boot.
okay so now we play the waiting game.
thanks!
 
Joined
Apr 23, 2019
Messages
76
Motherboard
Asus ROG STRIX B360-I gaming
CPU
I7-8700 3.2 GHz 6-core
Graphics
XFX - AMD Radeon RX 560 4gb
Mobile Phone
iOS
it has been two hours and it still on the "less than a min remaining"
is this normal or am I being impatient
 
Joined
Jul 25, 2012
Messages
6,468
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
HD 4000+GT 710
Mac
iMac, MacBook Pro
Mobile Phone
iOS
it has been two hours and it still on the "less than a min remaining"
is this normal or am I being impatient
That is NOT normal.
Force reboot and from CBM screen boot on your macOSMojave System disk icon.
It may be the last but one icon from the Left.
If in doubt, upload the CBM icons view shot after editing it with label of each icon.
 
Top