Contribute
Register

Solved > Mojave install on MSI Z390, i7-8700K, Vega64, NvmE

Joined
Oct 2, 2018
Messages
13
Motherboard
MSI MPG Z390 Pro Carbon-Clover
CPU
i7-8700K
Graphics
Vega 64
Classic Mac
iMac
Hi!

I'm currently trying to reinstall Mojave 10.14.0 on my machine, after changing the graphics card and messing around too much with clover. I went into some trouble on the way, and now I'm definatly stuck.

Current situation:
  • trying to install on MSI MPG Z390 Pro Carbon (newest 1.14 BIOS, the problems however were the same with the 1.0 BIOS), Powercolor Vega 64, ADATA NvmE SSD, no WiFi, CM8888 PCIe soundcard (internal card disabled), LSI 2008 SAS RAID controller (not regognized by macOS)
  • Just for the sake of detail: I managed to install Mojave flawlessly (meaning: installed and booted without any hiccups along the way) on my previous build (with a GTX 1080 instead of the Vega) with just the default UniBeast clover config.plist. However, this doesn't work anymore with the Vega 64 for some reason.
  • With the default UniBeast config.plist, now I make it so far:
    • added IntelMausiEthernet, Lilu, WhateverGreen, AppleALC, USBInjectAll kexts to /CLOVER/kexts/Other (FakeSMC was already there)
    • added AptioMemoryFix-64, NvmExpressDxe-64, OsxAptioFix3Drv-64 to /CLOVER/drivers64UEFI
    • started the installer on the USB drive and installed the basic Mojave files to the NVMe drive
    • when starting the installer from NVME, in verbose mode the screen stops at the line: "apfs_module_start:1334: load: com.apple.filesystems.apfs, v945.200.129, 2018/08/30"
So I think, I need to modify the config.plist. However, I don't know where to start. More confusing, while the SMBIOS section of the config.plist is empty, in the Clover boot screen, i am confronted with a full SMBIOS iMac 14,2 configuration with everything completely filled out.

I have attached pictures of my current BIOS configuration, as well as the compete EFI folder. I did also attach the config.plist, although I think that this is the defualt from tonymacx, as I pulled it out of the current Clover.pkg.

I really appreciate your help!

Markus
 

Attachments

Last edited:

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
20,007
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
Intel HD Graphics 4600
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS
I managed to install Mojave flawlessly on my previous build (with a GTX 1080 instead of the Vega)
Doubtful that you had a "flawless" installation with a GTX 1080 and Mojave as there are currently no Pascal drivers for Mojave.
 
Joined
Oct 2, 2018
Messages
13
Motherboard
MSI MPG Z390 Pro Carbon-Clover
CPU
i7-8700K
Graphics
Vega 64
Classic Mac
iMac
Doubtful that you had a "flawless" installation with a GTX 1080 and Mojave as there are currently no Pascal drivers for Mojave.
I meant that macOS installed and booted without any hiccups on the way like it is now... And guess why I replaced the GPU. ;)
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
20,007
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
Intel HD Graphics 4600
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS
/EFI/CLOVER/drivers64UEFI is wrong :

392899


AptioMemoryFix-64.efi and OsxAptioFix3Drv-64.efi do the same job and are mutually exclusive - Use one or the other but not both. AptioMemoryFix-64.efi is usually the better choice but I have seen many users with a Z390 board resorting to OsxAptioFix2Drv-free2000.efi instead - See nickwoodhams.com.

May require XHCI-unsupported.kext in /EFI/CLOVER/kexts/Other/. (Click Download repository).

Your config.plist is minimalistic.
 
Joined
Oct 2, 2018
Messages
13
Motherboard
MSI MPG Z390 Pro Carbon-Clover
CPU
i7-8700K
Graphics
Vega 64
Classic Mac
iMac
Thanks for your advice so far. However, the situation is mostly unchanged. With either AptioMemoryFix-64.efi or OsxAptioFix3Drv-64.efi, the system stops at the same line as before:

apfs_module_start:1334: load: com.apple.filesystems.apfs, v945.200.129, 2018/08/30

392903



With OsxAptioFix2Drv-free2000.efi, however, the system startup advances a little bit more, but stops at the following line:

Using 16384 buffer headers and 10240 cluster IO buffer loaders.

392905





Your link to XHCI-unsupported.kext leads to USBInjectAll.kext which I have already in /EFI/CLOVER/kexts/Other/.




I'm still asking myself where Clover takes the SMBIOS input from. As you've said, my config.plist is very minimalistic.

392906
 
Joined
Oct 2, 2018
Messages
13
Motherboard
MSI MPG Z390 Pro Carbon-Clover
CPU
i7-8700K
Graphics
Vega 64
Classic Mac
iMac
Read carefully :
Oh man, this is embarassing. :banghead: Sorry for that. Added XHCI-unsupported.kext. Now, with AptioMemoryFix-64.efi and OsxAptioFix3Drv-64.efi, I sometimes get the infamous "Could not allocate 0x#### pages" and sometimes also the "Error loading kernel cache (0x09)" error.

With OsxAptioFix2Drv-free2000.efi, this doesn't happen, however, the boot process still stucks at "Using 16384 buffer headers and 10240 cluster IO buffer loaders."

By the way, I recognized that my CsrActiveConfig was wrong, changed it to 0x67. However, still the same situation.

Also, a question of interest: SMCHelper-64.efi appears in /CLOVER/drivers64 as well as in /CLOVER/drivers64UEFI. Is this intended?
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
20,007
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
Intel HD Graphics 4600
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS
SMCHelper-64.efi appears in /CLOVER/drivers64 as well as in /CLOVER/drivers64UEFI. Is this intended?
Yes but neither are of interest to you.
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
20,007
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
Intel HD Graphics 4600
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS
Your FakeSMC.kext looks wrong with a 2009 copyright notice on it - Try updating it.

392912
 
Joined
Oct 2, 2018
Messages
13
Motherboard
MSI MPG Z390 Pro Carbon-Clover
CPU
i7-8700K
Graphics
Vega 64
Classic Mac
iMac
Your FakeSMC.kext looks wrong with a 2009 copyright notice on it
Did replace it with the latest from RehabMan's repository (RehabMan-FakeSMC-2018-0915). Did only copy FakeSMC.kext, not any of the other kexts.

Result: same (except that the copyright is now 2017 ;) ).

392919
 
Top