Contribute
Register

Mojave instalation keeps getting stuck on [PCI configuration end]

Status
Not open for further replies.
Joined
Sep 24, 2019
Messages
1
Motherboard
ASUS Z390M-PRO
CPU
i7 9700k
Graphics
UHD 630
Hey,

For the past 3 days, I've been trying to setup my hackintosh without any success. I've followed many guides on how to do it, including the tonymacx86 one. I also configured my BIOS as told on the tonymacx86 guide.

I always try to install in verbose mode, and it seems to always be getting stuck on the [PCI configuration end] message. Sometimes it gives me the no nvram variable but I seem to fix it by removing some drivers/kexts.

During the many attempts of the installation I've tried to remove one stick of RAM, placing an NVIDIA GeForce 1050 graphics card and removing the SSD, but nothing worked.
I've also tried a different approach that I saw on a thread on tonymacx86 that said to mount the OS image on the USB drive using command line and a variation of clover as posted here:
I've tried using an older version of "vanilla" Clover but without any success.

I would really like to hear anyones opinion on it as I need the hackintosh ready to work.

Here's my hackintosh specs:
Processor: Intel i7 - 9700k ~ 3.6GHz
Motherboard: ASUS TUF Z390M-PRO GAMING
SSD: Samsung 860 EVO NVMe M.2 1TB
RAM: 2x HyperX Predator DDR4 16GB 3000MHz
Graphics: Intel UHD 630
 

Attachments

  • Screen Shot 2019-09-25 at 8.55.45 AM.png
    Screen Shot 2019-09-25 at 8.55.45 AM.png
    351.7 KB · Views: 85
  • erro.jpg
    erro.jpg
    1.6 MB · Views: 90
  • EFI.zip
    4.1 MB · Views: 29
  • bios1.jpg
    bios1.jpg
    1.4 MB · Views: 83
  • bios2.jpg
    bios2.jpg
    1.3 MB · Views: 48
  • bios3.jpg
    bios3.jpg
    1.4 MB · Views: 54
Last edited:
Joined
Oct 28, 2014
Messages
11
Motherboard
ASUS Z390M-PRO
CPU
i7 9700k
Graphics
UHD 630
Does anyone know where can I find the IOPCIFamily patch?

This thread describes a similar problem:

IOPCIFamily patch from PMHeart

Now. I don't know where to get that from or who PMHeart is.

- - -

From https://www.tonymacx86.com/threads/...ojave-successful-build-extended-guide.255117/:
1569482976207.png




From https://kgp-hackintosh-corner.com/h...-a-config-plist-for-booting-your-macos-system:
1569483010610.png


Could it be that our i7 9700k needs this patch?
 

Attachments

  • 1569482584911.png
    1569482584911.png
    298.4 KB · Views: 85
Status
Not open for further replies.
Top