Contribute
Register

Mojave AppleHDA Audio

Joined
Aug 14, 2016
Messages
16
Motherboard
Gigabyte B360N WIFI ITX
CPU
i5-8400
Graphics
UHD 630
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
iMac, Power Mac, PowerBook, Quadra
Mobile Phone
iOS
I've a Gigabyte B360N WIFI (Realtek ALC887 codec) and audio works almost perfectly in Mojave 10.14.5 using AppleHDA.kext and Layout Id=1.
There is however a little issue with the max volume that come from the green audio port of the back panel: using my headset (Sennheiser Momentum On-Ear), I've noticed that under MacOs the max volume level is lower that level under Win10.
I've read in other threads that some Gigabyte mobo's use different default level for back and front audio output.
Does someone know a way to configure (increase) the output gain of the back green port into my setup?
 

toleda

Moderator
Joined
May 20, 2010
Messages
24,350
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
512K, LC, Power Mac
Mobile Phone
iOS
I've read in other threads that some Gigabyte mobo's use different default level for back and front audio output.
No external amplifiers on B360N WIFI
Does someone know a way to configure (increase) the output gain of the back green port into my setup?
No hardware support in macOS or Windows
I've noticed that under MacOs the max volume level is lower that level under Win10.
Why is this a problem?
Start a new thread in the Audio Forum
 
Joined
Aug 14, 2016
Messages
16
Motherboard
Gigabyte B360N WIFI ITX
CPU
i5-8400
Graphics
UHD 630
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
iMac, Power Mac, PowerBook, Quadra
Mobile Phone
iOS
Why is this a problem?
It's not big problem, in fact it is a very little issue.
I've tried solutions like Boom 2 and Boom 3D that can boost the output level but starting from a 10-15% boost level the audio become very distorted.
I've suspected a sort of different default setup from AppleALC.kext because the hardware is the SAME and with MacOs the max volume is too low to enjoy music with my headset (please note that I've made some test with the same files and on Win10 the sound is much louder, please also note the my headset above not exhibit this behaviour with my iPhone, iPod, iPad).
 

toleda

Moderator
Joined
May 20, 2010
Messages
24,350
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
512K, LC, Power Mac
Mobile Phone
iOS
I've suspected a sort of different default setup from AppleALC.kext because the hardware is the SAME
AppleHDA.kext does not natively support the ALC887; that is the difference
AppleALC configures AppleHDA for ALC887 support, no parameter for max volume
MacOs the max volume is too low to enjoy music with my headset
What macOS audio app are you using to play music?
 
Joined
Jun 8, 2019
Messages
3
Motherboard
huawei matebook d mrc-w10b
CPU
i5 8250U
Graphics
UHD 620
Mobile Phone
Android
Hello, i have make my first hackintosh whit a huawei matebook d mrc-w10b. The only problem that i can't fix is the sound. I have read some topics and try to use multibeast to install the sound drivers but whit no sucess. Can someone help me please? it literaly the only thing that's missing for a perfect hackintosh. Thank you
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
20,309
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS
Hello, i have make my first hackintosh whit a huawei matebook d mrc-w10b.
This is a Desktop Support thread - Post in Laptop Support.
 
Joined
Mar 5, 2016
Messages
48
Motherboard
Z77M-D3H-MVP
CPU
Xeon 1230 v2
Graphics
GTX 760
Mac
MacBook Pro, Mac Pro
Mobile Phone
Android, iOS
hi guys. when I update my Mojave installation, I lose the sound on my z77m-d3h mobo. every time install the sound drives for VIA VT2021 every time give me kernel panic. some one can help me.

thanks
 

toleda

Moderator
Joined
May 20, 2010
Messages
24,350
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
512K, LC, Power Mac
Mobile Phone
iOS
I lose the sound on my z77m-d3h mobo. every time install the sound drives for VIA VT2021 every time give me kernel panic.
What "sound drivers" did you install?
See Post #1/Problems/2. All other codecs and layouts
Off topic
 

toleda

Moderator
Joined
May 20, 2010
Messages
24,350
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
512K, LC, Power Mac
Mobile Phone
iOS
im install VoodooHDA 2.89. then i have Lilu, Watevergreen, APPLALC. and every time do clear installation i get Kernel Panic
VoodooHDA.kext with AppleHDA.kext, KP every time
AppleALC with AppleHDA only
Voodoo is off topic
VIA VT2021 is off topic
Post #210 removed
 
Last edited:
Top