Contribute
Register

Mojave AppleHDA Audio

Joined
Jan 27, 2014
Messages
180
Motherboard
MSI z87 mpower max
CPU
Intel I7 4770k
Graphics
Gainward Nvidia 760 2GB Phantom
Mac
Classic Mac
Mobile Phone
iOS
Thanks a lot for the responses, I will try when i get back home. Toleda, i did read B. Acidanthera/AppleALC but it was not fully clear to me, hence me verifying if the steps are a correct understanding of this post
 
Joined
Jul 26, 2012
Messages
180
Motherboard
Asus Maximus Formula IX
CPU
i7-7700K
Graphics
HD 630 / RX560
For users updating to Mojave, the Audio ID will be the same as it was for High Sierra. No research required, no config.plist edit required for Mojave audio.
Even if going from old method (CloverALC) to new (Lilu / AppleALC)? Good to know, I thought in some cases it may be different and though it best to be cautious. :thumbup:
 
Joined
Jul 18, 2018
Messages
70
Motherboard
Gigabyte Z370M DS3H
CPU
i7-8700K
Graphics
RX580
Mac
iMac
Mobile Phone
iOS
I have upgraded to the release of Mojave. Glad to see the computer sleeps now and audio is still working fine.
 

toleda

Moderator
Joined
May 20, 2010
Messages
24,297
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
512K, LC, Power Mac
Mobile Phone
iOS
Even if going from old method (CloverALC) to new (Lilu / AppleALC)
The codec files are exactly the same for both methods
Ithought in some cases it may be different
Developer created a new property, alc-layout-id, and new code to ensure the user experience was the same pre Mojave as with Mojave
 
Last edited:
Joined
Mar 16, 2014
Messages
5
Motherboard
Z87X-UD7-TH
CPU
i7-4770K
Graphics
Integrated
Mac
Classic Mac
Mobile Phone
Can I enable SPDIF-IN with AppleALC for the Realtek 898 codec?
 
Joined
Dec 10, 2010
Messages
33
Motherboard
Intel NUC6i3syh
Graphics
hd 520
Mobile Phone
Android
moved to mojave on my nuc6 i3syh with no probs except losin' audio. tried different ways but at last just saved the original applehda kext and installed my high sierra 10.13.6's one instead.works like a charm.
 
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,927
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS

toleda

Moderator
Joined
May 20, 2010
Messages
24,297
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
512K, LC, Power Mac
Mobile Phone
iOS
Joined
Feb 28, 2011
Messages
47
Mobile Phone
iOS
Evening, folks.

I have upgraded to Mojave on my i5 6500/Asus Z170P-D3 desktop. However, I'm not able to get audio to work, except with VoodooHDA. Voodoo only gives me stereo on my ALC887. I have a 5.1 speaker set.

I have tried installing AppleALC with Lilu. I already use Lilu for my Intel 530HD graphics (until nVidia updates their drivers for my GTX 750). If I try using -alcbeta -lilubeta with Layout ID of 5, I get a kernel panic in AppleALC. It doesn't seem to matter which Layout ID I try using.

And yes, I uninstalled VoodooHD.kext prior to installing AppleALC.
 
Top