Contribute
Register

Mojave AppleHDA Audio

Joined
Dec 31, 2013
Messages
39
Motherboard
GA-H61M-S2V-B3
CPU
Pentium G620 @ 2.60GHz
Graphics
GeForce GTX 650 Ti
The audio ALC889 works well on a new install Mojave( AppleALC and Lilu installed), but after migrate data from High Sierra via Migration assistant, there are only two selection(soundflower 64ch& 2ch) in the output device list, and there is no sound.

I also tried to install AppleHDA, not work too.

Did High Sierra setting replace something there?
 
Last edited:
Joined
Jun 13, 2015
Messages
10
Motherboard
GA-H81M-S2H
CPU
i7-4790
Graphics
HD4600 + GTX 970
Mac
Mac mini
Mobile Phone
Android, iOS
Untitled.jpg

Got audio working again on 10.14.1 for Realtek ALC887 audio codec...but only after MUCH trial and error :mrgreen:
Following Toleda's guidance, ensured:
1. AppleALC.kext and Lilu.kext installed in Lib/Ext, Sys/Lib/Ext AND EFI/Clover/kexts/Other
2. Used Clover Configurator to inject '7' in Audio devices (worked for me)
3. Also downloaded and installed Voodoo. Didn't think necessary but this install only seems to give Sound Menu with VoodooHDA.kext! :O (once sound working, I deleted Voodoo pref.pane and kext, but then didn't get options. Reinstalled and back to normal. So go figure...)
4. Happy to have sound back! :mrgreen:.
5. Now all I need is Nvidia driver. The lag/glitches is driving me nuts!!!. I'll happily buy the latest Radeon card if no alternative, but love my Nvidia card and would prefer to stay with it.
6. All is sweet in Windows 10...
 

toleda

Moderator
Joined
May 20, 2010
Messages
24,459
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
512K, LC, Power Mac
Mobile Phone
iOS
Got audio working again on 10.14.1 for Realtek ALC887 audio codec...but only after MUCH trial and error
Big Fail, no AppleHDA audio.
Installed Voodoo audio, off topic.
Post will be removed.
 
Joined
May 3, 2011
Messages
1
Motherboard
Giga H170 Gamming 3
CPU
i5 6500
Graphics
RX 570
Hi!
How to disable audio on displayport? It's useless for me!:)
Audio is disconnected when i tune the 2nd monitor on. I have to set audio in System Preferences again.
Sorry about my English!
My PC:
- OS: macOS Mojave 10.14.1
- Mobo: Giga h170
- Graphics: AMD RX 570
- CPU: i5 6500
- Audio: ALC 1150, layout 7, Lilu kext v1.2.7 + AppleALC kext v1.3.2
- Monitor: Dell U2718Q + Dell U2414H (both connect via mini displayport)
Thx in Advance!
 
Joined
Dec 31, 2013
Messages
39
Motherboard
GA-H61M-S2V-B3
CPU
Pentium G620 @ 2.60GHz
Graphics
GeForce GTX 650 Ti
High Sierra audio is not compatible with Mojave.
See Post #1, Problems ...
But I had installed AppleALC and Lilu again after migrating data, same process as new Mojave installation which once worked.
 
Joined
Jun 13, 2015
Messages
10
Motherboard
GA-H81M-S2H
CPU
i7-4790
Graphics
HD4600 + GTX 970
Mac
Mac mini
Mobile Phone
Android, iOS
Big Fail, no AppleHDA audio.
Installed Voodoo audio, off topic.
Post will be removed.
Please do. Will try AppleHDA audio route.
 
Top