Contribute
Register

Mojave App Store Not Working

Status
Not open for further replies.
Joined
Jun 16, 2019
Messages
35
Motherboard
Gigabyte Designare
CPU
i9-9900k
Graphics
Vega 56
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
@dropslot Honestly it's worked much better than Mojave (iMessage never worked for me, handoff/continuity are now perfect).

The instructions are super easy in the 'golden build' thread and I just followed them -- much easier then the first build..

The only problem is occasionally I get (on boot) the broken mac -- usually if I power down and leave it alone for 20 minutes it seems to then boot fine (and I don't know why) -- once booted it's been rock solid and (literally) everything is working...

As I said the biggest problems were some old software (I can buy a newer version) and I lost the scansnap support (but exact scan works for $99)

I'd recommend you just upgrade to catalina honestly.....
 
Joined
Feb 17, 2019
Messages
5
Motherboard
Gigagbyte Z390 Designare
CPU
i9-9900K
Graphics
Vega 64
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. Android
I'm also having this exact issue. iMessage and iTunes working fine in Mojave 10.14.6. But the App store just spins. It was working fine recently, so I'm not sure what changed or when exactly it stopped working. Moving up to Catalina is not an option for me. I have hundreds of audio plugins that will never be Catalina compatible, and it's going to be a long time before I rip that bandaid off.
 
Joined
Dec 3, 2019
Messages
28
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900k
Graphics
Sapphire Radeon VII
yup - everything I am seeing is recommending the best solution is to bite the bullet and go Catalina. Gonna pull the trigger.

@KaelYeah It's interesting that you also have the same processor-mobo setup as most of the folks on this post. Any ideas why either of those components might cause this problem?
 
Joined
Feb 17, 2019
Messages
5
Motherboard
Gigagbyte Z390 Designare
CPU
i9-9900K
Graphics
Vega 64
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. Android
Ok so I just spent a day and half looking into this. I'm still very new to hackintosh and I almost completely wrecked my otherwise solid build to fix it, but I can report that I may have found a solution. I updated Clover to the latest version and reinstalled the EmuVariableUefi-64.efi driver. Voila! Updates are working again in Mojave, yay!

Refer to CaseySJ's amazing thread for info on how to make those updates.
 
Joined
Dec 14, 2011
Messages
11
Motherboard
Asus Z590 Prime-A
CPU
i7-11700
Graphics
RX 6900 XT
Mac
  1. Mac Pro
Ok so I just spent a day and half looking into this. I'm still very new to hackintosh and I almost completely wrecked my otherwise solid build to fix it, but I can report that I may have found a solution. I updated Clover to the latest version and reinstalled the EmuVariableUefi-64.efi driver. Voila! Updates are working again in Mojave, yay!

Refer to CaseySJ's amazing thread for info on how to make those updates.
THANKS!! Your solution worked for me like a charm!!!
 
Joined
Dec 3, 2019
Messages
28
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900k
Graphics
Sapphire Radeon VII
WOW! I am going to try this, but I gotta say I haven't heard this yet as a solution, and you may have just solved a 4 month long puzzle for me. Reinstalled the EmuVariableUefi-64.efi manually? Basically just copy and paste right?
 
Joined
Dec 11, 2010
Messages
169
Motherboard
Z170X Gaming 5
CPU
i7 6700k
Graphics
RX580
Mac
  1. iMac
Mobile Phone
  1. iOS
Ok so I just spent a day and half looking into this. I'm still very new to hackintosh and I almost completely wrecked my otherwise solid build to fix it, but I can report that I may have found a solution. I updated Clover to the latest version and reinstalled the EmuVariableUefi-64.efi driver. Voila! Updates are working again in Mojave, yay!

Refer to CaseySJ's amazing thread for info on how to make those updates.
Thanks for this, worked for me as well.
I have no idea why the App Store just suddenly stopped working - just last week I downloaded the 10.5 update to Logic Pro without issue - then yesterday App Store said "Nope".
Anyway, thanks man
 
Joined
Feb 3, 2019
Messages
53
Motherboard
Gigabyte Designare Z390
CPU
i5-9600K
Graphics
RX-580
Mobile Phone
  1. iOS
Thanks for this, worked for me as well.
I have no idea why the App Store just suddenly stopped working - just last week I downloaded the 10.5 update to Logic Pro without issue - then yesterday App Store said "Nope".
Anyway, thanks man

Last night App Store stopped working for me on Mojave. I am tracking these threads in Apple Communities too https://discussions.apple.com/thread/251378763 It had a hiccup the other day, but I just Force Killed the process and it worked again a few days ago. App Store also wasn't working on my real Macbook. Now that is back, but my Hackintosh is stuck. I'll check out that thread you guys posted.

"Use the Clover installer (not Clover Configurator) to install EmuVariableUEFI-64.efi,"

I used Clover_r5118.pkg, which updated Clover, but not sure how to install EmuVariableUEFI-64.efi OK I see now in the post install files zip. Will try this.
 
Last edited:
Joined
Feb 3, 2019
Messages
53
Motherboard
Gigabyte Designare Z390
CPU
i5-9600K
Graphics
RX-580
Mobile Phone
  1. iOS
Its working now. I downgraded Clover to 4xxx and due to the 5xxx not recognizing -64 files that fixed it. All better now that AppStore works ! and I rechecked all the 64 bit drivers in clover. I'm staying on Clover 4934 and not messing with things until Catalina. whew!!!!
 
Joined
Jan 14, 2017
Messages
76
Motherboard
Lenovo Thinkpad E570 (OpenCore 0.7.2 UEFI)
CPU
i5-7200U
Graphics
HD 620
Mac
  1. iMac
Mobile Phone
  1. iOS
Ok so I just spent a day and half looking into this. I'm still very new to hackintosh and I almost completely wrecked my otherwise solid build to fix it, but I can report that I may have found a solution. I updated Clover to the latest version and reinstalled the EmuVariableUefi-64.efi driver. Voila! Updates are working again in Mojave, yay!

Refer to CaseySJ's amazing thread for info on how to make those updates.
boom!

works like a charm! thank you sir :)
 
Status
Not open for further replies.
Top