Contribute
Register

Mojave AMD HDMI Audio (HD 7730)

Joined
Aug 4, 2013
Messages
5
Motherboard
MSI B85M-E45
CPU
i5-4460
Graphics
HD 7730
Hi all,
I'm having problem with HDMI Audio on Mojave. My working config on High Sierra does not work on Mojave.

These are methods I used:
- Lilu (lastest release) + WhateverGreen (lastest release)
- InjectATI + FakeID + Specify FB name => Combo Inject ATI
- Custom SSDT fixes + Connector Patch => Combo Connector Patch
- HDMIAudio.kext

None of these methods works individually in my High Sierra. I must combine them for full working AMD GPU with HDMI Audio. These are details:

- Lilu + WhateverGreen:
=> No QI/CE, "Graphics Display 7MB" (both High Sierra & Mojave)

- Combo InjectATI, no WEG:
=> Black screen High Sierra, Yellow screen Mojave

- WEG (radpg=15) + Combo InjectATI:
=> Full QI/CE (both High Sierra & Mojave), no HDMI Audio

- WEG (radpg=15) + Combo InjectATI + Combo Connector Patch + HDMIAudio.kext:
=> Full QI/CE (both High Sierra & Mojave), working HDMI Audio on High Sierra, no HDMI audio on Mojave

- WEG (radpg=15) + Combo Inject ATI + Combo Connector Patch, no HDMIAudio.kext:
=> Mojave still no audio

I've tried all other combining ways but Mojave still no HDMI Audio

So is there any bro who can please help me for this HDMI Audio? I really need this because my chassis case only have AC'97 front audio jack which isn't supported by MacOS
 
Joined
Nov 9, 2012
Messages
10
Motherboard
ASUS GA-H77N-WIFI
CPU
I5-3570
Graphics
SAPPHIRE HD 6570
Mobile Phone
Other
- WEG (radpg=15) + Combo InjectATI:
=> Full QI/CE (both High Sierra & Mojave), no HDMI Audio
Hello, Mr Phan,
I have a AMD graphic card HD7730, No QI/CE graphic accelerator after 10.13.3,
Could you kindly teach me how to made it work using the Combo InjectATI method,
Thank you in advance.
 
Joined
Aug 4, 2013
Messages
5
Motherboard
MSI B85M-E45
CPU
i5-4460
Graphics
HD 7730
Is there anyone can help me with this problem ? :(

Hello, Mr Phan,
Could you kindly teach me how to made it work using the Combo InjectATI method
ACPI: FixDisplay=true
Devices: FakeID ATI=0x68391002
Graphics: FBName=Dashimaki, InjectATI=true

Kexts: Lilu + WhateverGreen
Add Boot Args: -lilubeta -wegbeta radpg=15
 
Joined
Nov 9, 2012
Messages
10
Motherboard
ASUS GA-H77N-WIFI
CPU
I5-3570
Graphics
SAPPHIRE HD 6570
Mobile Phone
Other
Thank you Mr Phan
 
Joined
Jun 23, 2015
Messages
1
Motherboard
GA-H81M-DS2
CPU
G3460
Graphics
HD 7730
Mac
iMac
Mobile Phone
Other
Hello Mr Phan!
I tried it this way but it's still 7mb.

"ACPI: FixDisplay=true
Devices: FakeID ATI=0x68391002
Graphics: FBName=Dashimaki, InjectATI=true

Kexts: Lilu + WhateverGreen
Add Boot Args: -lilubeta -wegbeta radpg=15"

Can you help me. Thank you very much.
We can speak Vietnamese
 

Attachments

Last edited:
Top