Contribute
Register

Mojave airplay problem and slow boot.

Joined
Oct 6, 2015
Messages
20
Motherboard
GA-H110ms2
CPU
i3-7100
Graphics
GTX 650
Mobile Phone
Android
First of all, I thank these folks at tonymacx86 I've been able to Install Mac OS on my PC( especially Rehabman for his amazing guides and tools)

My Problem,
I've followed several guides and able to install Sierra successfully everything was working including Airplay, QE/CI, quick-sync , audio etc. This week I've installed Mojave in a different partition keeping the sierra install alone, boot was slow on Mojave like sierra boots in 42 seconds but Mojave takes 1 minute 30 seconds, also airplay is not working.
I am booting from the same Clover EFI on both Sierra and Mojave can some one point out what have I done wrong installing Mojave and how to improve boot times and get airplay to work.

Thanks.
 

Attachments

Joined
Oct 29, 2012
Messages
149
Motherboard
ASUS H61M-K
CPU
i5-2500
Graphics
GT 610
Mac
iMac
Mobile Phone
Android
Mojave's TRIM implementation on 3rd party SSDs causes this very slow boot. APFS has its own Trim, You can either disable Trim (not recommended) or convert to HFS+ and enable TRIM. At least that's what worked for me, first i created a backup using Carbon copy cloner then restored the backup with my SSD set as target location.
 
Joined
Oct 6, 2015
Messages
20
Motherboard
GA-H110ms2
CPU
i3-7100
Graphics
GTX 650
Mobile Phone
Android
I am running on a hard disk, I am using HFS on mojave. On Sierra airplay is working fine but on mojave airplay is not working there is no change in clover and kexts from Sierra to mojave can some one point to me how to get airplay working.
Thanks
Edit: cover - Clover.
 
Joined
Oct 6, 2015
Messages
20
Motherboard
GA-H110ms2
CPU
i3-7100
Graphics
GTX 650
Mobile Phone
Android
Mojave's TRIM implementation on 3rd party SSDs causes this very slow boot. APFS has its own Trim, You can either disable Trim (not recommended) or convert to HFS+ and enable TRIM. At least that's what worked for me, first i created a backup using Carbon copy cloner then restored the backup with my SSD set as target location.
Thanks for reply, I am using HDD not SSD and I am using HFS.
 
Joined
Oct 6, 2015
Messages
20
Motherboard
GA-H110ms2
CPU
i3-7100
Graphics
GTX 650
Mobile Phone
Android
Try making the following change to your config.plist:
View attachment 365101
Thanks for being so helpful, Sorry that I bothered you and wasted your precious
time.
The thing is me being an idiot or I didn't know where to look, the thing is in versions after Sierra airplay in menu bar shows only if the Apple TV is turned on and connected to the same network, whereas in Sierra the airplay icon in menubar showed even if no device capable of AIRPLAY is in the network, so I thought the icon is not showing up in Mojave means airplay is not working. Today I connected and turned on airplay receiver and the icon magically appeared in menu bar.
Thanks for the help.

Any help how I can speed up my boot it is taking more than 1 minute 30 seconds at times in Mojave please help.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
11,742
Motherboard
Asus ROG Strix Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
Thanks for being so helpful, Sorry that I bothered you and wasted your precious
time.
The thing is me being an idiot or I didn't know where to look, the thing is in versions after Sierra airplay in menu bar shows only if the Apple TV is turned on and connected to the same network, whereas in Sierra the airplay icon in menubar showed even if no device capable of AIRPLAY is in the network, so I thought the icon is not showing up in Mojave means airplay is not working. Today I connected and turned on airplay receiver and the icon magically appeared in menu bar.
Thanks for the help.

Any help how I can speed up my boot it is taking more than 1 minute 30 seconds at times in Mojave please help.
I don't know what's causing the slow boot.
 
Joined
Oct 6, 2015
Messages
20
Motherboard
GA-H110ms2
CPU
i3-7100
Graphics
GTX 650
Mobile Phone
Android
Mac is getting stuck on Early boot complete continuing system boot for good 25 seconds why is it taking so much time to boot can anyone care to explain, Thanks.
 
Top