Contribute
Register

Mojave 10.14.4 Port Limit Removal Patch

Joined
Jul 29, 2016
Messages
49
Motherboard
ASUS MAXIMUS VII Formula
CPU
i7-4790K
Graphics
RX 580
Mac
iMac
sorry, didn't mean to be rude

in your config.plist:
Code:
<dict>
                <key>Comment</key>
                <string>change 15 port limit to 26 in XHCI kext (100-Series-10.12)</string>
                <key>Disabled</key>
                <false/>
                <key>Find</key>
                <data>
                g710////EA==
                </data>
                <key>InfoPlistPatch</key>
                <false/>
                <key>Name</key>
                <string>AppleUSBXHCIPCI</string>
                <key>Replace</key>
                <data>
                g710////Gw==
                </data>
            </dict>
under Disabled, it says false, you can change false to true which will disable that KextToPatch
thank you
 
Joined
Aug 25, 2018
Messages
3
Motherboard
Gigabyte Z370xp
CPU
i7-8700
Graphics
RX 580
Mac
iMac
Hi, I'm reaching out to you guys because I've been banging my head for 3 weeks now, trying to make my USB ports working since the upgrade to Mojave... yeah, one of the many "victims"... Basically, USBs are present but not working at full USB3 speed

Hardware:
Gigabyte Z370XP SLI (3 USB front, 6 USB3 back, excluded USB-C)
Intel Core i7-8700 Coffee Lake 6-Core 3.2 GHz
Sapphire 11265-01-20G Radeon Nitro+ RX 580 8GB
1T SSD M2 SATA
Clover 4630 (yeah I know it's a little dated but today's update to 4945 I tried crashed my computer, had to revert to 4630 through command line voodoo, a good thing I had a backup)

What I've done up to know:

Tried @RehabMan's guide for custom SSDT https://www.tonymacx86.com/threads/guide-creating-a-custom-ssdt-for-usbinjectall-kext.211311/: failed
Tried Google and found TechTies Ibrahim's guide youtube.com/watch?v=dFihvGaLmMQ: failed
Tried Google again and found Carl Mercier's guide youtube.com/watch?v=j3V7szXZZTc&list=WL&index=35&t=0s: failed

Since in either guides, it's mentioned that SS0x port will show when customizing, it's not happening: SS0x ports never show up in IORefExplorer after following steps and removing unused port SSDT-UIAC-ALL.dsl. I forced and SSDT-UIAC.aml config specifying HS0x and SS0x ports Had found, which on reboot caused land slide of all USB including my keyboard and mouse (had to revert to command line voodoo again to remove the custom SSDT in Clover with my High Sierra USB boot installer).

What works:
- PMHeart's 10.14.4 patch
or
- Combination of USBInjectall and manual uai exclude HS0x ports in Clover Configurator tool


BUT: USB3 Ports with USB3 devices are working but not at full speed (stuck at 480 mb/s)

Thanks

Michel
 
Top